Nach Neustart keine Mails mehr verschickbar.

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
mptiga
Posts: 15
Joined: 2002-12-20 01:56
Location: Bad Vilbel

Nach Neustart keine Mails mehr verschickbar.

Post by mptiga » 2003-03-31 02:53

Hi!

Bin noch ziemlich neu dabei was Linux angeht und habe mir zum Experimentieren und Hosten einiger mehr oder weniger privaten Seiten einen Root Server bei Server4Free zugelegt.

Ich hatte das Problem, dass beim Senden von emails die Absenderzeile die im email-client eingestellt wird ignoriert wurde und stattdessen immer die e-mailadresse als Absender angezeigt wurde. Senden und Empfangen von emails funktionierte aber ansonsten tadellos.

Ich habe daraufhin mit yast2 ein Onlineupdate durchgeführt und nachdem sich immer noch nichts getan hat den Server neu gestartet.

Jetzt, nach dem Neustart kann ich keine emails mehr versenden (kann keine Verbindung mit dem Postausgangsserver (SMTP) herstellen).

So wie ich das sehe läuft da gar kein SMTP Dienst mehr. Wenn ich netstat -plt eingebe wird auf jeden Fall nichts smtp-mäßiges aufgelistet und das sollte es doch oder?

Wenn ich versuche eine mail über die Komandozeile zu verschicken bekomme ich folgende Meldung:

Code: Select all

 /etc/sendmail.cf: line 71: readcf: DontBlameSendmail option: GroupReadableSASLFile unrecognized
Warning: Option: AuthMechanisms requires SASL support (-DSASL)
Weiss jemand was das sein kann? Was muß ich checken (Logfiles, Konfigurationsdateien, etc.) um dem Problem auf die Spur zu kommen.

Vielen Dank schonmal im Voraus!
Gruß mptiga

mptiga
Posts: 15
Joined: 2002-12-20 01:56
Location: Bad Vilbel

Re: Nach Neustart keine Mails mehr verschickbar.

Post by mptiga » 2003-03-31 19:58

Hallo,
ich habe jetzt einfach mal in der Datei /etc/sendmail.cf die Zeile

Code: Select all

O DontBlameSendmail=AssumeSafeChown,TrustStickyBit,GroupReadableSASLFile
auskommentiert und siehe da, ich kann wieder emails verschicken. Das heisst dann wohl, dass sich bei der neuen sendmail Version in diesem Konfigurationsfile etwas geändert hat oder?

Wäre super wenn mir jemand sagen könnte was ich da jetzt überhaupt auskommentiert habe. Ist nämlich schon ein mulmiges Gefühl so ... :?

Als Beschreibung in sendmail.cf steht folgendes:

Code: Select all

# override file safeties - setting this option compromises system security,
# addressing the actual file configuration problem is preferred
# need to set this before any file actions are encountered in the cf file
... werde ich nicht ganz schlau draus...

Das erste Problem (dass der Absendername beim Versenden von mails ignoriert wird (es wird nur die email Adresse angezeigt)) existiert leider immer noch. Hat da nicht irgendjemand eine Idee?

Danke!
mptiga

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Nach Neustart keine Mails mehr verschickbar.

Post by dodolin » 2003-03-31 20:53

Code: Select all

O DontBlameSendmail=AssumeSafeChown,TrustStickyBit,GroupReadableSASLFile
Das heisst soviel wie: "Eigentlich" sollte das SASLFile nicht GroupReadable sein (ls -l file), da dort unter Umständen sensitive Informationen (Passwörter, ...) stehen können. Mit dieser Option meckert dein Sendmail die falschen Recht an der Datei nicht mehr an. Die Doku sagt dazu allerdings, dass man das nur tun sollte, wenn man weiss, was man tut und es eigentlich besser wäre, man würde einfach die Permissions der entsprechenden Dateien fixen.
Das erste Problem (dass der Absendername beim Versenden von mails ignoriert wird (es wird nur die email Adresse angezeigt)) existiert leider immer noch. Hat da nicht irgendjemand eine Idee?
Sorry, mir ist noch nicht ganz klar, was du meinst. Hast du mal einen Beispiel Header und kannst daran beschreiben, was du gerne anders hättest? Was sagen die Logfiles dazu?

mptiga
Posts: 15
Joined: 2002-12-20 01:56
Location: Bad Vilbel

Re: Nach Neustart keine Mails mehr verschickbar.

Post by mptiga » 2003-03-31 21:36

Hi!
Mit dieser Option meckert dein Sendmail die falschen Recht an der Datei nicht mehr an.
aber bei mir hat er gemeckert als diese Option aktiviert war. Nachdem ich es auskommentiert habe funktioniert es alles...hmmm.. wo finde ich denn diese SASLFile?


zu dem 2.Problem:

Normalerweise wird beim Empfangen von emails z.B. über Outlook der Name des Absenders angezeigt (wenn von ihm angegeben). Wenn ich über meinen s4f emails versende (über Outlook) wird mein Name beim Empfänger nicht angezeigt (obwohl in den Kontoeinstellungen angegeben ist und es vorher auch mit denselben Einstellungen funktioniert hat), es steht nur die email Adresse da. Wenn ich über meinen GMX Account sende dann tritt das Problem nicht auf. Es scheint also wohl nicht an Outlook sondern am Server zu liegen.

Hier mal ein Header so einer email:

Code: Select all

Return-Path: <xxxx@yyy.de>
X-Flags: 0000
Delivered-To: GMX delivery to xxxx@gmx.net
Received: (qmail 2867 invoked by uid 65534); 31 Mar 2003 19:20:30 -0000
Received: from yyy.server4free.de (EHLO yyy.server4free.de) (217.172.xxx.xxx)
  by mx0.gmx.net (mx002-rz3) with SMTP; 31 Mar 2003 21:20:30 +0200
Received: from xxx (xxx.dip0.t-ipconnect.de [80.128.xxx.xxx])
	by yyy.server4free.de (8.11.3/8.11.3/SuSE Linux 8.11.1-0.5) with ESMTP id h2VIavH02382
	for <xxxx@gmx.net>; Mon, 31 Mar 2003 20:36:57 +0200
From: xxxx@yyy.de
To: <yyyy@gmx.net>
Subject: Test
Date: Mon, 31 Mar 2003 21:18:20 +0200
Message-ID: <000001c2f7ba$4afd7ee0$0300a8c0@silencio>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook, Build 10.0.2616
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
X-GMX-Antivirus: -1 (not scanned, may not use virus scanner)
Eigentlich sollte da irgendwo mein Name als Absender stehen :(

Finde ich schon irgendwie strange.

mptiga
Posts: 15
Joined: 2002-12-20 01:56
Location: Bad Vilbel

Re: Nach Neustart keine Mails mehr verschickbar.

Post by mptiga » 2003-03-31 21:44

So sollte das eigentlich aussehen:

Code: Select all

From: "Mein Name" <meine@adresse.de>
in /var/log/mail

kann ich nichts auffälliges finden. (Ist das das richtige Logfile?)

Danke!
mptiga

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Nach Neustart keine Mails mehr verschickbar.

Post by dodolin » 2003-03-31 22:27

Sorry, aber im From: Header wird kein anständiger MTA dieser Welt etwas herumpfuschen. Das wird wohl schon an deinem Outlook liegen... :wink:
Wenn du es nicht glaubst, probiere es doch mal "per Hand" mit telnet.

mptiga
Posts: 15
Joined: 2002-12-20 01:56
Location: Bad Vilbel

Re: Nach Neustart keine Mails mehr verschickbar.

Post by mptiga » 2003-03-31 22:59

dodolin wrote:Das wird wohl schon an deinem Outlook liegen... :wink:
Hab es gerade mal am anderen Rechner mit OE probiert. Und du hast Recht, es klappt :oops:

Nur komisch, das Outlook das nur mit Accounts macht die auf meinem Server liegen, habe sogar alle Konten nochmal neu eingerichtet.

Werde es nachher nochmal mit einem anderen Outlook Rechner probieren. Aber das Problem ist hier dann wohl doch etwas fehl am Platze... :wink:

Vielen Dank auf jeden Fall für die schnelle Hilfe!

Gruß
mptiga