POP3 weist Kennwort zurück

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
greatreaper
Posts: 12
Joined: 2002-12-08 00:02

POP3 weist Kennwort zurück

Post by greatreaper » 2003-01-13 17:32

Hi all!

Ich verwende einen Rootserver L von 1&1. An der eMail-Konfiguration habe ich nichts weiter geändert, als smtp_auth einzurichten.

Nundenn, alles läuft seit Tagen ohne Fehler. Nachdem ich heute ein Online-Update mit Yast2 durchgeführt habe, weist der POP3-Server die Kennwörter von jedem User zurück.

Code: Select all

Mon 2003-01-13 17:16:15: [668:459] +OK p15112xxx Cyrus POP3 v2.0.16 server ready
Mon 2003-01-13 17:16:15: [668:459] USER web1p5
Mon 2003-01-13 17:16:15: [668:459] +OK Name is a valid mailbox
Mon 2003-01-13 17:16:15: [668:459] PASS ******
Mon 2003-01-13 17:16:18: [668:459] -ERR Invalid login
Mon 2003-01-13 17:16:18: [668:459] QUIT
Außerdem ist mir aufgefallen, dass nun als Dienst nicht nur "pop3", sondern auch "pop3s" läuft.

Hat jemand einen Rat????

Marc :?

greatreaper
Posts: 12
Joined: 2002-12-08 00:02

Re: POP3 weist Kennwort zurück

Post by greatreaper » 2003-01-13 18:13

Vielleicht hilft ja auch diese Meldung.

/var/log/messages

Code: Select all

Jan 13 17:51:02 p15112xxx pop3d[649]: accepted connection
Jan 13 17:51:02 p15112xxx master[664]: about to exec /usr/cyrus/bin/pop3d
Jan 13 17:51:02 p15112xxx service-pop3[664]: executed
Jan 13 17:51:02 p15112xxx pop3d[664]: unable to open Berkeley db /etc/sasldb: No such file or directory
Jan 13 17:51:02 p15112xxx pop3d[664]: unable to open Berkeley db /etc/sasldb: No such file or directory
Habe schon mit dem Support telefoniert....KEINE AHNUNG....Man hat mich auf Google verwiesen :evil:

mastahcyman
Posts: 66
Joined: 2003-01-13 13:46
Location: München

langsam wird's komisch

Post by mastahcyman » 2003-01-13 18:23

ich hab' jetzt gerade das gleiche problem bekommen.
Mein ProFTP hat sich gestern auf mysteriöse art verabschiedet, jetzt läuft er wieder -> inetd hat sich aus dem staub gemacht gehabt;
jetzt geht aber der POP3 genauso wie bei dir nicht.

ich habe auch alle einstellungen wie du überprüft, aber ich finde ums ver****** keine lösung.

Meine Fehlermeldung ist:
der befehl PASS schlug fehl. ...antwort: invalid login.

So langsam wäre das schon interessant, was da los ist; vor 20 min hatter prima gefunzt, und jetzt nachdem inetd gestartet ist, geht's wieder nicht...

hoffentlich kommt ein profi vorbei :?:

greatreaper
Posts: 12
Joined: 2002-12-08 00:02

Re: POP3 weist Kennwort zurück

Post by greatreaper » 2003-01-13 18:26

:evil: :evil: ...und scheinbar sind wir nicht alleine.....grumpf

http://www.rootforum.de/forum/viewtopic.php?t=6212

mastahcyman
Posts: 66
Joined: 2003-01-13 13:46
Location: München

Re: POP3 weist Kennwort zurück

Post by mastahcyman » 2003-01-13 18:38

ähm ja, also jetzt erschrick nicht, aber des letzte mal hab ich nach 2 tagen aufgegeben und einen reset beantragt :cry:

sendmail-tls lässt sich ja auch ohne weiteres neu installieren, gemäß der anleitung von 1 & 1. der start funzt auch prima, nur dann...

sendmail selbst hab ich jetzt einfach auch nommal getestet, es liegt am Befehl PASS :twisted: [/b]

greatreaper
Posts: 12
Joined: 2002-12-08 00:02

Re: POP3 weist Kennwort zurück

Post by greatreaper » 2003-01-13 18:44

Hmm, son Sch....

Einen Reset will ich unbedingt vermeiden. Wäre es jetzt nicht klug, auf Postfix umzusteigen? Oder kommt Confixx damit nicht zurecht?

Naja, hoffentlich findet sich noch jemand mit DER Lösung :?: :arrow: :idea: :!:

mastahcyman
Posts: 66
Joined: 2003-01-13 13:46
Location: München

Re: POP3 weist Kennwort zurück

Post by mastahcyman » 2003-01-13 18:47

hehe, ich hab doch bei mir die email-notification drinn, an eine addresse, die ich im moment eigenltich gar nicht abrufen kann :oops:

also jetzt bin ich sprachlos, wenn ich selber versuche mich einzuloggen, dann geht's net, sobald ich aber outlook arbeiten lasse, funzt's

mastahcyman
Posts: 66
Joined: 2003-01-13 13:46
Location: München

Re: POP3 weist Kennwort zurück

Post by mastahcyman » 2003-01-13 18:50

habe gerade noch ein wenig geblättert:
ja, laut admin-handbuch kommt confixx mit postfix zurecht

hab da noch einen link:
http://sdb.suse.de/de/sdb/html/fetchmail_null.html

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: POP3 weist Kennwort zurück

Post by flo » 2003-01-13 20:20

Code: Select all

Mon 2003-01-13 17:16:15: [668:459] +OK p15112xxx Cyrus POP3 v2.0.16 server ready 
Wer lesen und suchen kann ist klar im Vorteil.

1) Beim Rootserver Standardinstall - und auf jeden Fall bei SuSE - ist kein Cyrus installiert und laufen tut er erst recht nicht, sonst hätte ich mir die drei Stunden manuelle Konfig bei mir sparen können. ;-)

2) Ich schätz, Du hast ein YOU gemacht, der hat Deinen imap oder popper durch Cyrus ersetzt, der benutzt aber eine andere Authentifizierung, nämlcih die sasldb.

3) http://www.rootforum.org/forum/viewtopi ... highlight=

4) http://www.rootforum.org/forum/viewtopi ... highlight=

5) Außer der Tatsache, daß man ein Kennwort eingeben muß und gegebenenfalls die Authentifizierung gegen die shadow-Datenbank funktioniert, hat SMTP AUTH verdammt wenig mit Mails abholen zu tun. SMTP=Mail senden POP3/IMAP4=Mail abholen

6) Der Rest mit Fetchmail und was weiß ich noch allem ist stochern im dicken Nebel - auch dazu einen Link:
http://www.rootforum.org/forum/viewtopic.php?t=5248



Grüße,

flo.

greatreaper
Posts: 12
Joined: 2002-12-08 00:02

Re: POP3 weist Kennwort zurück

Post by greatreaper » 2003-01-13 20:41

flo wrote:Wer lesen und suchen kann ist klar im Vorteil.
:lol: Jau, du hast ja sooooo Recht!!!

Während du vermutlich die Antwort geschrieben hast, bin ich fündig geworden <g>. Und ja, ich hab´s wieder hinbekommen. :-D

Trotzdem VIELEN DANK für die Antworten und Anteilnahme :lol:

Bis dahin,

Marc

mastahcyman
Posts: 66
Joined: 2003-01-13 13:46
Location: München

ich schäm mich ja auch schon

Post by mastahcyman » 2003-01-13 21:44

:roll: ich hab's auch wieder hinbekommen ...

danke für die mehr als umfangreiche hilfe :wink: