Windows auf Xen unter Lenny; nur ohne Netzwerk

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
smur
RSAC
Posts: 169
Joined: 2003-05-26 16:00
Location: Mannheim

Windows auf Xen unter Lenny; nur ohne Netzwerk

Post by smur » 2009-06-25 16:14

Hallo,

ich habe Xen unter Lenny eingerichtet. Das System ist ein Core2Duo mit VT Support und ausreichend Ram. Xen-3.2-1 setze ich ein. Linux domUs funktionieren einwandfrei, Windows bekomme ich jedoch ausschließlich ohne Netzwerk zum Starten. Sobald in der win.cfg eine 'vif' Konfiguration aktiviert ist, startet das System nicht und eine Verbindung via VNC ist auch nicht möglich. xm list bestätigt dies:

Code: Select all

Name                                        ID   Mem VCPUs      State   Time(s)
win                                         14   512     1     ------      0.0



(Auffällige) Fehlermeldungen gibt es keine. Hier meine Windows-config:

Code: Select all

import os, re
arch = os.uname()[4]
if re.search('64', arch):
    arch_libdir = 'lib64'
else:
    arch_libdir = 'lib'

kernel      =   '/usr/lib/xen-3.2-1/boot/hvmloader'
builder     =   'hvm'
memory      =   '512'
vcpus       =   1
vnc = 1
vncviewer = 1
device_model = '/usr/lib/xen-3.2-1/bin/qemu-dm'
vif = [ 'bridge=xenbr0' ]
disk        =   [
                    'file:/DISK/windisk.img,ioemu:hda,w',
                    'file:/DATA/en_winxp_pro_with_sp2.iso,ioemu:hdc:cdrom,r'
                ]
name        =   'win'
on_poweroff =   'destroy'
on_reboot   =   'restart'
on_crash    =   'restart'
#vif         =   [
#                    'ip=192.168.0.200,mac=00:16:3E:C0:06:44,bridge=xenbr0',
#                ]
#vif = ['type=ioemu, bridge=xenbr0']
#vif = ['mac=00:16:3E:C0:06:33']
boot        =   'c'
vnc         =   1
vncviewer   =   1
sdl         =   0
usbdevice = 'tablet'
acpi = 1
apic = 1
pae = 0


Welchen 'vif'-Block ich dabei verwende spielt keine Rolle, keiner der aufgeführten führt zum Erfolg.
Getestet habe ich bereits mit eigenem 2.6.27 Dom0 Kernel als auch mit dem standard Lenny Kernel.


Ich hoffe auf hilfreiche Tips.


Danke & Grüße,
Nico

miete-server.de
Anbieter
Posts: 2
Joined: 2009-09-02 15:06

Re: Windows auf Xen unter Lenny; nur ohne Netzwerk

Post by miete-server.de » 2009-09-11 19:14

Hi Nico,

lässt sich Wind. vServer wenigstens anpingen ???

Gruß
Stan

smur
RSAC
Posts: 169
Joined: 2003-05-26 16:00
Location: Mannheim

Re: Windows auf Xen unter Lenny; nur ohne Netzwerk

Post by smur » 2009-09-11 19:41

Schau mal aufs Datum.

papabaer
Userprojekt
Userprojekt
Posts: 170
Joined: 2009-05-14 17:40
Location: Halle (Saale)

Re: Windows auf Xen unter Lenny; nur ohne Netzwerk

Post by papabaer » 2009-09-12 00:16

Wenn du seit dem ne Lösung gefunden hast, dann sei doch so nett und lass Andere an deiner Erkenntnis teilhaben :)

smur
RSAC
Posts: 169
Joined: 2003-05-26 16:00
Location: Mannheim

Re: Windows auf Xen unter Lenny; nur ohne Netzwerk

Post by smur » 2009-09-12 03:02

Die Lösung heißt: CentOS benutzen :-)