Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
sd
Posts: 14
Joined: 2006-01-25 11:35

Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-25 11:52

Hallo,

zu meinem Hintergrund: Wir haben einen SLES Server und benutzen OX als Mailsystem.

Ich bin gerade dabei, Amavis und SpamAssassin zu konfigurieren. Amavis scheint mit den individuellen Anpassungen zu laufen.
Wenn ich allerdings Einträge in die Postfix master.cf und main.cf vornehme, damit die mails erst dort durch geleitet werden, schieße ich mir dabei offensichtlich den SMTP ab, denn dann können keine e-mails mehr versendet werden ...

Ich habe verschiedene Tutorien im Netz zu dem Thema studiert und Postfix-Einstellungen, die ich dort zum Thema amavis (amavisd-new natürlich) gefunden habe versucht...

Hat jemand auf Anhieb einen Anstoß woran genau das liegen könnte?

theton
Posts: 31
Joined: 2006-01-24 11:56
Location: Berlin

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by theton » 2006-01-25 12:26

Nun, es ist schwierig genaueres zu sagen, wenn du uns keine Fehlermeldungen gibst. Warum stuerzt denn der Postfix-SMTP ab?

Normalerweise reichen naemlich einige wenige Eintraege in der main.cf und der master.cf um den amavisd richtig in Postfix einzubinden, sprich dafuer zu sorgen, dass Postfix Emails an Amavis reicht, bevor diese zugestellt werden:

master.cf

Code: Select all

smtp-amavis unix -      -       n       -       2       smtp 
   -o smtp_data_done_timeout=1200
   -o smtp_send_xforward_command=yes
   -o disable_dns_lookups=yes
   -o max_use=100
127.0.0.1:10025 inet n  -       n       -       -  smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_delay_reject=no
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks_style=host
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o smtpd_error_sleep_time=0
    -o smtpd_soft_error_limit=1001
    -o smtpd_hard_error_limit=1000
    -o smtpd_client_connection_count_limit=0
    -o smtpd_client_connection_rate_limit=0
    -o receive_override_options=no_header_body_checks,no_unknown_recipient_checks
main.cf

Code: Select all

content_filter=smtp-amavis:[127.0.0.1]:10024
Voraussetzung ist natuerlich, dass du bei einem 'telnet localhost 10024' die Meldung "220 [127.0.0.1] ESMTP amavisd-new service ready" bekommst, denn erst dann laeuft dein amavisd auch richtig.

Nachtrag: Schau vor allem in /var/log/mail.log, welche Fehler dort stehen.

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-25 15:39

Jau, so ähnlich sah das bei mir auch aus. Telnet hatte auch geklappt.
Die genau(en) Fehlermeldung(en) weiß ich nicht mehr, es war allerdings so, dass der SMTP nach den Einträgen nicht mehr funktionierte. Sprich kein User konnte mehr mails versenden ... im Ox-Webmail-Tool tauchte irgendwas in der Richtung "Connection refused" und/oder "failed connecting smtp" etc. auf .... sehr seltsam ...

Eine weitere Frage: Wie setze ich die "tag level" in der amavisd.conf am sinnvollsten? Ich habe da im Netz stark voneinander abweichende Werte gesehen ...

theton
Posts: 31
Joined: 2006-01-24 11:56
Location: Berlin

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by theton » 2006-01-25 16:07

Das kommt darauf an, wie strikt du Spam als solchen behandeln willst also ab welcher Stufe eine Mail als Spam behandelt werden soll. Fuer einen stark benutzten Server mit Usern, die mir nicht im einzelnen bekannt sind (also ein public Mailserver) benutze ich folgende Werte sehr erfolgreich:

Code: Select all

$sa_tag_level_deflt  = 2.0;  # add spam info headers if at, or above that level
$sa_tag2_level_deflt = 6.31; # add 'spam detected' headers at that level
$sa_kill_level_deflt = 6.31; # triggers spam evasive actions
$sa_dsn_cutoff_level = 9;    # spam level beyond which a DSN is not sent
Das laesst zwar teilweise noch Spam durch, stellt aber auch sicher, dass der User alle seine Emails bekommt.

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-27 12:22

Im mail-log taucht folgende Fehlermeldung auf, wenn der Postfix mit den Amavis-Ã?nderungen neu gestartet wurde:

postfix/master[31740]:
fatal: /etc/postfix/master.cf: line 133: bad transport type: smtp_data_done_timeout=1200

Währenddessen können User wie gesagt keine mails versenden; es taucht ein "undefinierbarer Fehler" auf, der nicht mehr mit dem smtp verbinden lässt.

Ich stehe gerade irgendwie auf dem Schlauch ...

theton
Posts: 31
Joined: 2006-01-24 11:56
Location: Berlin

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by theton » 2006-01-27 12:28

Sieht sehr nach einem Syntax-Fehler in deiner Konfiguration aus. Kannst du mal die master.cf posten?

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-27 12:33

Haha, ich hatte Deine Einträge oben ge-copy-und-pastet. :oops:

theton
Posts: 31
Joined: 2006-01-24 11:56
Location: Berlin

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by theton » 2006-01-27 12:37

Dann hast du wohl eine Zeile vergessen oder das ganze in der master.cf an die falsche Stelle gesetzt. :)

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-27 12:42

Ersteres bestimmt nicht, und was zweiteres betrifft: Wo setz ich das denn hin?

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-27 13:56

So, ich hab's jetzt noch mal probiert. Ich sehe nicht, wo in den Konfigurationsdateien ein Fehler sein könnte.
Fehler in der Mail-Log wenn ich postfix mit den Amavis-Eträgen starte sehen u.a. wie folgt aus:

postfix/postfix-script: starting the Postfix mail system
postfix/master[3910]: fatal: /etc/postfix/master.cf: line 106: bad transport type: smtp_data_done_timeout=1200
postfix/postfix-script: starting the Postfix mail system
postfix/master[4084]: daemon started -- version 2.1.1

postfix/qmgr[4097]: warning: connect to transport smtp-amavis: Connection refused
postfix/qmgr[4097]: warning: connect to transport smtp-amavis: Connection refused

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by Roger Wilco » 2006-01-27 17:04

SD wrote:postfix/master[3910]: fatal: /etc/postfix/master.cf: line 106: bad transport type: smtp_data_done_timeout=1200
Da fehlen mit Sicherheit Leerzeichen am Zeilenanfang...

theton
Posts: 31
Joined: 2006-01-24 11:56
Location: Berlin

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by theton » 2006-01-27 18:41

Das wuerde ich auch sagen, waere aber einfacher zu analysieren, wenn wir die master.cf mal sehen koennten.

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-31 08:51

So, ich habe gerade noch mal was ausprobiert.
Im Orginal sieht meine master.cf SO aus:
# ==========================================================================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ==========================================================================
smtp inet n - n - - smtpd
#smtps inet n - n - - smtpd -o smtpd_tls_wrappermode=yes
# -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n - n - - smtpd
# -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628 inet n - n - - qmqpd
pickup fifo n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - n 300 1 nqmgr
#tlsmgr fifo - - n 300 1 tlsmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - n - - smtp
relay unix - - n - - smtp
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - n - - showq
error unix - - n - - error
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
#localhost:10025 inet n - n - - smtpd -o content_filter=

[X]

#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus unix - n n - - pipe
user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
vscan unix - n n - 10 pipe
user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
procmail unix - n n - - pipe
flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}

###### SPAMASSASIN #####
#spamassassin unix - n n - - pipe user=nobody argv=/usr/bin/spamc -f -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}

[X] - an diese Stelle setze ich die Einträge für Amavis. Also so was wie hier im Thread schon mal besprochen. Natürlich noch der Eintrag in der main.cf unten dran, aber der ist definitiv syntaktisch richtig. Wenn ich dann postfix restarte, läuft der smtp nicht mehr und es tauchen in der mail.log immer wieder andere Fehler betreffend der besagten Neu-Einträge auf. Letztes mal sah es so aus:
postfix/postfix-script: starting the Postfix mail system
postfix/master[21798]: fatal: /etc/postfix/master.cf: line 129: bad transport type: -o
postfix/postfix-script: starting the Postfix mail system
postfix/master[21954]: daemon started -- version 2.1.1

postfix/qmgr[21967]: warning: connect to transport smtp-amavis: Connection refused
Hier ist es jetzt "-o", neulich beschwerte er sich (wie weiter oben angegeben) auch mal über einen ganzen Ausdruck ...

Brauche Hilfe!!!!! :wink:

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-31 09:17

Es gibt noch 'ne alternative Möglichkeit: Ich kann im OX Spamassasin aktivieren. Wenn ich dann in die master.cf gucke, steht beim obestern smtp-Eintrag zusätzlich "-o content_filter=spamassasin".

Wie (und in welchen Dateien) konfiguriere ich den SpamAssassin, dass der mir so einen "***Spam***"-Eintrag ins Subject haut, ohne dass ich erst über Amavis gehen muss und weitere Einträge in postfix vornehmen muss?
Nach dem, was ich im Netz dazu gefunden habe, müsste das eigentlich möglich sein, ich stehe aber auf dem Schlauch, was ich da am sinnvollsten mache. [/i]

theton
Posts: 31
Joined: 2006-01-24 11:56
Location: Berlin

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by theton » 2006-01-31 11:33

/etc/amavisd.conf <- fuer amavis
/etc/mail/spamassassin/* <- fuer den Spamfilter

sd
Posts: 14
Joined: 2006-01-25 11:35

Re: Postfix-Konfiguration, Amavis - SMTP will nicht mehr

Post by sd » 2006-01-31 12:08

Jetzt stehe ich vor der nächsten Hürde, denn in der local.cf steht nicht mehr als
# Add your own customisations to this file. See 'man Mail::SpamAssassin::Conf'
# for details of what can be tweaked.
#


# rewrite the Subject: line with ****SPAM**** .* if set to 1 (default=1)
rewrite_subject 1
# report briefly, recommended for report_header==1 (default=0)
use_terse_report 1
was im Prinzip ja nicht weiter schlimm ist, denn das würde mir erst mal reichen; bisher ist aber noch keine mail so angekommen.

Wo kann ich bei SpamAssassin wie bei Amavis tag level definieren oder so was?