exim á la debianhowto & spamassassin problem

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
lines
Posts: 55
Joined: 2002-10-05 20:38

exim á la debianhowto & spamassassin problem

Post by lines » 2004-09-25 15:42

hallo

ich habe exim4 laut debianhowto.de installiert.
funzt auch alles reibungslos.
bin echt von exim und seinen Konfigurationsmöglichkeiten begeistert,
wenn auch die routers und transports doch etwas verwirren.

Leider habe ich aber noch nicht geschaft das spammails welche die max. Spampunkte
erreicht haben nicht in :blackhole: landen sondern in einen Spamfolder verschoben werden.
das gleiche auch mit viren.

muss ich da den weg über procmail gehen, oder kann da exim auch?

Zudem umschreibt mir spamassassin nicht den Subject, obwohl alles
in /etc/spamassassin/local.cf eingetragen ist, und auch die richtigen Rechte hat.

Oder muss ich da in der vexim-acl-check-content.conf schrauben?


danke.lines

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: exim á la debianhowto & spamassassin problem

Post by dodolin » 2004-09-25 17:08

Zudem umschreibt mir spamassassin nicht den Subject, obwohl alles
in /etc/spamassassin/local.cf eingetragen ist, und auch die richtigen Rechte hat.
Normales Verhalten.
Mit exiscan werden die Mails nicht "durch" SA geleitet, er hat also keine Möglichkeit, die Mails umzuschreiben. Was du diesbezüglich in der SA-Conf einträgst, ist also irrelevant.
Oder muss ich da in der vexim-acl-check-content.conf schrauben?
Ja.

http://duncanthrax.net/exiscan-acl/exis ... amples.txt
Punkt 3.

lines
Posts: 55
Joined: 2002-10-05 20:38

Re: exim á la debianhowto & spamassassin problem

Post by lines » 2004-09-25 18:07

hi


also ich wüsste nicht wo ich das einfügen sollte:

In the system filter, put this:
/* -----------------
if "${if def:header_X-New-Subject: {there}}" is there
then
headers remove Subject
headers add "Subject: $h_X-New-Subject:"
headers remove X-New-Subject
endif
------------------ */

also bei mir gibts es keine system filters.
ich habe es an ein paar stellen probiert, wo ich es für ok hielt,
war aber dennoch nicht so.
exim startete nicht wegen syntax error.

.lines

lines
Posts: 55
Joined: 2002-10-05 20:38

Re: exim á la debianhowto & spamassassin problem

Post by lines » 2004-09-25 18:41

also war ich wieder mal voreilig :))

Lösung:

man muss ein File anlegen:

/etc/exim4/exim_system_filter.conf

folgendes in die mainconf einfügen:

system_filter = /etc/exim4/exim_system_filter.conf
system_filter_user = Debian-exim


und das auskommentieren:

allow_filter

dann klappts auch.


aber gibt es denn eine Lösung das die Mails in ein Spam Ordner landen ?

.lines

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: exim á la debianhowto & spamassassin problem

Post by dodolin » 2004-09-25 20:05

aber gibt es denn eine Lösung das die Mails in ein Spam Ordner landen ?
Dazu gibts nen Eintrag im Wiki:
http://silverwraith.com/cgi-bin/wiki.pl/Filtering_Spam

Aber im IRC hatte jemand berichtet, dass das angeblich so nicht funktionieren würde. Du kannst es ja als Start nehmen und dann selbst umbauen, bis es passt. Ich selbst habe sowas noch nicht getestet oder benötigt, wenn du aber etwas funktionierendes hast, wäre es nett, wenn du das mal hier postest. :)

lines
Posts: 55
Joined: 2002-10-05 20:38

Re: exim á la debianhowto & spamassassin problem

Post by lines » 2004-09-25 20:52

hi
Ich selbst habe sowas noch nicht getestet oder benötigt, wenn du aber etwas funktionierendes hast, wäre es nett, wenn du das mal hier postest.
aber klar, mach ich doch immer... :))

aber das vorrige Problem habe ich iergendwie noch immer nicht behoben.
das mit dem Subject rewrite funzt nun, aber er umschreibt mir jetzt jedes subject :)


obwohl ich auch das definiert habe:


Code: Select all

  headers_remove = ${if or { { <{$spam_score_int}{1} } 
                             { <{$spam_score_int}{${lookup mysql{select users.sa_tag * 10 from users,domains 
                               where localpart = '${quote_mysql:$local_part}' 
                               and domain = '${quote_mysql:$domain}' 
                               and users.on_spamassassin = 1 
                               and users.domain_id=domains.domain_id}{$value}fail}} } 
                             { eq {0}{${lookup mysql{select users.sa_tag * 10 from users,domains 
                               where localpart = '${quote_mysql:$local_part}' 
                               and domain = '${quote_mysql:$domain}' 
                               and users.on_spamassassin = 0 
                               and users.domain_id=domains.domain_id}{$value}fail}}} 
                           } {X-Spam-Score:X-Spam-Report:X-New-Subject:} }
er löscht mir aber nicht den "X-New-Subject:" Tag und somit umschreibt der exim-Filter jedes Subject.

iergendeine Idee?

.lines

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: exim á la debianhowto & spamassassin problem

Post by dodolin » 2004-09-25 22:01

Ich kapier gerade das Problem nicht, ich fürchte, da fehlen noch irgendwelche weiteren Infos, damit ich's eventuell kapiere.

lines
Posts: 55
Joined: 2002-10-05 20:38

Spam im Spamfolder

Post by lines » 2004-10-03 13:47

also damit der Spam in den .Spam -Folder kommt muss man noch folgendes in der exim4.conf anlegen bzw. austauschen:

der ditch_spam Router sollte folgender massen aussehen:

Code: Select all

 ditch_spam:
   driver = redirect
   allow_fail
   file_transport = virtual_ditch
   data = ${lookup mysql{select concat(smtp,'/.Spam')  
               from users,domains  
               where localpart = '${quote_mysql:$local_part}'  
               and domain = '${quote_mysql:$domain}'  
               and domains.enabled = '1'  
               and users.enabled = '1'  
               and users.domain_id = domains.domain_id}}
   condition = ${if >{$spam_score_int}{${lookup mysql{select  
                 users.sa_refuse * 10 from users,domains  
                 where localpart = '${quote_mysql:$local_part}'  
                 and domain = '${quote_mysql:$domain}'  
                 and users.on_spamassassin = '1'  
                 and users.domain_id=domains.domain_id  
                 and users.sa_refuse > 0 }{$value}fail}} {yes}{no}}
   local_part_suffix = -*
   local_part_suffix_optional
   retry_use_local_part
und danach noch den Tansporter kreiren:

Code: Select all

 virtual_ditch:
   driver = appendfile
   envelope_to_add
   return_path_add
   mode = 0600
   maildir_format = true
   create_directory = true
   user = ${lookup mysql{select users.uid  from users,domains  
                 where localpart = '${quote_mysql:$local_part}'  
                 and domain = '${quote_mysql:$domain}'  
                 and users.domain_id = domains.domain_id}}
   group = ${lookup mysql{select users.gid from users,domains  
                 where localpart = '${quote_mysql:$local_part}'  
                 and domain = '${quote_mysql:$domain}'  
                 and users.domain_id = domains.domain_id}}
   maildir_use_size_file = false
somit lander der Spam nicht im :Blackhole: sondern in den
Folder.


.lines