xmail - eMail Versand scheitert

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
frankieboy
Posts: 7
Joined: 2004-07-08 15:19

xmail - eMail Versand scheitert

Post by frankieboy » 2004-09-02 15:26

Hallo Rooties,

seit ein paar Tagen versuche ich verzweifelt einen Mail-Server zu installieren und auf meinem Root-Server (Debian) im Internet nutzbar zu machen. Nachdem ich mit Exim, Postfix, Courier usw. überhaupt nicht klargekommen bin, habe ich jetzt xmail installiert und habe wenigstens einige Fortschritte erzielen können. So kann z.B. eMails von internen und externen Adressen empfangen (pop3) und sogar mit dem Client (Thunderbird) abrufen. POP3 klappt also :)

Etwas schwieriger gestaltet sich das ganze mit dem eMail-Versand (smtp). Mit meinem Thunderbird komme ich überhaupt nicht auf den Server. Die Fehlermeldung lautet:
Die Nachricht konnte nicht gesendet werden, weil keine Verbindung mit dem SMTP-Server SERVERNAME.de hergestellt werden konnte. Der Server ist entweder nicht verfügbar oder lehnt SMTP-Verbindungen ab. ...
Mit dem Telnet-Zugang klappt es hungegen. Ich kann sogar eMails an interne Adressen versenden. Der Versand an *externe* Adressen wird aber auch vom Telnet-Zugang verweigert.

Ich habe jetzt alles mögliche an Einstellungen ausprobiert, komme aber nicht wirklich weiter. Anders ausgedrückt bin ich mit meinem Latein Am Ende.

<gewinsel>Bitte helft.</gewinsel> Ihr solltet vielleicht noch wissen, daß ich mit meinem localen Client (Thunderbird) über eine dynamische IP mit dem Internet verbunden bin.

Hier noch die meiner Meinung nach wichtigen Dateiauszüge:
Datei "server.tab"

Code: Select all

"RootDomain"	"SERVERNAME.de"
"SmtpServerDomain"	"SERVERNAME.de"
"POP3Domain"	"SERVERNAME.de"
"HeloDomain"	"SERVERNAME.de"
"PostMaster"	"postmaster@SERVERNAME.de"
"ErrorsAdmin"	"postmaster@SERVERNAME.de"
"TempErrorsAdmin"	"postmaster@SERVERNAME.de"
"DefaultSMTPGateways"	"SERVERNAME.de"
"RemoveSpoolErrors"	"0"
#"DisableEmitAuthUser"	"1"
#"NotifyMsgLinesExtra"	"8"
#"NotifySendLogToSender"	"0"
"NotifyTryPattern"	"1"
#"MaxMTAOps"	"16"
#"ReceivedHdrType"	"0"
#"FetchHdrTags"	"+X-Deliver-To,+Received,To,Cc"
#"SmtpMsgIPBanSpammers"	"550 Denied due inclusion of your IP in our spam lists"
"SmtpMsgIPBanSpamAddress"	"550 Denied due inclusion of your email address in our spam lists"
"SmtpMsgIPBanMaps"	"550 Denied due inclusion of your IP in the following map"
"CustomSMTPMessage"	"Please open http://www.SERVERNAME.de/smtp_errors.html to get more information about this error"
#"MaxMessageSize"	"20000"
#"EnableAuthSMTP-POP3"	"0"
#"Pop3SyncErrorAccount"	"postmaster@SERVERNAME.de"
#"AllowNullSender"	"1"
#"AllowSmtpVRFY"	"1"
#"AllowSmtpETRN"	"1"
#"SmtpMinDiskSpace"	"100000"
#"SmtpMinVirtMemSpace"	"64000"
#"Pop3MinVirtMemSpace"	"64000"
#"CustMapsList"	"list.dsbl.org.:1,blackholes.mail-abuse.org.:1,dialups.mail-abuse.org.:0"
#"SMTP-RDNSCheck"	"1"
#"CheckMailerDomain"	"1"
#"SmartDNSHost"	"dns.home.bogus.net:tcp,192.168.1.1:udp"
#"DynDnsSetup"	"members.dyndns.org,80,/nic/dyndns?action=edit&started=1&hostname=YES&host_id=yourhost.ourdomain.ext&myip=%s&wildcard=OFF&mx=mail.exchanger.ext&backmx=NO,foouser,foopasswd"
#"SmtpConfig"	"mail-auth"
#"SmtpConfig-192_168_0_1"	"mail-auth"
#"DefaultSmtpPerms"	"MRVZ"
und "smtprelay.tab"

Code: Select all

"0.0.0.0"	"0.0.0.0"
In einem 1. Schritt kommt es mir darauf an, überhaupt eMails versenden zu können. Anschließend steht dann der Sicherheitsaspekt im Vordergrund.

Für Tipps und Hinweise bion ich dankbar.

Viele Grüße

Frank Dell

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: xmail - eMail Versand scheitert

Post by squize » 2004-09-02 21:14

Wird schwer werden, da xmail wohl nicht si verbreitet ist.

Ich habe ein nettes HowTo gefunden, dass dir vielleicht weiter hilft.

Gruss

Marc

frankieboy
Posts: 7
Joined: 2004-07-08 15:19

Problem gelöst ;-)

Post by frankieboy » 2004-09-06 14:10

alle Probleme scheinen(?!) gelöst. *Hurra*. Ich kann mittels "xmail" (eMail-Server) eMails versenden (smtp) und empfangen (pop3). Relaychecks bei http://www.mail-abuse.com und http://www.antispam-ufrj.pads.ufrj.br/test-relay.html haben zudem ergeben, daß meine Relays alle dicht sind ;-)

Allerdings hat es ein wenig gedauert,bis ich auf die Lösung gekommen bin. Genauer gesagt hat es ziemlich lange gedauert. Ob ich jemals wieder einen eMail-Server installieren und konfigurieren werde, muß ich mir jedenfalls gut überlegen.

Und obwohl "xmail" als einfach zu konfigurierender Server beschrieben wird, hat sich die offensichtlich geringe Verbreitung negativ bemerkbar gemacht. Jedenfalls habe ich weder im "Debianforum.de" noch im "RootForum" oder den "Linuxforen.de" brauchbare Hilfestellungen bekommen. Bei Problemen ist man echt ziemlich auf sich alleine gestellt. ;-(

Und so ging es dann doch: Zunächst hatte ich festgestellt, daß, wenn ich die eMails von meinem Clienten (Thunderbird) ohne Benutzerkennung und Passwort versende, sehr wohl ein Versand möglich ist. Allerdings ist der Server unter solchen Voraussetzungen offen wie ein Scheunentor und deshalb für den praktischen Einsatz nicht wirklich zu gebrauchen. Immerhin war "Problem 1" schon mal gelöst.

Das "Problem2" (Sicherheit) habe ich mit folgender Konfiguration hinbekommen (Datei: server.tab):

Code: Select all

"RootDomain"   "meineDomain.com"
"SmtpServerDomain"   "meineDomain.com"
"POP3Domain"   "meineDomain.com"
"HeloDomain"   "meineDomain.com"
"PostMaster"   "postmaster@meineDomain.com"
"ErrorsAdmin"   "postmaster@meineDomain.com"
"TempErrorsAdmin"   "postmaster@meineDomain.com"
#"DefaultSMTPGateways"   "meineDomain.com"
"RemoveSpoolErrors"   "0"
"DisableEmitAuthUser"   "0"
"NotifyMsgLinesExtra"   "1"
#"NotifySendLogToSender"   "0"
#"NotifyTryPattern"   "1"
#"MaxMTAOps"   "16"
"ReceivedHdrType"   "0"
"FetchHdrTags"   "+X-Deliver-To,+Received,To,Cc"
"SmtpMsgIPBanSpammers"   "550 Denied due inclusion of your IP in our spam lists"
"SmtpMsgIPBanSpamAddress"   "550 Denied due inclusion of your email address in our spam lists"
"SmtpMsgIPBanMaps"   "550 Denied due inclusion of your IP in the following map"
#"CustomSMTPMessage"   "Please open http://www.meineDomain.com/smtp_errors.html to get more information about this error"
"MaxMessageSize"   "20000"
"EnableAuthSMTP-POP3"   "0"
"Pop3SyncErrorAccount"   "postmaster@meineDomain.com"
"AllowNullSender"   "0"
"AllowSmtpVRFY"   "0"
"AllowSmtpETRN"   "0"
#"SmtpMinDiskSpace"   "100000"
#"SmtpMinVirtMemSpace"   "64000"
#"Pop3MinVirtMemSpace"   "64000"
"CustMapsList"   "list.dsbl.org.:1,blackholes.mail-abuse.org.:1,dialups.mail-abuse.org.:0"
#"SMTP-RDNSCheck"   "1"
#"CheckMailerDomain"   "1"
#"SmartDNSHost"   "dns.home.bogus.net:tcp,192.168.1.1:udp"
#"DynDnsSetup"   "members.dyndns.org,80,/nic/dyndns?action=edit&started=1&hostname=YES&host_id=yourhost.ourdomain.ext&myip=%s&wildcard=OFF&mx=mail.exchanger.ext&backmx=NO,foouser,foopasswd"
#"SmtpConfig"   "mail-auth"
#"SmtpConfig-192_168_0_1"   "mail-auth"
"DefaultSmtpPerms"   "MRVZ"
Die Dateien "smtprelay.tab" und "smtpauth.tab" müßen zudem ratzeputz leer sein. Die Authentifizierung erfolgt dann nach der Methode "smtp-after-pop"

Hilfreich ist hier das englischsprachige x-Mail-Forum gewesen. Auf die richtige Spur hat mich folgender Beitrag gebracht: http://xmailforum.homelinux.net/index.php?showtopic=335

Viele Grüße

Frank Dell