Qmail - Mails gehen teilweise wieder zurück

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
christian74
Posts: 13
Joined: 2004-01-16 20:14
Location: Hamburg

Qmail - Mails gehen teilweise wieder zurück

Post by christian74 » 2004-02-03 19:43

Hallo Leute...

Ich habe vor kurzem auf einem Strato-Server Debian installiert und dazu
Qmail nach dem DebianHowto.

Ich habe eigentlich erst keine Probleme festgestellt, allerdings bekommen einige Bekannte von mir Emails die sie an mich schreiben wieder mit einer Fehlermeldung zurück. Ich allerdings bekomme diese Mails ganz normal. Ich habe mal einen Auszug aus diesen Retour-Mails abgedruckt:

Code: Select all



-----Ursprüngliche Nachricht-----
Von: MAILER-DAEMON@h3220.serverkompetenz.net
[mailto:MAILER-DAEMON@h3220.serverkompetenz.net]
Gesendet: Dienstag, 3. Februar 2004 17:25
An: info@grewenig.de
Betreff: failure notice


Hi. This is the qmail-send program at h3220.serverkompetenz.net.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<christian@grewenig.de>:
The -P option has been removed.
lseek error 29
lseek errno=29

--- Below this line is a copy of the message.

Return-Path: <info@grewenig.de>
Received: (qmail 1017 invoked by uid 89); 3 Feb 2004 16:25:01 -0000
Received: from unknown (HELO mama) (217.227.61.30)
  by 81.169.158.30 with SMTP; 3 Feb 2004 16:25:01 -0000
From: "Grewenig" <info@grewenig.de>
To: "christian Grewenig" <christian@grewenig.de>
Subject:
Date: Tue, 3 Feb 2004 18:24:15 +0100
Message-ID: <NFBBKBJAALPNCHDBNDCCEEOPCDAA.info@grewenig.de>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2910.0)
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000

test.................


Ich muss dazu sagen, dass mein Mail-Server vorher auf einen Root-Server bei Puretec lief und ich die DNS-Server vor ca. einer Woche umgestellt habe. Alle betroffenen Domains zeigen auch auf meinen neuen Server.

Wo liegt das Problem?

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Qmail - Mails gehen teilweise wieder zurück

Post by kenzo » 2004-02-03 23:47

Schon gegooglet? Nein.
The -P option has been removed.
http://www.google.de/search?hl=de&ie=UT ... uche&meta=

Okay, das zweite ist schon schwieriger, aber wenn man systematisch sucht, findet man es auch - selbst wenn es für Deine vpopmail-Version nicht mehr zutreffen sollte (oder Du hast es flashc kompiliert):
http://marc.theaimsgroup.com/?l=vchkpw& ... 432128&w=2
Last edited by kenzo on 2004-02-03 23:52, edited 1 time in total.

christian74
Posts: 13
Joined: 2004-01-16 20:14
Location: Hamburg

Re: Qmail - Mails gehen teilweise wieder zurück

Post by christian74 » 2004-02-03 23:52

Sehe ich das richtig das der Spamassassin nicht richtig konfiguriert ist?

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Qmail - Mails gehen teilweise wieder zurück

Post by kenzo » 2004-02-03 23:54

man spamassassin

christian74
Posts: 13
Joined: 2004-01-16 20:14
Location: Hamburg

Re: Qmail - Mails gehen teilweise wieder zurück

Post by christian74 » 2004-02-04 00:00

Ich habe vpopmail folgendermassen kompiliert installiert:

Code: Select all

wget http://www.inter7.com/vpopmail/vpopmail-5.2.1.tar.gz
tar xvfz vpopmail-5.2.1.tar.gz
cd vpopmail-5.2.1

Code: Select all

groupadd -g 89 vchkpw
useradd -g vchkpw -u 89 -d /var/vpopmail vpopmail
chown vpopmail:vchkpw /var/vpopmail/

Code: Select all

./configure                                 
> --enable-clear-passwd=y 
> --enable-valias=y 
> --enable-roaming-users=y 
> --enable-relay-clear-minutes=10 
> --enable-tcpserver-file=/etc/tcp.smtp 
> --enable-auth-logging=y 
> --enable-logging=y 
> --enable-log-name=vpopmail 
> --enable-admin-email=admin@mailserver

Code: Select all

vpopmail 5.2.1           
            Current settings
---------------------------------------

vpopmail directory = /home/vpopmail
               uid = 89
               gid = 89
          ip alias = OFF --enable-ip-alias-domains=n (default)
address extentions = OFF --enable-qmail-ext=n (default)
     roaming users = ON  --enable-roaming-users=y
    tcpserver file = /etc/tcp.smtp
    open_smtp file = /home/vpopmail/etc/open-smtp
        user quota = OFF --enable-defaultquota=NOQUOTA default
table optimization = many domains --enable-many-domains=y default
       auth module = cdb default
  system passwords = OFF --enable-passwd=n default
      file locking = ON  --enable-file-locking=y default
         file sync = OFF --enable-file-sync=n default disable vdelivermail fsync
      auth logging = ON  --enable-auth-logging=y default
     mysql logging = OFF --enable-mysql-logging=n default
      clear passwd = ON  --enable-clear-passwd=y (default)
 valias processing = ON  --enable-valias=y
        pop syslog = show successful and failure login attempts
                     --enable-logging=y
    default domain =  --enable-default-domain=
          auth inc = -Icdb
          auth lib = 
Na ja.... und den rest eben .... make ....

Vielleicht kannst du mir ja ein wenig konkreter sagen was ich ändern sollte.

grüße
Christian

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Qmail - Mails gehen teilweise wieder zurück

Post by kenzo » 2004-02-04 00:06

Vielleicht kannst du mir ja ein wenig konkreter sagen was ich ändern sollte.
Klar - auch wenn ich's eben schon gesagt habe:
In http://marc.theaimsgroup.com/?l=vchkpw& ... 432128&w=2 steht:
You're first problem is that you need to apply the "seekable" patch to your
version of vpopmail or be using the latest devel code that contains the
patch natively. MANY people are using the devel code. It's quite stable...
and will be marked stable soon so I'd just upgrade to that.
Hättest Du da ein bißchen gesucht, hättest Du zum Thema auch mehr gefunden.
Wie auch immer: Unter http://sourceforge.net/projects/vpopmail/ findest Du die aktuellste Version (5.4.0), da sich da aber etwas gravierend geändert hat, würde ich 5.3.30 vorschlagen. Stable ist es allemal.
Und damit sollte es dann funktionieren.

christian74
Posts: 13
Joined: 2004-01-16 20:14
Location: Hamburg

Re: Qmail - Mails gehen teilweise wieder zurück

Post by christian74 » 2004-02-04 00:08

alles klar.... vielen Dank schon mal ....werd ich gleich mal ausprobieren!