Postfix sendet nur Mails an meine Domains

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
Anonymous

Postfix sendet nur Mails an meine Domains

Post by Anonymous » 2003-12-19 10:11

Ich habe einen Root-Sever bei Puretec unter dem Suse 8.1 läuft.
Leider funktioniert der Postversand (auch bei SMTP_auth ) nur an eigene Domains.
postconf gibt folgendes aus:
2bounce_notice_recipient = postmaster
access_map_reject_code = 554
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_mail_to_commands = alias,forward
allow_mail_to_files = alias,forward
allow_min_user = no
allow_percent_hack = yes
allow_untrusted_routing = no
alternate_config_directories =
always_bcc =
append_at_myorigin = yes
append_dot_mydomain = yes
best_mx_transport =
biff = yes
body_checks =
bounce_notice_recipient = postmaster
bounce_size_limit = 50000
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
command_expansion_filter = 1234567890!@%-_=+:,./abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ
command_time_limit = 1000s
config_directory = /etc/postfix
content_filter =
daemon_directory = /usr/lib/postfix
daemon_timeout = 18000s
debug_peer_level = 2
debug_peer_list =
default_database_type = hash
default_delivery_slot_cost = 5
default_delivery_slot_discount = 50
default_delivery_slot_loan = 3
default_destination_concurrency_limit = 10
default_destination_recipient_limit = 50
default_extra_recipient_limit = 1000
default_minimum_delivery_slots = 3
default_privs = autoresp
default_process_limit = 50
default_recipient_limit = 10000
default_transport = smtp
default_verp_delimiters = +=
defer_transports =
delay_notice_recipient = postmaster
delay_warning_time = 0h
deliver_lock_attempts = 20
deliver_lock_delay = 1s
disable_dns_lookups = no
disable_verp_bounces = no
disable_vrfy_command = no
dont_remove = 0
double_bounce_sender = double-bounce
duplicate_filter_limit = 1000
empty_address_recipient = MAILER-DAEMON
error_notice_recipient = postmaster
expand_owner_alias = no
export_environment = TZ MAIL_CONFIG
extract_recipient_limit = 10240
fallback_relay =
fallback_transport =
fast_flush_domains = $relay_domains
fast_flush_purge_time = 7d
fast_flush_refresh_time = 12h
fault_injection_code = 0
fork_attempts = 5
fork_delay = 1s
forward_expansion_filter = 1234567890!@%-_=+:,./abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ
forward_path = $home/.forward${recipient_delimiter}${extension},$home/.forward
hash_queue_depth = 2
hash_queue_names = incoming,active,deferred,bounce,defer,flush
header_checks =
header_size_limit = 102400
home_mailbox =
hopcount_limit = 50
ignore_mx_lookup_error = no
import_environment = MAIL_CONFIG MAIL_DEBUG MAIL_LOGTAG TZ XAUTHORITY DISPLAY
in_flow_delay = 0
inet_interfaces = all
initial_destination_concurrency = 5
invalid_hostname_reject_code = 501
ipc_idle = 100s
ipc_timeout = 3600s
line_length_limit = 2048
lmtp_cache_connection = yes
lmtp_connect_timeout = 0s
lmtp_data_done_timeout = 600s
lmtp_data_init_timeout = 120s
lmtp_data_xfer_timeout = 180s
lmtp_lhlo_timeout = 300s
lmtp_mail_timeout = 300s
lmtp_quit_timeout = 300s
lmtp_rcpt_timeout = 300s
lmtp_rset_timeout = 300s
lmtp_sasl_auth_enable = no
lmtp_sasl_password_maps =
lmtp_sasl_security_options = noplaintext, noanonymous
lmtp_skip_quit_response = no
lmtp_tcp_port = 24
local_command_shell =
local_destination_concurrency_limit = 2
local_destination_recipient_limit = 1
local_recipient_maps = $alias_maps unix:passwd.byname
local_transport = local
luser_relay =
mail_name = Postfix
mail_owner = postfix
mail_release_date = 20021122
mail_spool_directory = /var/mail
mail_version = 1.1.12
mailbox_command =
mailbox_command_maps =
mailbox_delivery_lock = flock, dotlock
mailbox_size_limit = 51200000
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
maps_rbl_domains =
maps_rbl_reject_code = 554
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains = bomboclaat.de
masquerade_exceptions = root
max_idle = 100s
max_use = 100
maximal_backoff_time = 4000s
maximal_queue_lifetime = 5d
message_size_limit = 10240000
minimal_backoff_time = 1000s
mydestination = $myhostname, localhost.$mydomain, $mydomain, smtp.$mydomain
mydomain = bomboclaat.de
myhostname = p15137994.pureserver.info
mynetworks = 127.0.0.0/8 217.160.214.175/32
mynetworks_style = subnet
myorigin = $myhostname
newaliases_path = /usr/bin/newaliases
non_fqdn_reject_code = 504
notify_classes = resource,software
owner_request_special = yes
parent_domain_matches_subdomains =
debug_peer_list,fast_flush_domains,mynetworks,permit_mx_backup_networks,qmqpd_authorized_clients,relay_domains,smtpd_access_maps
permit_mx_backup_networks =
prepend_delivered_header = command, file, forward
process_id_directory = pid
program_directory = /usr/libexec/postfix
propagate_unmatched_extensions = canonical, virtual
qmgr_fudge_factor = 100
qmgr_message_active_limit = 10000
qmgr_message_recipient_limit = 10000
qmgr_message_recipient_minimum = 10
qmgr_site_hog_factor = 100
qmqpd_authorized_clients =
qmqpd_error_delay = 5s
qmqpd_timeout = 300s
queue_directory = /var/spool/postfix
queue_minfree = 0
queue_run_delay = 1000s
readme_directory = /usr/share/doc/packages/postfix/README_FILES
recipient_canonical_maps =
recipient_delimiter =
reject_code = 554
relay_clientcerts =
relay_domains = $mydestination
relay_domains_reject_code = 554
relayhost =
relocated_maps = hash:/etc/postfix/relocated
require_home_directory = no
resolve_dequoted_address = yes
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
service_throttle_time = 60s
setgid_group = maildrop
smtp_always_send_ehlo = yes
smtp_bind_address =
smtp_connect_timeout = 0s
smtp_data_done_timeout = 600s
smtp_data_init_timeout = 120s
smtp_data_xfer_timeout = 180s
smtp_destination_concurrency_limit = $default_destination_concurrency_limit
smtp_destination_recipient_limit = $default_destination_recipient_limit
smtp_enforce_tls = no
smtp_helo_timeout = 300s
smtp_line_length_limit = 990
smtp_mail_timeout = 300s
smtp_never_send_ehlo = no
smtp_pix_workaround_delay_time = 10s
smtp_pix_workaround_threshold_time = 500s
smtp_quit_timeout = 300s
smtp_randomize_addresses = yes
smtp_rcpt_timeout = 300s
smtp_sasl_auth_enable = no
smtp_sasl_password_maps =
smtp_sasl_security_options = noplaintext, noanonymous
smtp_skip_4xx_greeting = yes
smtp_skip_5xx_greeting = yes
smtp_skip_quit_response = yes
smtp_starttls_timeout = 300s
smtp_tls_CAfile =
smtp_tls_CApath =
smtp_tls_cert_file =
smtp_tls_cipherlist =
smtp_tls_dcert_file =
smtp_tls_dkey_file = $smtp_tls_dcert_file
smtp_tls_enforce_peername = yes
smtp_tls_key_file = $smtp_tls_cert_file
smtp_tls_loglevel = 0
smtp_tls_note_starttls_offer = no
smtp_tls_per_site =
smtp_tls_session_cache_database =
smtp_tls_session_cache_timeout = 3600s
smtp_use_tls = no
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_client_restrictions =
smtpd_delay_reject = yes
smtpd_enforce_tls = no
smtpd_error_sleep_time = 5s
smtpd_etrn_restrictions =
smtpd_hard_error_limit = 100
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_history_flush_threshold = 100
smtpd_junk_command_limit = 100
smtpd_noop_commands =
smtpd_null_access_lookup_key = <>
smtpd_recipient_limit = 1000
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_restriction_classes =
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous
smtpd_sender_login_maps =
smtpd_sender_restrictions =
smtpd_soft_error_limit = 10
smtpd_timeout = 300s
smtpd_tls_CAfile = /etc/postfix/cacert.pem
smtpd_tls_CApath =
smtpd_tls_ask_ccert = no
smtpd_tls_auth_only = yes
smtpd_tls_ccert_verifydepth = 5
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_cipherlist =
smtpd_tls_dcert_file =
smtpd_tls_dh1024_param_file =
smtpd_tls_dh512_param_file =
smtpd_tls_dkey_file = $smtpd_tls_dcert_file
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_req_ccert = no
smtpd_tls_session_cache_database =
smtpd_tls_session_cache_timeout = 3600s
smtpd_tls_wrappermode = no
smtpd_use_tls = yes
soft_bounce = no
stale_lock_time = 500s
strict_rfc821_envelopes = no
sun_mailtool_compatibility = no
swap_bangpath = yes
syslog_facility = mail
syslog_name = postfix
tls_daemon_random_bytes = 32
tls_daemon_random_source =
tls_random_bytes = 32
tls_random_exchange_name = ${config_directory}/prng_exch
tls_random_prng_update_period = 60s
tls_random_reseed_period = 3600s
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
transport_retry_time = 60s
trigger_timeout = 10s
undisclosed_recipients_header = To: undisclosed-recipients:;
unknown_address_reject_code = 450
unknown_client_reject_code = 450
unknown_hostname_reject_code = 450
verp_delimiter_filter = -=+
virtual_gid_maps =
virtual_mailbox_base =
virtual_mailbox_limit = 51200000
virtual_mailbox_lock = fcntl
virtual_mailbox_maps =
virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
virtual_minimum_uid = 100
virtual_uid_maps =

Wer kann mir weiterhelfen?

MfG
Fabian

lostsoul
Posts: 6
Joined: 2003-12-11 18:41

Re: Postfix sendet nur Mails an meine Domains

Post by lostsoul » 2003-12-19 13:28

Moin!

Inwiefern nur an "eigene Domain"? Meinst du Domains, die auf dem Server gehosted werden? Welche Fehlermeldung gibt es, wenn du an eine 'externe' Domain senden willst?

Was steht in:
/var/log/mail
/var/log/warnings

Anonymous

Re: Postfix sendet nur Mails an meine Domains

Post by Anonymous » 2003-12-20 15:44

Moin

Mit eigenen Domains meine ich Domains, die auf dem Server gehostet werden. Ich erhalte die Fehlermeldung "Relay access denied".

p15137994:~ # tail /var/log/mail

Dec 20 12:27:20 p15137994 postfix/smtpd[4079]: E5E6D204186: client=p508360C1.dip0.t-ipconnect.de[80.131.96.193]
Dec 20 12:27:21 p15137994 postfix/cleanup[4080]: E5E6D204186: message-id=<3FE43195.09F1C4B8@asgard.net.au>
Dec 20 12:27:21 p15137994 postfix/qmgr[6220]: E5E6D204186: from=<e.mcKinley_gc@asgard.net.au>, size=1207, nrcpt=1 (queue active)
Dec 20 12:27:21 p15137994 postfix/local[4082]: E5E6D204186: to=<web2p1@p15137994.pureserver.info>, relay=local, delay=1, status=sent (mailbox)
Dec 20 12:27:21 p15137994 postfix/smtpd[4079]: disconnect from p508360C1.dip0.t-ipconnect.de[80.131.96.193]
Dec 20 14:11:05 p15137994 popper[5843]: Stats: web2p1 5 110300 0 0 pD9ECD0DD.dip.t-dialin.net 217.236.208.221 [pop_updt.c:296]
Dec 20 15:07:13 p15137994 postfix/smtpd[6604]: connect from pD9ECD0DD.dip.t-dialin.net[217.236.208.221]
Dec 20 15:07:13 p15137994 postfix/smtpd[6604]: 52B59204186: client=pD9ECD0DD.dip.t-dialin.net[217.236.208.221]
Dec 20 15:07:13 p15137994 postfix/smtpd[6604]: reject: RCPT from pD9ECD0DD.dip.t-dialin.net[217.236.208.221]: 554 <fstehle@gmx.de>: Relay access denied;
from=<info@roessle-stetten.de> to=<fstehle@gmx.de>
Dec 20 15:07:18 p15137994 postfix/smtpd[6604]: disconnect from pD9ECD0DD.dip.t-dialin.net[217.236.208.221]


p15137994:~ # tail /var/log/warn

Dec 19 09:57:24 p15137994 postfix/master[1362]: warning: process /usr/lib/postfix/smtpd pid 1372 exit status 1
Dec 19 09:57:24 p15137994 postfix/master[1362]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 19 09:58:24 p15137994 postfix/smtpd[1377]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of:
check_relay_domains, reject_unauth_destination or reject
Dec 19 09:58:25 p15137994 postfix/master[1362]: warning: process /usr/lib/postfix/smtpd pid 1377 exit status 1
Dec 19 09:58:25 p15137994 postfix/master[1362]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 19 09:59:25 p15137994 postfix/smtpd[1387]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of:
check_relay_domains, reject_unauth_destination or reject
Dec 19 09:59:26 p15137994 postfix/master[1362]: warning: process /usr/lib/postfix/smtpd pid 1387 exit status 1
Dec 19 09:59:26 p15137994 postfix/master[1362]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 19 23:10:47 p15137994 postfix/smtpd[24704]: warning: dibico.de[217.160.214.18] sent message header instead of SMTP command: From:pete@aol.com
Dec 20 00:11:33 p15137994 postfix/cleanup[24709]: warning: premature end-of-input from cleanup socket while reading input attribute name

/var/log/warnings gibts bei mir net.

MfG
Fabian

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Postfix sendet nur Mails an meine Domains

Post by flo » 2003-12-20 16:53

poste doch mal Deine main.cf ohne Kommentare ...

flo.

lostsoul
Posts: 6
Joined: 2003-12-11 18:41

Re: Postfix sendet nur Mails an meine Domains

Post by lostsoul » 2003-12-20 16:58

Moin!

Jupp, poste mal deine main.cf (findest du in /etc/postfix). Denn die Passage aus deinen Logs lässt auf eine fehlerhafte Konfiguration schliessen:
Dec 19 09:58:25 p15137994 postfix/master[1362]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 19 09:59:25 p15137994 postfix/smtpd[1387]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of:
check_relay_domains, reject_unauth_destination or reject
Dec 19 09:59:26 p15137994 postfix/master[1362]: warning: process /usr/lib/postfix/smtpd pid 1387 exit status 1

Anonymous

Re: Postfix sendet nur Mails an meine Domains

Post by Anonymous » 2003-12-21 13:58

p15137994:~ # grep '^[^#]' /etc/postfix/main.cf

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
default_privs = autoresp
myhostname = p15137994.pureserver.info
mydomain = bomboclaat.de
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, $mydomain, smtp.$mydomain
relay_domains = $mydestination

local_recipient_maps = $alias_maps unix:passwd.byname
in_flow_delay = 0
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

mail_spool_directory = /var/mail

fast_flush_domains = $relay_domains
debug_peer_level = 2
debugger_command =
PATH=/usr/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = maildrop
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples
readme_directory = /usr/share/doc/packages/postfix/README_FILES
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
inet_interfaces = all
masquerade_domains = bomboclaat.de
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_use_tls = yes
smtpd_tls_auth_only = yes
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_CAfile = /etc/postfix/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

MfG
Fabi

sanchez
Posts: 33
Joined: 2004-01-13 13:05

Re: Postfix sendet nur Mails an meine Domains

Post by sanchez » 2004-01-15 14:55

genau das problem hab ich zur zeit auch...wie habt ihr es denn jetzt gelöst?

momo
Posts: 33
Joined: 2003-08-03 16:35

Re: Postfix sendet nur Mails an meine Domains

Post by momo » 2004-01-17 16:56

Häkchen in Outlook gesetzt? ( Server erfordert Authentifizierung )

Anonymous

Re: Postfix sendet nur Mails an meine Domains

Post by Anonymous » 2004-01-26 16:09

der haken ist natürlich drin, aber bei mir dasselbe problem. ich bekomme alle mails zurück (Unknown local part .... ). der name vor dem @ kann also nicht aufgelöst werden.

außerdem reagiert der smtp-server seltsam: mx00.schlund.de[212.227.126.147] said: 550 --- der kann also auch nicht!

testmails von und nach derselben mailadresse funktionieren aber. daraus schließe ich, die postfächer sind i.o.

was kann das nur sein??


ps: hab rootserver suse8.1 bei puretec.

mattes
Posts: 4
Joined: 2003-04-04 19:26

Re: Postfix sendet nur Mails an meine Domains

Post by mattes » 2004-01-26 18:51

Das erinnert mich an mein drittliebstes Problem mit 1&1 Rootservern:

Wenn du eine neue domain bestellst, dann legt 1&1 automatisch einen eintrag für webmaster@deine.neue.domain im webinterface login.1und1.com an. Das wird meistens nicht bemerkt, und verursacht auch keine probleme, bis man versucht, mails an einen anderen server bei 1&1 zu schicken... mails ganz raus funktionieren, weil sie direkt raus gehen, lokale mails funzen auch, weil sich der lokale mta nen scheiss um den mail-eintrag von 1&1 kümmert, aber wenn ich eine mail innerhalb von 1&1 zu einem anderen server schicken will, bekomme ich "unknown local part", von mx.kundenserver.de, obwohl die lokale adresse dort definitiv existiert.

Lösung: login.1und1.com, dort den rootserver-vertrag auswählen, und unter "Emails", einfach ALLE automatisch eingerichteten webmaster@domain.de einfach löschen ! die sind echt mal überflüssiger als ein Kropf !

dann 6-12h warten, und es soltle gehen...


liebe grüsse,

Matthias
akoimetos wrote:der haken ist natürlich drin, aber bei mir dasselbe problem. ich bekomme alle mails zurück (Unknown local part .... ). der name vor dem @ kann also nicht aufgelöst werden.

außerdem reagiert der smtp-server seltsam: mx00.schlund.de[212.227.126.147] said: 550 --- der kann also auch nicht!

testmails von und nach derselben mailadresse funktionieren aber. daraus schließe ich, die postfächer sind i.o.

was kann das nur sein??


ps: hab rootserver suse8.1 bei puretec.

Anonymous

Re: Postfix sendet nur Mails an meine Domains

Post by Anonymous » 2004-01-27 09:51

hat leider nichts gebracht, der fehler besteht immernoch.
einen neuen effekt habe ich aber gefunden: alle mailkonten, die ich für meine erste domain eingerichtet habe, funktionieren - alle mailadressen von dazugekauften domains nicht...

Anonymous

Re: Postfix sendet nur Mails an meine Domains

Post by Anonymous » 2004-01-27 15:45

Ã?berprüfe doch mal bitte die Datei /etc/poppasswd. Hier sollten die Zugangsdaten aufgeführt werden und keine Leerzeilen enthalten sein. Falls Leerzeilen vorhanden sind, so solltest du diese löschen und QMail neu starten.