Debian 3.0, Postfix, smtp-auth via pwcheck

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
hpschulz
Posts: 14
Joined: 2002-10-05 15:52
Location: Neustadt

Debian 3.0, Postfix, smtp-auth via pwcheck

Post by hpschulz » 2003-07-18 14:41

Hallo Leute,

Ich weiss nicht, was solls bedeuten, das mein Woody nimmer will,... *träller*
Ne, aber mal im Ernst:

Ich sitze nun seit drei Tagen an folgendem Problem und sehe wohl vor lauter Bäume den Wald nimmer:

Man nehme ein frisch intallierten Woody, installiere nach diesem Howto http://www.debianforum.de/wiki/?page=Postfix+SMTP-AUTH sein Postfix, sende ein Testmail an einen dort eingerichteten Unix-User, holt mit seinen Account-Daten die Post ab, und versendet als dieser Unix-User von aussen Mails über diesen Server. Fantastisch, es funktioniert :-)

Da ich zwei, drei Intallationen vorher das Prob hatte, das ich Confixx installiert hatte und den Server neu gebootet habe, dann nicht mehr relayen konnte, dachte ich, es liegt an Confixx.
Also wollte ich das wie folgt verifizieren:

Auf dem nackten woody mit Mailsystem erst mal alle relevanten Dateien gesichert, nochmal Test-Mails versendet (hat funktioniert), dann den Server rebootet.
Danach wieder Testmails versendet und....... *GG* es funzt nicht mehr,

Code: Select all

SASL LOGIN authentication failed
Sodele, wie gesagt, ich habe die letzten drei Tage nichts weiter gemacht, als den Woody gequält und hier fleissig im Forum und anderen Foren gelesen.

Ich habe daher keine weiteren Ã?nderungen am System vorgenommen, habe es belassen, wie nach obigen Howto beschrieben und rufe jetzt einfach mal HILFE :-)

Mir scheint, das entweder pwcheck nicht läuft (der PID dazu taucht nicht unter top oder ps aux auf) oder sonstige Dateien nicht gefunden werden. Ferner ist es ja auch so, das Postfix in einer chroot umgebung läuft.

Die frage ist nun: warum hats frisch nach einer Installation funktioniert und nach einem Reboot nicht mehr ??

Greetz
hps

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Debian 3.0, Postfix, smtp-auth via pwcheck

Post by sascha » 2003-07-18 19:06

Wenn pwcheck nicht läuft hast du dein Problem ja schon gefunden.

hpschulz
Posts: 14
Joined: 2002-10-05 15:52
Location: Neustadt

Re: Debian 3.0, Postfix, smtp-auth via pwcheck

Post by hpschulz » 2003-07-18 19:19

Hallo Sascha,

pwcheck läuft, das hab ich damit geprüft, welches PID er hatte, dann den daemon gestopt, neu gestartet und den neuen PID geprüft, war ein anderer, also muss ich davon ausgehen, das er läuft. Dennoch immer noch der selbe fehler.

Greetz
hps

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Debian 3.0, Postfix, smtp-auth via pwcheck

Post by sascha » 2003-07-18 23:15

Oben schreibst du dass er nicht bei ps aux zu sehen ist. Das müsste er aber in jedem Fall.

hpschulz
Posts: 14
Joined: 2002-10-05 15:52
Location: Neustadt

Re: Debian 3.0, Postfix, smtp-auth via pwcheck

Post by hpschulz » 2003-07-18 23:51

@Sascha:

nach oben genannter Howto (erste fassung) hats solange funktioniert, bis ein Rebbot kam.

Nach dem reboot wurde kein neuer PID-file angelegt, der alte Symlink wurde gelöscht.

Im neuen init-script wird beim Start des Daemon ein neuer symlink nach /var/run angelegt für den pwcheck.

Bisher funktioniert das soweit alles, ich teste noch und poste dann die komplette config und das Howto.

Greetz
hps

force
Posts: 7
Joined: 2003-04-24 19:19

Re: Debian 3.0, Postfix, smtp-auth via pwcheck

Post by force » 2003-07-19 18:34

Das Problem ist das die Symlinks in /var/run bei jeden neustart gelöscht werden, deswegen habe ich das start skript verändert so das er halt bei jeden starten und beenden den symlink löscht oder anlegt.
So funktioniert es bei mir gut.
Hatte ich erst nicht bemerkt da ich meine Server normal nie neustarte :-)

Hoffe das jetzt alles klapt wie im Howto beschrieben.


Aktuelle version ist zu finden unter
http://www.debianforum.de/forum/viewtopic.php?t=9628

Habe noch einiges hinzugefügt und überarbeitet.
z.B. Imap, Maildir , Convertierung von MBox zu Maildir.