Exim sendet nicht oder nur teilweise

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
steffz
Posts: 84
Joined: 2003-04-13 13:07
Location: Hamburg

Exim sendet nicht oder nur teilweise

Post by steffz » 2003-04-13 13:21

Hallo,
folgendes Problem: mein Exim 3.35 sendet einzelne eMails z.B. über Webinterfaces, ob diese nun minimalistisch sind oder ein Teil der WBB2-Boards sind.
Versucht aber mein Benutzer, eine Rundmail an die ca 150 Forenuser zu schreiben, kommt nix an. Laut Logdatei werden entweder gar keine, oder nur 2-3 Mails verschickt, die zu Mitgliedern mit relativ hohen Benutzer IDs gehören (die Reihenfolge schwankt) - inzwischen passiert nichtmal mehr das. Ansonsten findet sich dort nichts, nichtmal eine Fehlermeldung.
Witzig ist, dass es schonmal geklappt hat. Aber dann muss ich irgendeine Kleinigkeit verstellt haben. Exim scheint ein kleines Sensibelchen zu sein. Naja, habt ihr eine Idee, woran das liegen könnte?
Meine Vermutung ist, dass Exim Probleme mit Sonderzeichen in den Benutzernamen hat. Ich kann z.B. keine Mails empfangen, wenn der Name des Sendern ein Umlaut enthält.

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: Exim sendet nicht oder nur teilweise

Post by jtb » 2003-04-13 13:36

Umlaute sind ja auch nicht erlaubt..

siehe http://www.ietf.org/rfc/rfc821.txt
<local-part> ::= <dot-string> | <quoted-string>
<dot-string> ::= <string> | <string> "." <dot-string>
<string> ::= <char> | <char> <string>
<quoted-string> ::= """ <qtext> """
<qtext> ::= "" <x> | "" <x> <qtext> | <q> | <q> <qtext>
<char> ::= <c> | "" <x>
<c> ::= any one of the 128 ASCII characters, but not any
<special> or <SP>

btw: was steht im reject_log?

steffz
Posts: 84
Joined: 2003-04-13 13:07
Location: Hamburg

Re: Exim sendet nicht oder nur teilweise

Post by steffz » 2003-04-13 13:39

Nicht in den Adressen. Ich habe aber vom Namen gesprochen und bei allen möglichen ISPs funktioniert das ja auch (web.de, gmx, planet-school.com, ...). Die eMailadressen selbst enthalten keine Sonderzeichen.

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: Exim sendet nicht oder nur teilweise

Post by jtb » 2003-04-13 13:41

wie sieht deine Exim-Conf aus?

steffz
Posts: 84
Joined: 2003-04-13 13:07
Location: Hamburg

Re: Exim sendet nicht oder nur teilweise

Post by steffz » 2003-04-13 17:39

Wie das Original, mit folgenden Unterschieden:

qualify_domain = [domain2]
local_domains = localhost:[domain1]:[domain2]:[domain3]
relay_domains = [domain4]

local_delivery:
[...]
file = /var/mail/${local_part}

majortermi
Userprojekt
Userprojekt
Posts: 930
Joined: 2002-06-17 16:09

Re: Exim sendet nicht oder nur teilweise

Post by majortermi » 2003-04-14 14:29

Und was meinen die Logfiles dazu (ggf. den Log-Level erhöhen)?
Erst nachlesen, dann nachdenken, dann nachfragen... :)
Warum man sich an diese Reihenfolge halten sollte...