Problem mit SendMail

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
redbull
Posts: 16
Joined: 2002-08-02 23:40

Problem mit SendMail

Post by redbull » 2003-04-04 14:10

Hi, habe ein Problem mit meinem Server. Wenn ich von all-inkl aus eine E-Mail an den Server schicke, kommt diese nicht an. In den Serverlogfiles des Servers steht dann:

Apr 4 14:04:47 ns12345a sendmail[1935]: OAA01935: ruleset=check_mail, arg1=<test@addresse.de>, relay=ks406.kasserver.com [62.141.48.110] (may be forged), reject=451 <test@addresse.de>... Sender domain must resolve
Apr 4 14:04:47 ns12345a sendmail[1935]: OAA01935: from=<test@addresse.de>, size=0, class=0, pri=0, nrcpts=0, proto=ESMTP, relay=ks406.kasserver.com [62.141.48.110] (may be forged)

Was läuft da schief...alle anderen E-Mails kommen an, halt nur diese nicht... :(

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Problem mit SendMail

Post by dodolin » 2003-04-04 14:16

reject=451 <test@addresse.de>... Sender domain must resolve
Steht doch da! Dein sendmail ist so schlau und erkennt, dass du ihn mit einer test.addresse verarschen willst. Da spielt er natürlich nicht mit - zu Recht. Abhilfe: Eine gültige Absenderadresse benutzen.

redbull
Posts: 16
Joined: 2002-08-02 23:40

Re: Problem mit SendMail

Post by redbull » 2003-04-04 16:07

Wäre ja schön und gut ;-) Allerdings hab ich die Adresse für dieses Posting hier verändert. Die Adresse die ich als Absender nehme existiert ind wirklichkeit.

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Problem mit SendMail

Post by captaincrunch » 2003-04-04 16:30

Wobei wir wieder einmal feststellen müssen, das "Security by obscurity" wirklich gar nichts bringt. :wink:
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Problem mit SendMail

Post by dodolin » 2003-04-04 17:02

Eigentlich finde ich das echt zum <zensiert>, dass hier dauernd alles mögliche verschleiert wird. Meine Herrn, da kann man euch doch nicht helfen...! :evil:

Wenn die Adresse existiert, dann funktioniert was mit dem DNS dieser Domain nicht. Wenn du uns das aber nicht verrätst, verrate ich auch nicht mehr. :wink:

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Problem mit SendMail

Post by Outlaw » 2003-04-04 20:18

Hmmmm, wenn ich an "test@meinedomain.tld" sende, kommt sie auch an. Warum sollte sendmail das blocken ??

Hier liegt der Fehler woanders ....
:D Gruß Outi :D

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Problem mit SendMail

Post by dodolin » 2003-04-05 03:37

wenn ich an "test@meinedomain.tld" sende
reject=451 <test@addresse.de>... Sender domain must resolve
Merkst du was? :wink:
Warum sollte sendmail das blocken ??
s.o.

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Problem mit SendMail

Post by Outlaw » 2003-04-06 01:34

Ich merke nix, bei mir kommen die Mails ganz normal an ....

Ok, ich habe aber auch die Fehlermeldung nicht.
Evtl. ist mein Sendmail anders konfiguriert.

[EDIT]
Ah, jetzt sehe ich es weiter oben: "ruleset", da wird wohl eine Regel aktiv sein .... ;):D

Ok, ich sehe es ein, ich hab mal wieder nicht aufgepasst .... Sorry nochmal ....
[/EDIT]
:D Gruß Outi :D

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Problem mit SendMail

Post by dodolin » 2003-04-06 03:38

@Outlaw: Du redest davon, eine Mail an jemanden zu schicken. Die Fehlermeldung von RedBull bezieht sich aber auf den Absender einer Mail, nicht auf den Empfänger. Das wollte ich dir durch meine Fettmachereien deutlich machen und dachte, du merkst es dann selbst. :wink: