qmail startet nicht / daemontools problem ?

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
[monk]
Posts: 163
Joined: 2002-08-09 17:31
Location: Ulm

qmail startet nicht / daemontools problem ?

Post by [monk] » 2003-03-08 21:47

tach,
nachdem sich gerade mein windoof mit nem bluescreen verabschiedet hat fasse ich mich kurz.. mein eigentliches posting währe ausführlicher gewesen (aber mehr zu lesen :wink: )

Also ich hab das Howto von http://www.rootforum.org/forum/viewtopic.php?t=3783 durchgemacht. (übrigends ein super howto, danke einfach nur spitze).

courier-imap läuft
qmail nicht..

/etc/init.d/qmail start gibt folgendes aus:

Code: Select all

Starting qmail
qmail-send supervise/log not running
qmail-send supervise not running
qmail-smtpd/log supervise not running
qmail-smtpd supervise not running

Wenn ich die Befehle in dem qmail script manuell starte kommt folgendes.
(anhand des beispieles von "svc -u /etc/service/qmail-send")
svc: warning: unable to control /etc/service/qmail-send: file does not exist

/etc/service/ sieht wie folgt aus:

Code: Select all

lrwxrwxrwx    1 root     root           32 Mar  7 20:05 qmail-pop3d -> /var/qmail/supervise/qmail-pop3d
lrwxrwxrwx    1 root     root           33 Mar  7 20:05 qmail-pop3ds -> /var/qmail/supervise/qmail-pop3ds
lrwxrwxrwx    1 root     root           31 Mar  7 20:05 qmail-send -> /var/qmail/supervise/qmail-send
lrwxrwxrwx    1 root     root           32 Mar  7 20:05 qmail-smtpd -> /var/qmail/supervise/qmail-smtpd
Die run Dateien in den Ordnern laufen fehlerfrei, wenn ich sie manuell starte.

Ich habe das howto 2 mal durchgemacht um fehler zu vermeiden.
ich weiss nicht mehr woran es liegen könnte.. :(
hat jemand ne idee?

Vielen Dank
Last edited by [monk] on 2003-03-09 11:44, edited 1 time in total.

cosmicboy
Posts: 146
Joined: 2003-02-04 13:28

Re: qmail startet nicht / daemontools problem ?

Post by cosmicboy » 2003-03-08 21:57

Bin in der Sache jetzt auch nicht so fit, aber ich hatte auch das gleiche Problem.

Bei mir waren es die Daemontools selbst, die das Problem verursachten. Ich hatte zuerst die meiner Distribution im Einsatz und die zickten rum.

Nachdem ich diese von Hand kompiliert hatte, "fluppte" alles wunderbar.

Gruß
Thorsten

[monk]
Posts: 163
Joined: 2002-08-09 17:31
Location: Ulm

Re: qmail startet nicht / daemontools problem ?

Post by [monk] » 2003-03-08 22:23

cosmicboy wrote:Bin in der Sache jetzt auch nicht so fit, aber ich hatte auch das gleiche Problem.

Bei mir waren es die Daemontools selbst, die das Problem verursachten. Ich hatte zuerst die meiner Distribution im Einsatz und die zickten rum.

Nachdem ich diese von Hand kompiliert hatte, "fluppte" alles wunderbar.

Gruß
Thorsten
Hallo, dass war auch mein erster Gedanke, weshalb ich das Howto ja mehrmals durchgemacht hab. Diese werden ja gleich beim Ersten Schritt installiert. Hab es exakt so gemacht wie im howto. (oder war die anpassung bei einem Debian System nicht so gut ?)
hab ehrlich gesagt noch nicht oft mit den daemontools gearbeitet

[monk]
Posts: 163
Joined: 2002-08-09 17:31
Location: Ulm

Re: qmail startet nicht / daemontools problem ?

Post by [monk] » 2003-03-09 11:36

hmm kann mir evtl. jemand sagen, wie ich die daemontools wieder restandslos entferne ?

das problem ist, das ich den server, welchen ich gekriegt hab so übernommen hab, wie er war..

ich hab versucht den ganzen schrott und müll gröstenteils zu entfernen.


ich glaub jetzt dürften 3 versch. daemontools auf dem server installiert gewesen sein, welche evtl. nicht restandslos beseitigt wurden.

im moment verspüre ich ein richtiges lustgefühl als root rm -rf / auszuführen...
mich hat noch nie ein server so zur wut gebracht wie dieses verkonfigurierte und vermurkste system.