Problem mit suPHP / PHP

Bash, Shell, PHP, Python, Perl, CGI
Anonymous

Problem mit suPHP / PHP

Post by Anonymous »

Hi, ich bin völlig ratlos, ich bekomme das mit dem suPHP einfach nicht gebacken! Komischerweise lese ich hier permanent im Forum, daß bei allen die Installation wunderbar klappt und alles zur Zufriedenhait läuft. Warum geht das bei mir nicht:
- habe php4.3.1 drauf, suPHP0.2.3 (aber auch schon 0.2 und 0.2.2 probiert)
-immer wieder das gleiche Problem: ich bekomme beim Ausführen der Scripts per Browser einen Internal Server Error!
In der httpd.conf steht:
AddHandler x-httpd-php .php
rufe ich das Script auf, bekomme ich wie gesagt den Internal Servererror, dann steht in der suphp_log:
[Sun Feb 23 22:00:56 2003] [info] /home/www/web6/html/phptest/dateierstellung.php executed as user web6 (1042), group ftponly (103)
also eigentlich korrekt ausgeführt (oder?) und im error_log steht
[Sun Feb 23 22:00:56 2003] [error] [client 80.135.61.47] Premature end of script headers: /home/www/web6/html/phptest/dateierstellung.php
Ich interpretiere das mal so:
suPHP wurde korrekt ausgeführt und hat das PHP-Script zur Weiterbearbeitung an /usr/bin/php übergeben, dort wurde es aber offenbar nicht, bzw. nicht korrekt abgearbeitet???

Habe mich auch schon an den 1&1 Support gewandt, die kennen kein suPHP ??? ALso Fehlanzeige ...
Ich bin am Ende, ich hatte heute nochmal alles neu kompiliert und installiert, ich bekomm es einfach nicht hin! Wo kann denn hier nur noch die Ursache liegen???
HILFE!!!!

Gruß
André
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: Problem mit suPHP / PHP

Post by arty »

Hi,

wie hast Du denn PHP kompiliert? Hast Du das mod_php auskommentiert?

bye
arty
Anonymous

Re: Problem mit suPHP / PHP

Post by Anonymous »

arty wrote:wie hast Du denn PHP kompiliert?
... zuletzt so:
./configure
--prefix=/usr/share
--datadir=/usr/share/php
--bindir=/usr/bin
--libdir=/usr/share
--with-config-file-path=/etc
--with-exec-dir=/usr/lib/php/bin
--with-mysql=/usr
--with-pdflib=yes
--with-pdflib=/usr/lib/pdflib/bind/c
--with-gd=yes
--enable-gd-native-ttf
--enable-gd-imgstrttf
--with-tiff-dir=/usr
--with-jpeg-dir=/usr
--with-png-dir=/usr
--with-xpm-dir=/usr/X11R6
--with-zlib=yes
--with-bz2
--with-gmp
--with-xml
--with-dom
--with-ttf
--with-t1lib
--with-mcal=/usr
--with-imap=yes
--with-imap-ssl=yes
--with-xslt-sablot=/usr
--with-ftp
--with-ndbm
--with-gdbm
--with-mcrypt
--with-gettext
--enable-versioning
--enable-yp
--enable-bcmath
--enable-trans-sid
--enable-inline-optimization
--enable-track-vars
--enable-magic-quotes
--enable-safe-mode
--enable-sockets
--enable-sysvsem
--enable-sysvshm
--enable-shmop
--enable-calendar
--enable-mbstring
--enable-exif
--enable-ftp
--enable-memory-limit
--enable-wddx
--enable-filepro
--enable-dbase
--enable-ctype
--disable-debug
--enable-force-cgi-redirect
--enable-discard-path
--enable-sigchild
--with-openssl
--with-apxs=/usr/sbin/apxs
die mod_php habe ich testweise auch schon mal auskommentiert, das hat jedoch nichts geändert. Ich hatte eigentlich vor, den AddHandler nur in den <vhost> einzufügen, für den suPHP notwendig ist, alle anderen sollten weiter als modul laufen. Aber wie gesagt, komplettes auskommentieren brachte erst mal Fehler, weil in der confixx_vhost.conf noch irgendwelche Einräge drinstehen, wie z.B.:
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /home/www/empty
die ich dann auch erst auskommentieren mußte, da sich sonst der Apache nicht mehr starten ließ. Dann als alles auskommentiert war, lief es auch nicht, es waren genau die gleichen Effekte und log-Einträge wie jetzt auch.

Ich bin mir aber auch nicht so sicher, was im configure-String für php ales rein muß (bin kein Profi), ich benötige in jedem Fall gd, pdf, mysql und alles was Standard ist sowieso. Hab nen Kunden der mit Dreamweawer arbeitet und da arge Probleme mit den Dateirechten hat: entweder kann er nicht auf von Scripten erstellte/bearbeitete Dateien zugreifen oder umgekehrt ...

Hast Du vielleicht ne Idee für N sinnvolles /.configure ?


Gruß
André
jamesb
Posts: 661
Joined: 2002-05-08 15:35
Location: Karlsruhe

Re: Problem mit suPHP / PHP

Post by jamesb »

Ã?bersetze dein PHP mal so:

Code: Select all

'./configure' '--with-config-file-path=/etc/apache-ssl' '--with-gd' '--with-freetype' '--with-jpeg-dir=/usr/lib' '--with-png=/usr/lib' '--with-mysql' '--enable-memory-limit' '--enable-force-cgi-redirect' '--with-zlib' '--with-bz2' '--with-gettext' '--with-imap' '--with-ldap' '--with-ming' '--with-pspell' '--with-mm' '--enable-sockets' '--with-snmp' '--enable-ftp' '--enable-trans-sid' '--enable-calendar' '--enable-bcmath' '--with-mcrypt' '--with-mhash' '--with-xml'
Und kopiere das PHP-Binary nach /usr/local/bin
In der config.h von suPHP gibst du dann diesen Pfad für das PHP-Binary an.

Der Entwickler von suPHP weiß übrigens, dass da irgendwas faul ist, weiß aber nicht, was, und ist derzeit auf Fehlersuche.

JamesB
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: Problem mit suPHP / PHP

Post by arty »

Hi,
aly2000 wrote:
...
--with-apxs=/usr/sbin/apxs
da ist bereits ein Fehler, Du benötigst kein APXS, wenn Du PHP als CGI laufen lässt!

bye
arty
jamesb
Posts: 661
Joined: 2002-05-08 15:35
Location: Karlsruhe

Re: Problem mit suPHP / PHP

Post by jamesb »

@arty: Wie's aussieht, existierte schon ein PHP-Binary, denn sonst hätte suPHP sofort gemeckert. Aber trozdem hast du recht, dise Config-Einstellungen sind absolut sinnlos, wenn man ein CGI-PHP bauen will...

EDIT:

Ihr müsst bei dem Config-String oben (also bei meinem) noch den Config-Dir-Pfad anpassen, ansonsten sollte dieser bei 99% aller PHP-Scripte funktioniern. Und suPHP 0.2.3 hat scheinbar keinen Fehler, sonst würde mein Server jetzt nichtmehr laufen *g*
Es wäre übrigens intressant zu wissen, welche Apache-Version ihr alle einsetzt, bei denen suPHP nicht funktioniert.

JamesB
Anonymous

Re: Problem mit suPHP / PHP

Post by Anonymous »

... ok, danke erst mal, ich werde mich nacher mal dran setzen, und php noch mal mit obigem configure kompilieren ...

das sagt meine apache beim Starten:
[Wed Feb 26 00:15:20 2003] [notice] SIGUSR1 received. Doing graceful restart
[Wed Feb 26 00:15:22 2003] [notice] Apache/1.3.27 (Unix) mod_throttle/3.0 mod_ssl/2.8.12 OpenSSL/0.9.6h PHP/4.3.1 mod_perl/1.25 mod_layout/1.0 mod_fastcgi/2.2.2 mod_dtcl configured -- resuming normal operations
[Wed Feb 26 00:15:22 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Feb 26 00:15:22 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Feb 26 00:15:22 2003] [warn] long lost child came home! (pid 6455)
bis dann
André
Anonymous

Re: Problem mit suPHP / PHP

Post by Anonymous »

So, nun habe ich das mal so gemacht, außer
--with-config-file-path=/etc
habe ich angepaßt. Nun klappt suPHP, allerdings wenn ich phpinfo() aufrufe, sieht alles so ziemlich leer aus, alle Angaben im /.configure sind offenbar nicht übernommen worden:
System Linux pxxxxxx 2.4.18 #1 Sat Apr 20 16:15:17 CEST 2002 i686
Build Date Feb 26 2003 21:12:09
Configure Command './configure'
Server API CGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php.ini
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
Debug Build no
Thread Safety disabled
Registered PHP Streams php, http, ftp
und es wurde auch keine neue php.ini geschrieben, ist noch die alte - das ist doch bestimmt nicht korrekt, oder?

wie nun weiter????

Gruß André
Anonymous

Re: Problem mit suPHP / PHP

Post by Anonymous »

Juch_huh,

es läuft!!! nach fast 2 Wochen habe ich es gepackt!!! Das ganze muß irgend ein Pfad Problem gewesen sein (in den obersten 5 Zeilen) ...
Hier noch mal mein /.configure String (sollte auf jedem RootServer der noch nicht großartig verändert wurde laufen):
./configure
--prefix=/usr/local
--datadir=/usr/local/php
--bindir=/usr/local/bin
--libdir=/usr/local
--with-config-file-path=/etc
--with-mysql=/usr
--with-pdflib=yes
--with-gd=yes
--enable-gd-native-ttf
--enable-gd-imgstrttf
--with-tiff-dir=/usr
--with-jpeg-dir=/usr
--with-png=/usr
--with-zlib=yes
--with-bz2
--with-gmp
--with-xml
--with-dom
--with-ttf
--with-t1lib
--with-mcal=/usr
--with-imap=yes
--with-imap-ssl=yes
--with-xslt-sablot=/usr
--with-ftp
--with-ndbm
--with-gdbm
--with-mcrypt
--with-gettext
--enable-versioning
--enable-yp
--enable-bcmath
--enable-trans-sid
--enable-inline-optimization
--enable-track-vars
--enable-magic-quotes
--enable-safe-mode
--enable-sockets
--enable-sysvsem
--enable-sysvshm
--enable-shmop
--enable-calendar
--enable-mbstring
--enable-exif
--enable-ftp
--enable-memory-limit
--enable-wddx
--enable-filepro
--enable-dbase
--enable-ctype
--disable-debug
--enable-discard-path
--enable-sigchild
--with-openssl
--with-freetype
--with-ldap
--with-mm
--enable-force-cgi-redirect
Vielen Dank noch mal allen, die sich die Mühe gemacht haben, mir helfen zu wollen ...

Gruß André