nix läuft mehr :((

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
pedä
Posts: 51
Joined: 2002-08-13 19:30

nix läuft mehr :((

Post by pedä » 2003-02-09 23:36

hallo zusammen!!!

folgendes problem:

in /var/log/warn stehen fehlermeldungen
bind: adress already in use

suse sagt dazu ich sollte rctab -r eingeben..
aber der befehl "rctab" ist garnicht erst auf meinem root L zu finden..

wie kann ich nun diesen befehl ausführen oder den fehler auf andere art und weise beheben?

grüssels
pedä

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: nix läuft mehr :((

Post by floschi » 2003-02-09 23:45

Hi !

Der winzig kleine Ausschnitt aus der Fehlermeldung sagt konkret gar nichts, sorry.

Ich tippe mal darauf, dass du einen Port 2x benutzen willst, was nicht geht. Evtl. willst du einen Dienst zum einen als Standalone starten, zum anderen mittles inetd - der kann aber den Post nicht mehr nutzen und deshalb sagt er dir, dass der Port bereits genutzt wird (already in use).

Evtl. mehr Details...


Grüßle

Olfi ;)

pedä
Posts: 51
Joined: 2002-08-13 19:30

Re: nix läuft mehr :((

Post by pedä » 2003-02-10 00:03

Hallo olfi!

tut mir leid.. muss grad über lynx auffm root versenden, weil ier zu haus überhaupt nix mehr geht! (über 3 stunden versuche ich nun hier rein zu posten, per lynx funktionierts sofort) deswegen die etwas kurze message

also jezze mal genauer:

ausgefallen sind bis jetzt: smtp, pop und ftp...

alle drei dienste werden aufgrund des doppelstarts beendet (denke ich mal)

fehlermeldungen werden in /var/log/mail nicht mehr geschrieben, weiß der henker, aber das file bleibt einfach leer.. :(

in /var/log/warn steht:

Feb 9 19:47:04 vondreaming /usr/sbin/named[3243] NOQUEUE SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Adress already in use

Feb 9 20:55:49 vondreaming inetd[6272] ftp/tcp (2): bind: adress already in use

feb 9 20:55.49 vondreaming inetd[6272] pop3/tcp (2) bind adress already in use

empfang von email geht noch (teilweise - ein paar sind verloren geangen, weiß noch nicht warum)

versand von email über outlook unmöglich, über the bat! innerhalb des systems (also auf dem selben server) zu 100% mögich zu anderen servern nur teilweise...

ftp nur download möglich, upload nicht.

hmmmm.. noch was?
apache restart, sendmail restart, indetd restart sogar server restart..

alles schon gemacht. keine chance.. der will nich mehr.. ;)

angefangen hast gestern nacht
grüssels
pedä

pedä
Posts: 51
Joined: 2002-08-13 19:30

Re: nix läuft mehr :((

Post by pedä » 2003-02-10 01:03

hat keiner ne ahnung, wie ich an "rctab" komme?

das programm müsste doch eigentlich mit auf meinem server liegen?!!! :((

grüssels

Anonymous

Re: nix läuft mehr :((

Post by Anonymous » 2003-02-10 09:03

Ich find auf diversen SuSEVersionen kein rctab

Karlo

pedä
Posts: 51
Joined: 2002-08-13 19:30

Re: nix läuft mehr :((

Post by pedä » 2003-02-10 10:32

Karlo wrote:Ich find auf diversen SuSEVersionen kein rctab

Karlo
hmmm.. soll das jetzt heißen, daß man sich damit abfinden muß, oder soll das heißen, daß man es auch nachinstallieren kann?

grüssels
pedä

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: nix läuft mehr :((

Post by floschi » 2003-02-10 10:52

Nein, ich denke nicht, dass du das brauchst.

Erstmal: um welche Dienste genau handelt es sich, also welcher MTA, welcher POP, welcher FTPd?

Dann, was sagt ein ps aux? Laufen die Dienste als Standalone?

Dann, was genau steht in deiner inetd.conf?


Grüßle

Olfi ;)

pedä
Posts: 51
Joined: 2002-08-13 19:30

Re: nix läuft mehr :((

Post by pedä » 2003-02-10 11:09

olfi wrote:Nein, ich denke nicht, dass du das brauchst.

Erstmal: um welche Dienste genau handelt es sich, also welcher MTA, welcher POP, welcher FTPd?

Dann, was sagt ein ps aux? Laufen die Dienste als Standalone?

Dann, was genau steht in deiner inetd.conf?


Grüßle

Olfi ;)
proftpd läuft auf meinem root, dazu sendmail als mailserver..

Code: Select all

root     11049  0.0  0.9  4280 2292 ?        S    10:09   0:00 sendmail: server pD955ADAC.dip.t-dialin.net [217.85.173.172] ch
root     11051  0.0  0.9  4320 2420 ?        S    10:09   0:00
die sendmaildienste stehen noch öfter im psaux :((
werden aber nicht ausgeführt.. sie häufen sich an..

EDIt: die probleme mit dem mailversand und dem ftp haben sich erledigt..
es lag an unserem router.. ;)))

aber nichtsdestotrotz habe ich immernoch die fehlermeldungen in /var/log/warn...

inetd ist so ein thema...
hab gestern im netz was gefunden, was auf meine fehlermeldungen zutrifft.
smtp auskommentieren und inetd killen, dann neustart..
hat aber leider auch nix gebracht..

nun steht in der inetd.conf smtp auskommentiert, ftp und pop nicht..

grüssels