komisches datenbankverhalten bei mysql

MySQL, PostgreSQL, SQLite
cybernd
Posts: 83
Joined: 2002-08-08 14:39

komisches datenbankverhalten bei mysql

Post by cybernd » 2003-02-05 19:28

hmm heute bin ich doch glatt verzweifelt beim versuch courier mit mysql zu kombinieren

nachdem ich irgendwann mal die sqls mitzuloggen begann wurde ich darauf aufmerksam, das es auf einmal nicht mehr möglich war sich über localhost als mysql root / postfix user einzuloggen

gang ins webmin => user => root => passwort ändern - auf das selbe wie zuvor .. eingabe des alten passwortes

sieheda der user funktioniert wieder über ssh => mysql -u root -p

kurze zeit später ...
der user geht nicht mehr als localhost .. webmin bzw. php können aber nach wie vor connecten

courier imap runtergefahren ...
mysql runtergefahren ..

alles hochgefahren ...
per webmin die user wieder korrigiert ..

alles runtergefahren ..
alles hochgefahren ...

sieheda jetzt scheinen wieder alle user zu funktionierne und courier kann entlich auf die mysql connecten

dennoch stimmt mich der fehler sehr bedenklich ...
was kann diese inkonsistenz der mysql user datenbank hervorgerufen haben? hardwaredeffekt? softwaredeffekt?

hat jemand eine idee?
danke
cybi

cybernd
Posts: 83
Joined: 2002-08-08 14:39

Re: komisches datenbankverhalten bei mysql

Post by cybernd » 2003-02-05 19:50

erweiterung der probleme ...

postfix selbst funktionierte bisher problemlos ...

aber jetzt seit dem diese problematik auftaucht kann sich postfix nicht mehr connecten

fehlermessage: postfix@localhost denied

manuelles ausprobieren
postfix kann ich zum einloggen verwenden
postfix@localhost hingegen wirft mir einen fehler

hmmmm
cybi

cybernd
Posts: 83
Joined: 2002-08-08 14:39

Re: komisches datenbankverhalten bei mysql

Post by cybernd » 2003-02-06 01:29

hmm ich erweitere meine beiträge:

postfix benutzte den user postfix
courier-imap sollte auch den user postfix benutzen

d.h. einfach ein geteilter user für mails, zum zugriff auf die datenbank mail

resultat:
postfix starten
courier-imap starten => schwup datenbankzugriffsystem deffekt (weiß nicht was exakt dabei kaputt geht ... )

....
hab die datenbanken vom vortag eingespielt ...

einen user courierImap in mysql angelegt mit den identen rechten wie der user postfix

courier-imap bekam die zuweisung dieses users ..

sieheda alles läuft diesmal fehlerfrei ..
ohne seiteneffekte jeglicher art


...
falls jemand meinen denkfehler bei der sache sieht möge er sich melden
ich bin noch immer der meinung das man sich beliebig oft mit einem user einloggen kann und dies eigentlich gehen hätte müssen ..

cybi

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: komisches datenbankverhalten bei mysql

Post by oxygen » 2003-02-06 06:54

Hm, vielleicht besteht eine Diskrepanz zwischen den Rechten die du über den Socket hast und den Rechten wenn du normal über die IP connectest.

cybernd
Posts: 83
Joined: 2002-08-08 14:39

Re: komisches datenbankverhalten bei mysql

Post by cybernd » 2003-02-06 10:18

mhmmm laut log wurden beide verbindungen als "localhost" identifiziert

und das müsste ja eigentlich, das einzige sein, was für die rechtevergabe zählt oder? müsste mich mit dem fehlverhalten wohl oder übel mal bei einer offizielleren mysql mailingliste melden .. maybe wissen die ja wodurch so ein verhalten ausgelöst werden kann

so oder so darf so etwas eigentlich nicht passieren
denn eine grundlegende aufgabe des rdbms besteht darin die zugriffe zu kapseln und somit die integrität der daten zu gewährleisten, wodurch ich zur auffassung komme, das es unter absolut keinem umstand dazu kommen darf, das ein client das rechtevergabesystem durcheinander würfeln kann, sodaß ich mich nicht mehr manuell über mysql -u user -p einloggen kann ... (selbst restart des servers brachte da nichts mehr - war schon im datenverzeichnis vergurkt)


da ich aber zu faul bin dem fehler nachzugehen freue ich mich einfach mal, das es jetzt funktioniert ... vielleicht bin ich ja mutig genug und probier das ganze nach dem nächsten updaten der software wieder .. vielleicht ja nur ein bug der 3.23.54er mysql (den ich wohl melden müsste, damit er behoben wird)

cybi