xchat und glib

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
randar
Posts: 73
Joined: 2002-08-31 12:01

xchat und glib

Post by randar »

hi
ich bekomme dne fehler das die glib net gefundne wird in der neusten version, ich habe sie aber instaliert. Ich hab mal in die congigure.log geguckt unbd da steht folgendes drinne,
configure:11390: checking for GLIB - version >= 2.0.3
configure:11535: result: no
configure:11571: gcc -o conftest -g -O2 conftest.c >&5
configure:11551:18: glib.h: No such file or directory
configure: In function `main':
configure:11563: `glib_major_version' undeclared (first use in this function)
configure:11563: (Each undeclared identifier is reported only once
configure:11563: for each function it appears in.)
configure:11563: `glib_minor_version' undeclared (first use in this function)
configure:11563: `glib_micro_version' undeclared (first use in this function)
configure:11574: $? = 1
configure: failed program was:
#line 11549 "configure"
#include "confdefs.h"

#include <glib.h>
#include <stdio.h>

#ifdef F77_DUMMY_MAIN
# ifdef __cplusplus
extern "C"
# endif
int F77_DUMMY_MAIN() { return 1; }
#endif
int
main ()
{
return ((glib_major_version) || (glib_minor_version) || (glib_micro_version));
;
return 0;
}
configure:11617: error: "Cannot find glib"
Was soll ich da machen?

Also ich hab die glib erfolgriehc instaliert kam kein fehler oder so.

edit:

Vieleicht sollte ich hinzufügen das ich kkgconfig neu instaliert habe aber mit --with-glib-dir=/usr/lib

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: xchat und glib

Post by captaincrunch »

Wenn er die glib-Headerfiles (*.h) nicht findet, hast du wahrscheinlich die zugehörigen Devel-Pakete nicht installiert. Ganz simpel ... :wink:
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

randar
Posts: 73
Joined: 2002-08-31 12:01

Re: xchat und glib

Post by randar »

wo kann ich die devel packete downloaden?
Ich hab gegoogled aber nix gefunden :(
Aber die müssten eigentlich instaliert sein, weil unter yast2 ist das instaliert.

Kann das net sien das ich in der pkgconfig was falsch habe? Was muss ich dne dazuschreiben damit glib richtig geht?

Anonymous

Re: xchat und glib

Post by Anonymous »

rpm -qa|grep libc
glibc-2.2.5-164
libcap-1.92-216
glibc-locale-2.2.5-151
glibc-devel-2.2.5-151

Karlo

randar
Posts: 73
Joined: 2002-08-31 12:01

Re: xchat und glib

Post by randar »

Sorry wenn ich frage aber was ist das alles? Kannst du mri das erklären?