Connectprobleme zu postgres

MySQL, PostgreSQL, SQLite
as-n
Posts: 196
Joined: 2002-12-19 17:42

Connectprobleme zu postgres

Post by as-n » 2003-01-30 11:28

Hallo,

ich habe hier postgres auf SuSE8.0.
Postmaster ist mit der -i Option gestartet und läuft auch, lsof -i sagt dazu:

postmaste 17465 postgres 3u IPv4 455445134 TCP *:postgresql
(LISTEN)

Mittels Console kan ich mich auch in die Datenbank einloggen, aber der Zugriff über 'telnet localhost 5432' oder mit Ikonboard klappt nicht.
Beim Versuch in Ikonboard die postgres db zu initialisieren kommt:

pgSQL connection error: connectDBStart() -- connect() failed: No such
file or directory Is the postmaster running at 'localhost' and
accepting connections on Unix socket '5432'?

Debug meldet beim Versuch mittel telnet:

BackendStartup: forkedDEBUG: reaping dead processes
DEBUG: child process (pid 32494) exited with exit code 0

Woran könnte das liegen?

Ciao
AS-N

Anonymous

Re: Connectprobleme zu postgres

Post by Anonymous » 2003-01-30 17:47

schau mal ob in der datei /var/lib/pgsql/data/postgresql.conf

"tcpip_socket = true"

gesetzt ist

as-n
Posts: 196
Joined: 2002-12-19 17:42

Re: Connectprobleme zu postgres

Post by as-n » 2003-01-30 20:36

In der postgresql.conf steht:

tcpip_socket=true
port=5432

Ciao
AS-N

Anonymous

Re: Connectprobleme zu postgres

Post by Anonymous » 2003-01-30 21:32

dann fällt mir nur noch die zugangskontrolle mittel pg_hba.conf ein,
sieht bei so aus

Code: Select all

host       database     loginame   x.x.x.x     255.255.255.248    md5

as-n
Posts: 196
Joined: 2002-12-19 17:42

Re: Connectprobleme zu postgres

Post by as-n » 2003-01-30 21:57

Kann es auch nicht sein, hier habe ich folgendes drin:

local all trust
host all 127.0.0.1 255.255.255.255 trust


Mensch, woran kann es denn noch liegen?

Ciao
AS-N

Anonymous

Re: Connectprobleme zu postgres

Post by Anonymous » 2003-01-30 22:25

Code: Select all

local	all				trust
host	all         127.0.0.1	255.255.255.255    	trust
gib doch mal zusätzlich, aber nur zum testen
# TYPE DATABASE USER IP-ADDRESS IP-MASK METHOD
host all all 0.0.0.0 0.0.0.0 trust

und probliere es dann nochmal
[/quote]

as-n
Posts: 196
Joined: 2002-12-19 17:42

Re: Connectprobleme zu postgres

Post by as-n » 2003-01-30 23:27

Brint auch nix. :(

Gibt es bei der SuSE8.0 vielleicht noch irgend eine Zeile in irgend einer conf Datei, welche man auskommentieren muss oder sowas?

Ciao
AS-N

Anonymous

Re: Connectprobleme zu postgres

Post by Anonymous » 2003-01-31 13:11

AS-N wrote:Brint auch nix. :(

Gibt es bei der SuSE8.0 vielleicht noch irgend eine Zeile in irgend einer conf Datei, welche man auskommentieren muss oder sowas?

Ciao
AS-N
hast du vielecht eine firewall am laufen, mir fällt sonst auch nichts mehr ein

ciao
chris

as-n
Posts: 196
Joined: 2002-12-19 17:42

Re: Connectprobleme zu postgres

Post by as-n » 2003-01-31 13:17

Hallo, es geht! :-D :-D :-D
Habe postgres nochmal runtergeschmissen und alles von ganz vorn neu installiert und eingerichtet.
Scheinbar war da irgend wo ein Tippfehler oder ein falscher Zeilenumbruch etc.
Auf telnet antwortet postgres zwar immer noch nicht, aber sowohl Ikonboard, als auch phpBB können connecten.
Herzlichen Dank an dich.

Ciao
AS-N

Anonymous

Re: Connectprobleme zu postgres

Post by Anonymous » 2003-01-31 14:25

AS-N wrote:Hallo, es geht! :-D :-D :-D
Habe postgres nochmal runtergeschmissen und alles von ganz vorn neu installiert und eingerichtet.
Scheinbar war da irgend wo ein Tippfehler oder ein falscher Zeilenumbruch etc.
Auf telnet antwortet postgres zwar immer noch nicht, aber sowohl Ikonboard, als auch phpBB können connecten.
Herzlichen Dank an dich.

Ciao
AS-N

freude :-))