Komische Meldung unter phpMyAdmin!!

MySQL, PostgreSQL, SQLite
schorsch
Posts: 43
Joined: 2003-01-28 02:42

Komische Meldung unter phpMyAdmin!!

Post by schorsch » 2003-01-29 19:38

so bin Linux Newbie :twisted: und nun starte ich phpMyAdmin und es kommt diese Meldung:

Das $cfg['PmaAbsoluteUri']-Verzeichnis MUSS in Ihrer Konfigurationsdatei angegeben werden!

Könnt ihr mir sagen was genau ich da machen muss ?

Danke,
Schorsch

scythe42
RSAC
Posts: 154
Joined: 2002-10-14 18:30
Location: Internet

Re: Komische Meldung unter phpMyAdmin!!

Post by scythe42 » 2003-01-29 19:44

RTFM - ist in den Documentention.txt von phpMyAdmin bestens beschrieben...
Sets here the complete url (with full path) to your phpMyAdmin
version. E.g.
http://www.your_web.net/path_to_your_phpMyAdmin_directory/.
phpMyAdmin needs this setting, because of requirements of the
HTTP protocol, explained in RFC2616, section 14.30.
Don't forget the slash at the end of your url. The url must
contain characters that are valid for a url, and on some
servers, the path is case-sensitive.
Starting with version 2.3.0, you can try to leave this
parameter empty, because the program tries to auto-detect its
proper value. Additional details are in the configuration file.
Alternatively, this setting can be dynamically completed. For
example, you can try to use such a kind of code:
Und dann kommen die Beispiele, die man sogar via copy and paste übernehmen kann...

Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Komische Meldung unter phpMyAdmin!!

Post by Matthias Diehl » 2003-01-29 19:52

Oder aber: Wenn ansonsten phpmyadmin funktioniert (Datenbanken werden angezeigt etc.) dann kannst Du die Warnung auch ausschalten.
In der config.inc.php den Eintrag ändern auf

Code: Select all

$cfg['PmaAbsoluteUri_DisableWarning'] = TRUE;
Dann ist die Warnung weg ! Steht auch genauso in der config.inc.php drin :)

schorsch
Posts: 43
Joined: 2003-01-28 02:42

Re: Komische Meldung unter phpMyAdmin!!

Post by schorsch » 2003-01-29 19:55

jo genau die datenbanken werde wunderbar angezeigt! also kann ich die meldung getrost ignorieren ?!

Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Komische Meldung unter phpMyAdmin!!

Post by Matthias Diehl » 2003-01-29 19:59

Ja, kannste !
Oder aber schaltest sie aus wie oben beschrieben

schorsch
Posts: 43
Joined: 2003-01-28 02:42

Re: Komische Meldung unter phpMyAdmin!!

Post by schorsch » 2003-01-29 20:03

ok thx.

wie schütze ich das phpMyAdmin nun damit man benutzername und passwort eingben muss ?

bis jetzt hat da jeder zugriff

Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Komische Meldung unter phpMyAdmin!!

Post by Matthias Diehl » 2003-01-29 20:07

Das kannst Du entweder mit einer .htaccess und .htpasswd Datei machen oder z.B. wenn Du Confixx benutzt mit dem Eintrag

Code: Select all

$cfg['Servers'][$i]['auth_type']     = 'http';

scythe42
RSAC
Posts: 154
Joined: 2002-10-14 18:30
Location: Internet

Re: Komische Meldung unter phpMyAdmin!!

Post by scythe42 » 2003-01-29 20:08

such mal nach "htaccess" im Forum.... erster link hilf direkt...

schorsch
Posts: 43
Joined: 2003-01-28 02:42

Re: Komische Meldung unter phpMyAdmin!!

Post by schorsch » 2003-01-29 20:44

hmm habe es jetzt mal nach dieser Anleitung probiert, allerdings funzt es nicht, es kommt einfach keine Login Box beim Verzeichnisaufruf.

Muss ich sonst noch was einstellen, z.b. in der httpd.conf ??

Gruß,
Schorsch

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Komische Meldung unter phpMyAdmin!!

Post by floschi » 2003-01-29 20:44

Ich würde an deiner Stelle der unüberlesbaren Anleitung, die scythe42 netterweise hier nochmal zur Verdeutlichung gepostet hat, folgen. Meistens geht sonst was schief, wenn phpmyadmin über https betrieben wird, was es ja auf jeden Fall sollte ;)

schorsch
Posts: 43
Joined: 2003-01-28 02:42

Re: Komische Meldung unter phpMyAdmin!!

Post by schorsch » 2003-01-30 01:02

hallo,

ich würde es jetzt trotzdem mal gerne fürs erste nur mit .htaccess schützen. allerdings klappt es nicht.

Habe probehalber .htaccess und .htpasswd ins selbe Verzeichnis gelegt:

meine .htaccess schaut so aus:
# AuthUserFile ist die Passwortdatei
AuthUserFile /srv/www/htdocs/phpMyAdmin/.htpasswd
# AuthName ist der Name des Schutzbereichs
AuthName phpMyAdmin
# AuthType ist der Schutz-Typ
AuthType Basic
# Was soll limitiert werden
<Limit GET>
require valid-user
</Limit>
.htpasswd so:
root:hier_das_verschlüsselte_pw
Ist das soweit richtig ?? Weil es klappt einfach nicht, es kommt keine login und passwort abfrage wenn ich in das verzeichnis wechsel, kann immer noch ganz normal drauf zugreifen :(

Muss ich sonst noch was einstellen ? Habe SuSE Linux 8.1 drauf.

Danke für Tips!!

Gruß,
Schorsch

scythe42
RSAC
Posts: 154
Joined: 2002-10-14 18:30
Location: Internet

Re: Komische Meldung unter phpMyAdmin!!

Post by scythe42 » 2003-01-30 05:52

du musst die httpd.conf vom apache noch anpassen....

Da steht bestimmt folgendes drin:
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
Sprich kein Override der Berechtigungen ohne vorherige Erlaubnis. Klemm einfach noch sowas in die httpd.conf rein. (natürlich pfad anpassen)
<Directory "/var/www/htdocs/phpMyAdmin">
deny from all
AllowOverride AuthConfig
Order deny,allow
</Directory>
Kannst natürlich auch dir erste Direktive anbpassen, so das ein Override AuthConfig immer möglich ist.

Und wichtig NIEMALS die .htpasswd in ein Verzeichnis legen, das via Webbrowser zusgänglich ist!.