Sendmail und Spamassassin wollen nicht...

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
suntzu
RSAC
Posts: 698
Joined: 2002-12-20 19:47
Location: Mönchengladbach

Sendmail und Spamassassin wollen nicht...

Post by suntzu » 2003-01-29 12:45

Hallo,

ich habe ein Debian Woody-System mit funktionierendem Sendmail, fetchmail, procmail und installiertem spamassassin. In meiner procmailrc steht:

Code: Select all

:0fw
| /usr/bin/spamc
Leider werden die E-Mails gar nicht erst durch Spamassassin geschickt. Nun habe ich entdeckt, dass in webmin steht, dass sendmail mit dem local_procmail feature aktiviert werden muss. Also habe ich ein wenig gesucht und das Feature dann in die sendmail.mc eingetragen.

Code: Select all

FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
Danach ein sendmailconfig, anscheinend hat auch alles funktioniert - die Mails werden aber leider immer noch nicht gescannt. Kann mir vielleicht jemand helfen? Bei Bedarf poste ich auch gewünschte Konfigurationsdateien.

Danke,
Dominik

[tom]
RSAC
Posts: 671
Joined: 2003-01-08 20:10
Location: Berlin

Re: Sendmail und Spamassassin wollen nicht...

Post by [tom] » 2003-01-30 03:58

Hast Du schon mal einen Blick auf http://www.rootforum.org/faq/index.php? ... =002&id=63 geworfen?

Ich konnt da Teile von gebrauchen und es lief dann auch sofort. Hab allerdings Debian/postfix/procmail/spamassassin.

Der Link http://www.cts.wustl.edu/cts/help/Mail_ ... _Conf.html am Ende ist auch sehr empfehlenswert.

[TOM]