Openwebmail cookie problem

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
blecky
Posts: 6
Joined: 2002-10-15 16:03

Openwebmail cookie problem

Post by blecky » 2003-01-15 16:53

Ich habe Openwebmail installiert und kann das login aufrufen. Nach der Eingabe von Username und Passwort geschieht eine Weile nichts, und dann kommt die Meldung "your request didn't contain the proper session ID cookie -- access denied!"

Laut FAQ liegt das am verfügbaren Platz oder am Quota. Ich habe jedoch genügend Platz und das Quota ist "unlimited". Im Browser sind cookies erlaubt.... :cry:

Hat einer eine Idee was zu tun?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Openwebmail cookie problem

Post by captaincrunch » 2003-01-15 18:26

Hast du mal versucht, die lokal auf der Platte befindlichen Cookies zu läschen, und dich dann nochmal anzumenlden ?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

blecky
Posts: 6
Joined: 2002-10-15 16:03

Re: Openwebmail cookie problem

Post by blecky » 2003-01-16 09:59

Danke für den Tip, aber das ist es nicht. (Cookies werden alle beim beenden des Browsers gelöscht).

Ich denke, es ist ein Zugriffs-Problem, die Meldung kommt nach ca. 2 Minuten (Timeout?). Für den Bruchteil einer Sekunde erscheint eine Meldung "Software Error" und dann sofort die vorher genannte Meldung Cookie..

Ich habe auch mehrfach die user und group sowie lese/schreib/ausführ-rechte überprüft - alles wie es sein soll.

Anonymous

Re: Openwebmail cookie problem

Post by Anonymous » 2003-01-16 12:49

@ blecky
welche Authentifizierungs-Methode verwendest Du?

blecky
Posts: 6
Joined: 2002-10-15 16:03

Re: Openwebmail cookie problem

Post by blecky » 2003-01-16 13:02

auth_unix.pl und es sind auch /etc/passwd und /etc/shadow eingestellt.

Anonymous

Re: Openwebmail cookie problem

Post by Anonymous » 2003-01-16 18:33

Hallo blecky,

in welchem verzeichnis hast du openwebmail installiert?

poste doch mal deine openwebmail.conf

ciao

callum

blecky
Posts: 6
Joined: 2002-10-15 16:03

Re: Openwebmail cookie problem

Post by blecky » 2003-01-17 06:48

openwebmail.conf [B---] 0 L:[ 1+28 29/ 29] *(814 / 814b)= ? -1 ffffffffH
#
# Open WebMail configuration file
#
# This file contains just the overrides from openwebmail.conf.default
# please make all changes to this file.
#
# This file sets options for all domains and all users.
# To set options on per domain basis, please put them in sites.conf/domainname
# To set options on per user basis, please put them in users.conf/username
#
domainnames auto
auth_module auth_unix.pl
mailspooldir /var/mail
dbm_ext .pag
dbmopen_ext none
dbmopen_haslock no
ow_cgidir /home/www/webmail/bin/openwebmail
ow_cgiurl /bin/openwebmail
ow_htmldir /home/www/webmail/data/openwebmail
ow_htmlurl /data/openwebmail
logfile /var/log/openwebmail.log
spellcheck /usr/local/bin/ispell
default_language en

<default_signature>
--
Open WebMail Project (http://openwebmail.org)
</default_signature>

Verzeichnis webmail und darunter ist root.mail

openwebmail-*.pl sind 4755 root.mail

blecky
Posts: 6
Joined: 2002-10-15 16:03

Re: Openwebmail cookie problem

Post by blecky » 2003-01-17 06:50

Sorry, erste Zeile gehört raus, kam vom copy & paste des Editors....

Anonymous

Re: Openwebmail cookie problem

Post by Anonymous » 2003-01-17 07:52

Hallo blecky,

versuche mal

Code: Select all

dbmopen_haslock no 
auf yes zu setzen.

funktioniert das script im verzeichnis "webmail"?

ich werde mich heute abend oder morgen früh nochmal intensiver mit OW beschäftigen. ich maile dir dann mal meine config. habe im moment keinen zugriff...

du kannst aber mal probieren, ow in /home/confixx/html/cgi-bin zu installieren und, wie gesagt, dbmopen_haslock auf yes setzen.

da das script ja anscheinend ansonsten läuft, scheinen die rechte von suidperl bei dir ja zu stimmen.

ok, heute abend oder morgen früh dann mehr.

ciao

callum

blecky
Posts: 6
Joined: 2002-10-15 16:03

Re: Openwebmail cookie problem

Post by blecky » 2003-01-17 09:38

Danke für die Hilfe, aber das war's auch nicht.

Habe es mit yes und no probiert, bekomme aber immer noch eine Fehlermeldung (login failure). Dies lag offenbar daran, daß ich in der virtusertable

blecky error:No mailbox

gesetzt hatte, um zu erzwingen, daß nur an alias mail geschickt werden kann. Nach der Ã?nderung war dann wieder der alte Fehler da.

Software error:
alarm

For help, please send mail to the webmaster , giving this error message and the time and date of the error. Set-Cookie: blecky-sessionid=OWMkAXF5pyGp6; path=/ Set-Cookie: openwebmail-loginname=blecky; path=/; expires=Sun, 16-Feb-2003 08:23:58 GMT Set-Cookie: openwebmail-rememberme=; path=/; expires=Sun, 16-Feb-2003 08:23:58 GMT Set-Cookie: openwebmail-ssl=0; path=/ Date: Fri, 17 Jan 2003 08:23:58 GMT pragma: no-cache Content-Type: text/html; charset=iso-8859-1

Und im openwebmail.log:
Fri Jan 17 09:32:45 2003 - [25675] (IP) blecky - session cleanup - blecky-session-0.395990076781349
Fri Jan 17 09:32:45 2003 - [25675] (IP) blecky - login - blecky-session-0.59355760792187
Fri Jan 17 09:32:47 2003 - [25676] (IP) blecky - session error - request doesn't have proper sessionid cookie, access denied!


Confix habe ich nicht im Einsatz und daher auch nicht mehr das Verzeichnis. Ich benutze Webmin.

Anonymous

Re: Openwebmail cookie problem

Post by Anonymous » 2003-01-18 17:38

ok, hier ist meine openwebmail.conf:

Code: Select all

# To set options on per domain basis, please put them in sites.conf/domainname
# To set options on per user basis, please put them in users.conf/username
#
domainnames             auto
auth_module             auth_unix.pl
mailspooldir            /var/mail
dbm_ext                 .pag
dbmopen_ext             none
dbmopen_haslock         yes
ow_cgidir               /home/confixx/html/cgi-bin/openwebmail
ow_cgiurl               /cgi-bin/openwebmail
ow_htmldir              /home/confixx/html/data/openwebmail
ow_htmlurl              /data/openwebmail
logfile                 /var/log/openwebmail.log
spellcheck              /usr/sbin/ispell
default_language        de

<default_signature>
--
Open WebMail Project (http://openwebmail.org)
</default_signature>
hast du dem entsprechenden user ein verzeichnis "mail" mit schreibrechten eingerichtet?
gehören die files root und der gruppe mail?
hast du im verzeichnis "users.conf" den entsprechenden user angelegt? (einfach das SAMPLE-file kopieren und den namen des users geben)
und zu guter letzt: die faq auf http://www.openwebmail.net ist auch ganz hilfreich.

ciao

callum