Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
iggemonster
Posts: 80
Joined: 2002-07-16 10:47
Location: im inti net ;)

Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by iggemonster » 2003-01-05 22:50

Erst mal Guten Abend !

ich hoffe mir kann jemand helfen. Ich kann keine emails mehr abrufen. Ich kann anscheinen nicht mehr auf den "pop" server zugreifen.

Folgende Fehlermeldungen: (aus /var/log/messages)

Jan 5 22:46:00 p15097216 pop3d[1671]: unable to open Berkeley db /etc/sasldb: N
o such file or directory
Jan 5 22:46:00 p15097216 pop3d[1671]: unable to open Berkeley db /etc/sasldb: N
o such file or directory
Jan 5 22:46:00 p15097216 pop3d[1671]: accepted connection
Jan 5 22:46:03 p15097216 master[228]: process 1671 exited, status 0
Jan 5 22:46:07 p15097216 master[1672]: about to exec /usr/cyrus/bin/pop3d
Jan 5 22:46:07 p15097216 service-pop3[1672]: executed
Jan 5 22:46:07 p15097216 pop3d[1672]: unable to open Berkeley db /etc/sasldb: N
o such file or directory
Jan 5 22:46:07 p15097216 pop3d[1672]: unable to open Berkeley db /etc/sasldb: N
o such file or directory
Jan 5 22:46:07 p15097216 pop3d[1672]: accepted connection
Jan 5 22:46:10 p15097216 master[228]: process 1672 exited, status 0

So ein mist ! ich habe rein "garnichts" an einer config verändert.. geht von gestern auf heute nicht mehr :(

Danke schonmal für eure Hilfe !

EDIT:

Folgende Meldungen erhalte ich aus der selben Datei direkt nach einem reboot:

Jan 5 22:52:58 p15097216 xntpd[381]: kern_enable is 1
Jan 5 22:52:58 p15097216 xntpd[381]: using kernel phase-lock loop 0040
Jan 5 22:52:58 p15097216 xntpd[381]: frequency initialized -30.204 from /etc/nt
p.drift
Jan 5 22:52:58 p15097216 xntpd[381]: using kernel phase-lock loop 0041
Jan 5 22:52:58 p15097216 /usr/sbin/cron[396]: (CRON) STARTUP (fork ok)
Jan 5 22:52:59 p15097216 /USR/SBIN/CRON[430]: (root) CMD ( /etc/init.d/iptables
start)
Jan 5 22:52:59 p15097216 inetd[442]: pop3/tcp (2): bind: Address already in use
Jan 5 22:52:59 p15097216 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jan 5 22:53:00 p15097216 kernel: ip_conntrack (1983 buckets, 15864 max)

SORRY nochmal ein EDIT:

Folgendes hab ich aus /var/log/warn

Jan 5 22:21:53 p15097216 inetd[473]: pop3/tcp (2): bind: Address already in use
Jan 5 22:26:45 p15097216 pop3d[16437]: unable to open Berkeley db /etc/sasldb: No such file or directory

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by floschi » 2003-01-05 23:14

iggemonster wrote:Jan 5 22:21:53 p15097216 inetd[473]: pop3/tcp (2): bind: Address already in use
Die berühmte inetd vs. Daemon Geschichte...
iggemonster wrote:Jan 5 22:26:45 p15097216 pop3d[16437]: unable to open Berkeley db /etc/sasldb: No such file or directory
Gibt's die? Hat die die richtigen Rechte?

Und so ganz nebenbei, welcher MTA?


Grüßle

Olfi ;)

iggemonster
Posts: 80
Joined: 2002-07-16 10:47
Location: im inti net ;)

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by iggemonster » 2003-01-06 16:18

Hi olfi ! erstmal danke für deine Hilfe..

Also ich nutze noch immer sendmail !

und die oben angesprochene datei hab ich bereits gesucht, aber leider nicht gefunden.

Das Port ist auch nicht doppelt belegt...

ahh, und ich habe rein GARNICHTS verändert ! :(

Ich bitte da echt um eure Hilfe, da sonst einige meiner Kunden ihre emails nicht mehr abrufen können. Was natürlich nicht von Vorteil ist.

VIELEN DANK FÃ?R EURE BEMÃ?HUNGEN !!!

mario

Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by Matthias Diehl » 2003-01-06 16:49

Hast Du wenn Du NIX gemacht hast evtl. mal ein Yast Update gemacht ?
Der installiert dann gerne einen neuen POP. Prüfe mal ob NUR der QPopper installiert ist....
Denn der Port (110) wird schon von was anderem verwendet. Und pop3d klingt nicht nach Sendmail sondern nach Cyrus bzw. Imap. Der wird installiert wenn man auf SMTP AUTH stellt und dann ein Onlineupdate macht. Schmeiss den runter und installier notfalls den qpopper nochmal neu.

iggemonster
Posts: 80
Joined: 2002-07-16 10:47
Location: im inti net ;)

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by iggemonster » 2003-01-06 16:53

Hallo Matthias !

Cyrus ... Genau das hab ich da auch in nem logfile gesehen.. ich habe vor ca. 1 /12 wochen ein auto update gemacht ! Da hst du vollkommen recht. Allerdings verstehe ich nicht warum das Problem erst jetzt auftritt.

Hast du evtl. ne Idee wie ich das ganze beheben kann..? bzw. wie ich den wieder runter bekomme ! SMTP AUTH nutze ich, ich denk mal daran hats wohl gelegen !

THX
Last edited by iggemonster on 2003-01-06 16:55, edited 1 time in total.

Matthias Diehl
Posts: 315
Joined: 2002-09-24 13:26

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by Matthias Diehl » 2003-01-06 16:54

Wie oben geschrieben:

Cyrus runter, wenns noch nicht geht, qpopper wieder per RPM drauf

SCD
Posts: 8
Joined: 2002-07-07 02:52

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by SCD » 2003-01-06 17:03

Das gleiche Problem hatte ich gestern.

Lösungsweg bei mir war:

Deinstallation cyrus-imap(-devel) RPM
Serverneustart

@iggemonster

Das Problem ist bei mir auch erst nach einen Serverneustart aufgetreten.

iggemonster
Posts: 80
Joined: 2002-07-16 10:47
Location: im inti net ;)

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by iggemonster » 2003-01-06 17:05

also hab jetzt cyrus zumindets mal deaktiviert... werd jetzt mal versuchen den qpopper wieder aufzuspielen. danke schonmal für die tipps.. ich werd berichten wie´s gelaufen ist !

iggemonster
Posts: 80
Joined: 2002-07-16 10:47
Location: im inti net ;)

Re: Bitte Hilfe mit pop3/Nichts geht mehr ! :(

Post by iggemonster » 2003-01-06 18:14

so ! da bin ich wieder... ( oh ! *g* klingt ja fast wie ne drohung..hehe)

GESCHAFFT !!!!

Also, habe Cyrus deinstalliert. den "alten" qpopper wieder aktiviert und ES GEHT !

Vielen Dank.

Eins bleibt jedoch noch. Habe nachgesehen, das Update habe ich am 31.12. gemacht. und vom 04. auf den 05.01. geht´s auf einmal nicht mehr ???

nee nee....

Trotzdem ! Riesen Dankeschön, ohne deinen Tip wär ich da ersma nich drauf gekommen, wenn überhaupt.. ;)

iggemonster

EDIT:

grad erst SCD´s beitrag gesehen !

Der Server Neustart war´s !

DANKE