Debian, IPv6 und ich!

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
User avatar
Proteus
Posts: 289
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Debian, IPv6 und ich!

Post by Proteus »

Ja, ich habe es nicht so mit IPv6, ich weiß nur das sich die IPv6 irgendwie aus der MAC Adresse zusammensetzt. Ich weiß auch, dass das hier ein Root Forum für Server die als Webserver dienen. Aber vielleicht kann man mir ein paar Tipps geben warum bei mir im Lokalen Netzwerk(Intanet) IPv6 auf Debian 10 Buster so gar nicht funktionieren will.

Ich habe meine Netzwerkkarte, eine Intel Dual P Server Karte gebondet, das mein Switch das Trunking irgendwie nicht machen will. Hier erstmal einige grundlegende Informationen.

Code: Select all

auto lo
        iface lo inet loopback

auto ens6f0
        iface ens6f0 inet manual
        iface ens6f0 inet6 manual
        bond-master bond0

auto ens6f1
        iface ens6f1 inet manual
        iface ens6f1 inet6 manual
        bond-master bond0

auto bond0
        iface bond0 inet static
        address 192.168.178.3/24
        netmask 255.255.255.0
        gateway 192.168.178.1
        dns-nameservers 192.168.178.1
        dns-search fritz.box
        bond_mode 802.3ad

iface bond0 inet6 static
        pre-up /sbin/modprobe -q ipv6 ; /bin/true
        address fe80::215:17ff:feb4:30a9
        netmask 64
        dns-nameservers 2002:2eed:d79a:0:ca0e:14ff:fe8a:b028
        dns-search fritz.box
        bond_mode 802.3ad
Soweit ich das überblicken kann stimmen meine Einstellungen. Und auch der Server ist über IPv4 erreichbar.

Code: Select all

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: ens6f0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP group default qlen 1000
    link/ether 00:15:17:b4:30:a8 brd ff:ff:ff:ff:ff:ff
3: ens6f1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP group default qlen 1000
    link/ether 00:15:17:b4:30:a8 brd ff:ff:ff:ff:ff:ff
4: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:15:17:b4:30:a8 brd ff:ff:ff:ff:ff:ff
    inet 192.168.178.3/24 brd 192.168.178.255 scope global bond0
       valid_lft forever preferred_lft forever
    inet6 fe80::215:17ff:feb4:30a9/64 scope link
       valid_lft forever preferred_lft forever
    inet6 fe80::215:17ff:feb4:30a8/64 scope link
       valid_lft forever preferred_lft forever
Auch IPv6 scheint richtig konfiguriert zu sein, aber der Server ist darüber nicht erreichbar.

Hier nochmal die Ifconfig:

Code: Select all

ifconfig
bond0: flags=5187<UP,BROADCAST,RUNNING,MASTER,MULTICAST>  mtu 1500
        inet 192.168.178.3  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::215:17ff:feb4:30a9  prefixlen 64  scopeid 0x20<link>
        inet6 fe80::215:17ff:feb4:30a8  prefixlen 64  scopeid 0x20<link>
        ether 00:15:17:b4:30:a8  txqueuelen 1000  (Ethernet)
        RX packets 75068665  bytes 103460401306 (96.3 GiB)
        RX errors 0  dropped 2771  overruns 0  frame 0
        TX packets 37772626  bytes 6726190642 (6.2 GiB)
        TX errors 0  dropped 6 overruns 0  carrier 0  collisions 0

ens6f0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 00:15:17:b4:30:a8  txqueuelen 1000  (Ethernet)
        RX packets 37402456  bytes 55351196804 (51.5 GiB)
        RX errors 0  dropped 127  overruns 0  frame 0
        TX packets 18887299  bytes 3364383248 (3.1 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 27  memory 0xfb380000-fb3a0000

ens6f1: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 00:15:17:b4:30:a8  txqueuelen 1000  (Ethernet)
        RX packets 37666209  bytes 55805888996 (51.9 GiB)
        RX errors 0  dropped 448  overruns 0  frame 0
        TX packets 18885327  bytes 3361807394 (3.1 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 58  memory 0xfb320000-fb340000

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 1177  bytes 89012 (86.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1177  bytes 89012 (86.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Ein ping -6 PowerShell oder auch CMS bringt folgendes zu Tage:

Code: Select all

ping -6 server
Ping-Anforderung konnte Host "server" nicht finden. Überprüfen Sie den Namen, und versuchen Sie es erneut.

Code: Select all

ping -6 server.fritz.box
Ping-Anforderung konnte Host "server.fritz.box" nicht finden. Überprüfen Sie den Namen, und versuchen Sie es erneut.
Meine Hosts:

Code: Select all

127.0.0.1       localhost
192.168.178.3   server.fritz.box        server

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
Meine Hostname:

Code: Select all

server
Meine Resolve:

Code: Select all

search fritz.box
nameserver 192.168.178.1
Ping auf meine Fritz.Box:

ping -6 fritz.box

Code: Select all

Ping wird ausgeführt für fritz.box [2002:2eed:d79a:0:ca0e:14ff:fe8a:b028] mit 32 Bytes Daten:
Antwort von 2002:2eed:d79a:0:ca0e:14ff:fe8a:b028: Zeit<1ms
Antwort von 2002:2eed:d79a:0:ca0e:14ff:fe8a:b028: Zeit<1ms
Antwort von 2002:2eed:d79a:0:ca0e:14ff:fe8a:b028: Zeit<1ms
Antwort von 2002:2eed:d79a:0:ca0e:14ff:fe8a:b028: Zeit<1ms
Übersicht meiner Router-Einstellung betreffend IPv6:
You do not have the required permissions to view the files attached to this post.
LG
Proti

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"
User avatar
Proteus
Posts: 289
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Re: Debian, IPv6 und ich!

Post by Proteus »

Ich habe es nun irgendwie hinbekommen. Der Server ist nun auch über IPv6 ansprechbar. Frage mich nur wieso das nun automatisch ge-bondet wurde?

Code: Select all

# The loopback network interface
auto lo
        iface lo inet loopback

auto ens6f0
        iface ens6f0 inet manual
        bond-master bond0

auto ens6f1
        iface ens6f1 inet manual
        bond-master bond0

auto bond0
        iface bond0 inet static
        address 192.168.178.3/24
        netmask 255.255.255.0
        gateway 192.168.178.1
        dns-nameservers 192.168.178.1
        dns-search fritz.box
        bond_mode 802.3ad

auto ens6f0
        iface ens6f0 inet6 auto
        dhcp 1
        request_prefix 1

auto ens6f1
        iface ens6f1 inet6 auto
        dhcp 1
        request_prefix 1

Code: Select all

root@server:~# ifconfig
bond0: flags=5187<UP,BROADCAST,RUNNING,MASTER,MULTICAST>  mtu 1500
        inet 192.168.178.3  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::215:17ff:feb4:30a8  prefixlen 64  scopeid 0x20<link>
        inet6 2002:2eed:d79a:0:215:17ff:feb4:30a8  prefixlen 64  scopeid 0x0<global>
        ether 00:15:17:b4:30:a8  txqueuelen 1000  (Ethernet)
        RX packets 1166  bytes 154650 (151.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1370  bytes 489233 (477.7 KiB)
        TX errors 0  dropped 6 overruns 0  carrier 0  collisions 0

ens6f0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 00:15:17:b4:30:a8  txqueuelen 1000  (Ethernet)
        RX packets 613  bytes 87840 (85.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 688  bytes 234089 (228.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 27  memory 0xfb380000-fb3a0000

ens6f1: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 00:15:17:b4:30:a8  txqueuelen 1000  (Ethernet)
        RX packets 553  bytes 66810 (65.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 682  bytes 255144 (249.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 58  memory 0xfb320000-fb340000

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 9  bytes 720 (720.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9  bytes 720 (720.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
LG
Proti

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"
User avatar
Joe User
Project Manager
Project Manager
Posts: 11176
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Debian, IPv6 und ich!

Post by Joe User »

Proteus wrote: 2019-07-21 00:53Frage mich nur wieso das nun automatisch ge-bondet wurde?
Hast Du doch hier so konfiguriert:
Proteus wrote: 2019-07-21 00:53

Code: Select all

auto ens6f0
        iface ens6f0 inet manual
        bond-master bond0

auto ens6f1
        iface ens6f1 inet manual
        bond-master bond0
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
User avatar
Proteus
Posts: 289
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Re: Debian, IPv6 und ich!

Post by Proteus »

Ah okay, manchmal ist einem die Logik nicht ganz klar. 😀
LG
Proti

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"