ajenti v pmp7 413 Request Entity Too Large nginx

Apache, Lighttpd, nginx, Cherokee
Enzo030
Posts: 1
Joined: 2017-01-27 12:53

ajenti v pmp7 413 Request Entity Too Large nginx

Post by Enzo030 » 2017-01-27 14:42

Ich habe einen root Server mit ubuntu 15.10.

Dort habe ich ajenti installiert php7 und phpmyadmin. Jetzt habe ich versucht wordpress zu installieren und mein backup einzuspielen. doch leiber bekomme ich immer den fehler 413 Request Entity Too Large

nginx.

in den ajenti Einstellungen unter php.ini werte habe ich folgendens eingetragen.

Code: Select all

file_uploads = On 
max_execution_time = 120 
post_max_size = 256M 
memory_limit = 256M 
register_globals = Off 
safe_mode = Off 
upload_max_filesize = 256M 
session.gc_maxlifetime = 1440 
session.cache_expire = 180.
Ich hoffe ihr könnt mir helfen
Gruß
Enzo

jan10001
Anbieter
Posts: 728
Joined: 2004-01-02 12:17

Re: ajenti v pmp7 413 Request Entity Too Large nginx

Post by jan10001 » 2017-01-28 20:52

Stichwort: client_max_body_size
http://nginx.org/en/docs/http/ngx_http_ ... _body_size

Den Wert dort erhöhen und Nginx neustarten dann sollte es gehen.

User avatar
Proteus
Posts: 286
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Re: ajenti v pmp7 413 Request Entity Too Large nginx

Post by Proteus » 2017-02-18 13:04

Auch wenn etwas spät, aber lieber auf phpMyAdmin verzichten und manuell einspielen.

Code: Select all

(Optional) Datenbank Benutzer anlegen und Datenbank importieren, gilt als Beispiel! Bei der Ergänzung des Passwotes müssen die ( '' ) erhalten bleiben.

mysql -u root -p

show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| howto              |
| mysql              |
| performance_schema |
| sys                |
+--------------------+

CREATE DATABASE wordpress;

show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| howto              |
| mysql              |
| performance_schema |
| sys                |
| wordpress          |
+--------------------+

CREATE USER 'wordpress'@'localhost' IDENTIFIED BY 'PASSWORD';

GRANT ALL ON my_db.* TO 'wordpress'@'localhost';

GRANT ALL PRIVILEGES ON *.* TO 'wordpress'@'localhost' WITH GRANT OPTION;

FLUSH PRIVILEGES;

quit

Optional Nur bei vorhandener Datenbank, ansonsten einfach Wordpress installieren:

mysql -u wordpress -p wordpress < /home/admin/wordpress.sql
LG
Proti

https://phoenix-blog.de

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"