Vim Visual Styles deaktivieren

Bash, Shell, PHP, Python, Perl, CGI
User avatar
Proteus
Posts: 272
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Vim Visual Styles deaktivieren

Post by Proteus » 2016-10-04 15:53

Hallo,

wie bekomme ich Vim dazu, dass Texte aus der Zwischenablage wieder ganz normal mit der linken Maustaste wieder einfügen kann?

Irgendwie liegt es an diesem Visual Style, denn seit Neustem muss ich die Shift Taste gedrückt halten damit ich Texte/Scripte einfügen bzw. kopieren kann. Auch das markieren mit der linken Maustaste funktioniert nicht mehr so problemlos.

Die Manpages über Vim schweigen sich darüber aus, wie man das deaktivieren könnte.

Gruß Olaf

PS. Ich arbeite mit Windows und Putty. Ich habe versucht in Putty selbst etwas ändern, dass aber scheint nicht zu greifen.
LG
Proti

https://phoenix-blog.de

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"

User avatar
rudelgurke
Systemtester
Systemtester
Posts: 400
Joined: 2008-03-12 05:36

Re: Vim Visual Styles deaktivieren

Post by rudelgurke » 2016-11-15 10:24

Hi,

ein wenig spät vielleicht, aber besser als nie.

http://vimdoc.sourceforge.net/htmldoc/o ... 27mouse%27

Vielleicht mal mit ":set mouse" in den Optionen experimentieren, bis die richtige Option gefunden wurde. Ein tmux in einem rxvt auf Client Seite und ein VIM 8.x unter BSD, 7.x unter Linux hatte die gleichen Probleme.
Ein ":set mouse=v" hat Abhilfe gebracht.
Da es bei mir einige Zeit her ist Putty genutzt zu haben (mal bei der Suchmaschine der Wahl "putt" eingeben und es kommt mitunter ein nettes Mini-Golf) - hier hilft vielleicht auch die $TERM Variable zu setzen. Bisher hatte "xterm" am wenigsten Stress gemacht.

User avatar
Proteus
Posts: 272
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Re: Vim Visual Styles deaktivieren

Post by Proteus » 2016-11-15 10:55

Ja jetzt JA, funktioniert es! Danke!
LG
Proti

https://phoenix-blog.de

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"