kein Netzwerk mehr nach reboot

Alles rund um Netzwerktechnik und Protokolle
tomotom
Posts: 330
Joined: 2006-09-22 13:37

kein Netzwerk mehr nach reboot

Post by tomotom »

Moin, nach einem kleinen upgrade auf meinem Jessi Server ist er nach einem Reboot nicht mehr über das Netzwerk zu erreichen. Nur über eine remote Konsole.

Der Netzwerkkartentreiben schein geladen zu sein

Code: Select all

root@h1:/var/log# lspci -nnk | grep -i net -A2 
03:00.0 Ethernet controller [0200]: Intel Corporation 82573L Gigabit Ethernet Controller [8086:109a]
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:6b30]
	Kernel driver in use: e1000e
root@h1:/var/log# lsmod | grep e1000
e1000e                237568  0 
ptp                    20480  1 e1000e
Aber das folgende steht im syslog

Code: Select all

Sep 14 10:50:50 h1 dhclient:
Sep 14 10:50:50 h1 ifup[1383]: Cannot find device "eth0"
Sep 14 10:50:50 h1 dhclient: Bind socket to interface: No such device
Sep 14 10:50:50 h1 ifup[1383]: Bind socket to interface: No such device
Sep 14 10:50:50 h1 ifup[1383]: If you think you have received this message due tt
o a bug rather

Code: Select all

root@h1:/var/log# ifconfig eth0
eth0: Fehler beim Auslesen der Schnittstelleninformation: Gerät nicht gefunden

wie kann ich das Problem weiter eingrenzen?
Kann die Netzwerkkarte kaputt sein?
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: kein Netzwerk mehr nach reboot

Post by Joe User »

Ich tippe mal auf eine beim Update nicht aktualisierte udev/systemd Konfiguration.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
tomotom
Posts: 330
Joined: 2006-09-22 13:37

Re: kein Netzwerk mehr nach reboot

Post by tomotom »

Hast Du evt. noch einen Tipp zu Aktualisierung dieser?
tomotom
Posts: 330
Joined: 2006-09-22 13:37

Re: kein Netzwerk mehr nach reboot

Post by tomotom »

die einzige Fehlermeldung aus dem Bootprotokoll ist diese:

Code: Select all

[code][FAILED] Failed to start Raise network interfaces.
[/code]

Alle anderen Dienste starten ohne Fehlermeldung.
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: kein Netzwerk mehr nach reboot

Post by Joe User »

Ich nutze seit Jahren kein Linux mehr, damals ging das noch über udev-Rules.
Irgendwo ist die Zuordnung des physischen NIC zur Bezeichnung eth0 hinterlegt, dort musst Du meiner Meinung nach ansetzen.

Es kann auch sein, dass sich die Syntax der /etc/network/interfaces (wenn ich mich richtig erinnere) geändert hat.
Oder doch ein Problem mit dem Treiber oder dem Kernel.
Oder etwas völlig Anderes, wobei ich das eher bezweifle.

Sorry, bin kein Debian-User und war es nie und werde es aus guten Gründen nie sein.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
homebox
Posts: 9
Joined: 2008-05-21 14:37

Re: kein Netzwerk mehr nach reboot

Post by homebox »

Systemd benennt die Interfaces anders, Stichwort "Predictable Network Interface Names".

Was sagt denn

Code: Select all

ip addr
?

Um eth0 wiederherzustellen reicht meist ein:

Code: Select all

ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules
tomotom
Posts: 330
Joined: 2006-09-22 13:37

Re: kein Netzwerk mehr nach reboot

Post by tomotom »

Der link nach /dev/null ist nun in /etc/udev/rules.d/ und nach einem reboot war das netz wieder da. Besten Dank dafür.

Aber warum geht das nun nur so, mit diesem Link?

Und leider läuft auch mysql nicht mehr. Werde dafür einen neuen Thread eröffnen.
homebox
Posts: 9
Joined: 2008-05-21 14:37

Re: kein Netzwerk mehr nach reboot

Post by homebox »

Weil mit systemd zusammen auch systemd-udevd kommt und standardmäßig ne udev Regel unter /usr/lib/udev/rules.d/80-net-setup-link.rules liegt, die du mit dem Symlink überschreibst (override). Einfach mal nach "Predictable Network Interface Names" googeln...