[Gelöst] php5-fpm aktualisieren oder entfernen

Apache, Lighttpd, nginx, Cherokee
tsaenger
Posts: 414
Joined: 2003-08-13 01:14

[Gelöst] php5-fpm aktualisieren oder entfernen

Post by tsaenger » 2016-06-09 17:11

Hallo zusammen,

ich habe ein Jessie mit installiertem php5-fpm
Hier bekomme ich beim updaten angezeigt, das es ein update gibt, kann es aber nicht installieren.
Nun versuchte ich das Pakte zu deinstallieren, was mir aber auch nicht geklückt ist.
Ich bekomme die Meldung

Code: Select all

/etc/bind# apt-get install --purge php5-fpm
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  php5-fpm
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
20 not fully installed or removed.
Need to get 0 B/2196 kB of archives.
After this operation, 0 B of additional disk space will be used.
Reading changelogs... Done
(Reading database ... 57609 files and directories currently installed.)
Preparing to unpack .../php5-fpm_5.6.20+dfsg-0+deb8u1_amd64.deb ...
invoke-rc.d: initscript php5-fpm, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
invoke-rc.d: initscript php5-fpm, action "stop" failed.
dpkg: error processing archive /var/cache/apt/archives/php5-fpm_5.6.20+dfsg-0+de                                                                                                                     b8u1_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
invoke-rc.d: initscript php5-fpm, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/php5-fpm_5.6.20+dfsg-0+deb8u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hat jemand eine Idee wie ich das lösen kann?
Habe auch noch folgendes versucht:

Code: Select all

root@i:/etc/bind# dpkg --purge php5-fpm
dpkg: error processing package php5-fpm (--purge):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting a removal
Errors were encountered while processing:
 php5-fpm

und

Code: Select all

root@i:/etc/bind# dpkg -i php5-fpm
dpkg: error processing archive php5-fpm (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 php5-fpm

Dann habe ich es erzwungen:

Code: Select all

root@ispconfig:/etc/bind# dpkg --remove --force-remove-reinstreq php5-fpm
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: package is in a very bad inconsistent state; you should
 reinstall it before attempting a removal
(Reading database ... 57603 files and directories currently installed.)
Removing php5-fpm (5.6.19+dfsg-0+deb8u1) ...
php5_invoke prerm: Disable module gd for fpm SAPI
php5_invoke prerm: Disable module memcache for fpm SAPI
php5_invoke prerm: Disable module mysqli for fpm SAPI
php5_invoke prerm: Disable module opcache for fpm SAPI
php5_invoke prerm: Disable module json for fpm SAPI
php5_invoke prerm: Disable module pdo_mysql for fpm SAPI
php5_invoke prerm: Disable module recode for fpm SAPI
php5_invoke prerm: Disable module sqlite3 for fpm SAPI
php5_invoke prerm: Disable module readline for fpm SAPI
php5_invoke prerm: Disable module pspell for fpm SAPI
php5_invoke prerm: Disable module curl for fpm SAPI
php5_invoke prerm: Disable module imagick for fpm SAPI
php5_invoke prerm: Disable module mysql for fpm SAPI
php5_invoke prerm: Disable module imap for fpm SAPI
php5_invoke prerm: Disable module tidy for fpm SAPI
php5_invoke prerm: Disable module pdo_sqlite for fpm SAPI
php5_invoke prerm: Disable module xmlrpc for fpm SAPI
php5_invoke prerm: Disable module mcrypt for fpm SAPI
php5_invoke prerm: Disable module xsl for fpm SAPI
php5_invoke prerm: Disable module intl for fpm SAPI
php5_invoke prerm: Disable module xcache for fpm SAPI
php5_invoke prerm: Disable module memcached for fpm SAPI
php5_invoke prerm: Disable module pdo for fpm SAPI
invoke-rc.d: initscript php5-fpm, action "stop" failed.
dpkg: error processing package php5-fpm (--remove):
 subprocess installed pre-removal script returned error exit status 1
invoke-rc.d: initscript php5-fpm, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 php5-fpm

kann es aber nicht erneut installieren.
Vielen Dank.

Gruß
TObias
Last edited by tsaenger on 2016-06-09 20:39, edited 1 time in total.

tsaenger
Posts: 414
Joined: 2003-08-13 01:14

Re: php5-fpm aktualisieren oder entfernen

Post by tsaenger » 2016-06-09 20:39

habe es eben gelöst bekommen.
Musste in in /etc/default/rcS VERBOSE=yes eintragen und dann konnte ich mit:

dpkg --remove --force-remove-reinstreq php5-fpm

entfernen und über apt-get install php5-fpm die neue Version installieren.

Gruß
Tobias