Too many open files in system

Apache, Lighttpd, nginx, Cherokee
PersilColor
Posts: 4
Joined: 2014-01-27 20:31

Too many open files in system

Post by PersilColor » 2014-02-16 20:54

Hallo,

ich bekomme in meiner error.log ständig die Fehlermeldung

Code: Select all

Too many open files in system


Die Ausgabe

Code: Select all

cat /proc/user_beancounters
sagt:

Code: Select all

Version: 2.5
       uid  resource                     held              maxheld              barrier                limit              failcnt
 10023303:  kmemsize                 78447277            109305856            106385865            117024451                13281
            lockedpages                     0                    8                  860                  860                    0
            privvmpages                634551               969278              1048576              1048576                    0
            shmpages                     5377                 6993                65536                65536                    0
            dummy                           0                    0  9223372036854775807  9223372036854775807                    0
            numproc                       186                  282                  512                  512                    0
            physpages                  324379              1048576              1048576              1048576                    0
            vmguarpages                     0                    0               524288  9223372036854775807                    0
            oomguarpages                78268               103509               524288  9223372036854775807                    0
            numtcpsock                     50                  350                 1800                 1800                    0
            numflock                       11                   24                  500                  500                    0
            numpty                          1                    2                  128                  128                    0
            numsiginfo                      0                  192                 1024                 1024                    0
            tcpsndbuf                  655952              4612376              4942675              7056211                    0
            tcprcvbuf                  615784              4994272              4942675              7056211                  384
            othersockbuf               241984               844328               844366              1481926                  502
            dgramrcvbuf                     0                77280               844366               844366                    0
            numothersock                  199                  275                 1800                 1800                    0
            dcachesize                5293351              8110080              7299072              8110080                    0
            numfile                      2677                 4550                10000                10000                    0
            dummy                           0                    0  9223372036854775807  9223372036854775807                    0
            dummy                           0                    0  9223372036854775807  9223372036854775807                    0
            dummy                           0                    0  9223372036854775807  9223372036854775807                    0
            numiptent                      50                   50                  128                  128                    0


Wo liegt das Problem, bzw. wie kann ich es lösen?

bin über jeden Ratschlag dankbar :)

LG

ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: Too many open files in system

Post by ddm3ve » 2014-02-16 22:26

Du hast also eine virtuelle Maschine.
Betriebst Du den Server selbst oder ist es eine vServer Paket eines Providers?

Grundsätzlich:

/etc/sysctl.conf bzw. /etc/security/limits.conf

Paramter fs.file-max =

Sowie ulimit zur Laufzeit / Session sind für die open Files zuständig.


Welche Limit tatsächlich gesetzt werden müssen sind hauptsächliche Erfahrungswert, die Du für Deinen Anwendungsfall erarbeiten solltest.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

PersilColor
Posts: 4
Joined: 2014-01-27 20:31

Re: Too many open files in system

Post by PersilColor » 2014-02-17 09:56

Ja, ich habe einen vServer bei S4Y mit 2 GB garantiertem Arbeitsspeicher.

Hier der Inhalt der /etc/sysctl.conf

Code: Select all

#  /etc/syslog.conf   Configuration file for syslogd.
#
#         For more information see syslog.conf(5)
#         manpage.

#
# First some standard logfiles.  Log by facility.
#

auth,authpriv.*       -/var/log/auth.log
*.*;auth,authpriv.none      -/var/log/syslog
#cron.*          -/var/log/cron.log
daemon.*         -/var/log/daemon.log
kern.*            -/var/log/kern.log
lpr.*            -/var/log/lpr.log
mail.*                  -/opt/psa/var/log/maillog
user.*            -/var/log/user.log

#
# Logging for the mail system.  Split it up so that
# it is easy to write scripts to parse these files.
#
mail.info         -/var/log/mail.info
mail.warning         -/var/log/mail.warn
mail.err       -/var/log/mail.err

# Logging for INN news system
#
news.crit       -/var/log/news/news.crit
news.err       -/var/log/news/news.err
news.notice         -/var/log/news/news.notice

#
# Some `catch-all' logfiles.
#
*.=debug;\
   auth,authpriv.none;\
   news.none;mail.none   -/var/log/debug
*.=info;*.=notice;*.=warning;\
   auth,authpriv.none;\
   cron,daemon.none;\
   mail,news.none      -/var/log/messages

#
# Emergencies are sent to everybody logged in.
#
*.emerg            *

#
# I like to have messages displayed on the console, but only on a virtual
# console I usually leave idle.
#
#daemon,mail.*;\
#   news.=crit;news.=err;news.=notice;\
#   *.=debug;*.=info;\
#   *.=notice;*.=warning   /dev/tty8

# The named pipe /dev/xconsole is for the `xconsole' utility.  To use it,
# you must invoke `xconsole' with the `-file' option:
#
#    $ xconsole -file /dev/xconsole [...]
#
# NOTE: adjust the list below, or you'll go crazy if you have a reasonably
#      busy site..
#
daemon.*;mail.*;\
   news.err;\
   *.=debug;*.=info;\
   *.=notice;*.=warning   |/dev/xconsole


und der /etc/security/limits.conf

Code: Select all

/etc/security/limits.conf
#
#Each line describes a limit for a user in the form:
#
#<domain>        <type>  <item>  <value>
#
#Where:
#<domain> can be:
#        - an user name
#        - a group name, with @group syntax
#        - the wildcard *, for default entry
#        - the wildcard %, can be also used with %group syntax,
#                 for maxlogin limit
#        - NOTE: group and wildcard limits are not applied to root.
#          To apply a limit to the root user, <domain> must be
#          the literal username root.
#
#<type> can have the two values:
#        - "soft" for enforcing the soft limits
#        - "hard" for enforcing hard limits
#
#<item> can be one of the following:
#        - core - limits the core file size (KB)
#        - data - max data size (KB)
#        - fsize - maximum filesize (KB)
#        - memlock - max locked-in-memory address space (KB)
#        - nofile - max number of open files
#        - rss - max resident set size (KB)
#        - stack - max stack size (KB)
#        - cpu - max CPU time (MIN)
#        - nproc - max number of processes
#        - as - address space limit (KB)
#        - maxlogins - max number of logins for this user
#        - maxsyslogins - max number of logins on the system
#        - priority - the priority to run user process with
#        - locks - max number of file locks the user can hold
#        - sigpending - max number of pending signals
#        - msgqueue - max memory used by POSIX message queues (bytes)
#        - nice - max nice priority allowed to raise to values: [-20, 19]
#        - rtprio - max realtime priority
#        - chroot - change root to directory (Debian-specific)
#
#<domain>      <type>  <item>         <value>
#

#*               soft    core            0
#root            hard    core            100000
#*               hard    rss             10000
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
#ftp             -       chroot          /ftp
#@student        -       maxlogins       4

# End of file


Ich kann fs.file-max = und ulimit nicht finden, wo genau muss ich sie anpassen?

LG
Last edited by PersilColor on 2014-02-17 10:08, edited 3 times in total.

ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: Too many open files in system

Post by ddm3ve » 2014-02-17 11:21

fs.file-max= setzt Du in ter sysctl.conf ulimit in deiner eignen Umgebung .profile, .bashrc etc.
In der /etc/security/limits.conf setzt Du Benutzerspezifische Limits.


Bitte lies dazu ausführliche Dokumentationen oder nimm an einer Linux Schulung teil.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.