Apache Logformat plötzlich anders

Apache, Lighttpd, nginx, Cherokee
exor79
Posts: 3
Joined: 2013-07-12 21:13

Apache Logformat plötzlich anders

Post by exor79 » 2013-07-12 21:33

Hallo.

seit 3 Tagen sehen Apache Access Logs plötzlich anders aus, Hostname fehlt,

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined

früher hat z.B. so ausgesehen:
...:80 172-195.60-xx.cust.bluewin.ch - - [12/Jul/2013:21:33:07 +0200] "GET /index.php

jetzt plötzlich:
...:80 172.195.60-xx- - [12/Jul/2013:21:33:07 +0200] "GET /index.php

statt hostname nur die IP-Adresse.

das %h ist eigentlich für Hostname, weiss jemand warum das ignoriert wird?

besten Dank im Voraus.

ddm3ve
Moderator
Moderator
Posts: 1177
Joined: 2011-07-04 10:56

Re: Apache Logformat plötzlich anders

Post by ddm3ve » 2013-07-12 22:58

Das hängt mit dem RDNS Eintrag zusammen.
Dieser scheint nicht mehr zu existieren.

Beispiel:

Code: Select all

nslookup 172.195.60.0
Server:      212.19.38.28
Address:   212.19.38.28#53

Name:   172.195.60.0
Address: 172.195.0.60.0


Im gegensatz zu einem gesetzten RDNS Eintrag:

Code: Select all

nslookup 81.26.173.150
Server:      212.19.38.28
Address:   212.19.38.28#53

150.173.26.81.in-addr.arpa   name = devmisc.rootforum.org.


Ich würde aber generell von der Namensauflösung beim Apachen ab sehen.
Dies kann u.U. zu einem Bottleneck führen.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

exor79
Posts: 3
Joined: 2013-07-12 21:13

Re: Apache Logformat plötzlich anders

Post by exor79 » 2013-07-13 06:37

das ist mir schon klar, trotzdem danke...

eigentlich mache ich mir nur Gedanken ob evtl.. etwas (nicht von mir) verändert wurde.

rkhunter zeigt zwar nichts verdächtiges.