Plesk + webmail = Error 500

Jaik
Posts: 7
Joined: 2013-01-28 09:50

Plesk + webmail = Error 500

Post by Jaik »

Ich habe ein Webserver mit Plesk 10.4.4. Seit ich vor kurzem AfterLogic WebMail Lite deinstalliert habe, und danach wieder installiert habe, bekomme ich im Frontend(schon beim anmeldebereich) einen Error 500. Das Backend und der Sql zugang funktioniert aber ohne Probleme. Mails über Thunderbird zu senden/abzurufen funktioniert auch.
Woran könnte das liegen?

viele Grüße,
Jaik

EDIT// hoffe das ist im richtigen Forum, ansonsten einfach sagen oder verschieben :)

EDIT2// Im Plesk in den Mail Einstellungen, kann man bei "Webmail" nichts auswählen.
Top

jan10001
Anbieter
Posts: 720
Joined: 2004-01-02 12:17

Re: Plesk + webmail = Error 500

Post by jan10001 »

Das du mit Thunderbird senden und empfangen kannst ist kein Wunder, denn WebMail hat nichts damit zu tun.

Ich würde mal sagen, du hast AfterLogic WebMail nicht mit Plesk deinstalliert und auch nicht mit Plesk neuinstalliert. Daran könnte es liegen.
Top

Jaik
Posts: 7
Joined: 2013-01-28 09:50

Re: Plesk + webmail = Error 500

Post by Jaik »

Doch, habe es beides mal mit Plesk de- und installiert. Hab auch schon überprüft ob die Daten wirklich gelöscht worden sind und ob die Tabellen richtig angelegt wurden. Die Rechte stimmen ebenfalls. Hab mit dem Thunderbird nur gemeint, dass der Mailserver funktioniert
Last edited by Jaik on 2013-06-25 08:23, edited 1 time in total.
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Plesk + webmail = Error 500

Post by daemotron »

Was sagt denn das Webserver-Log zu dem geschmissenen 500er? Das deutet ja auf ein Ausführungsproblem hin, und nicht auf irgendeine Berechtigungsgeschichte...
“Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying 'End-of-the-World Switch. PLEASE DO NOT TOUCH', the paint wouldn't even have time to dry.” — Terry Pratchett, Thief of Time
Top

Jaik
Posts: 7
Joined: 2013-01-28 09:50

Re: Plesk + webmail = Error 500

Post by Jaik »

Wo finde ich den die logs? bei /var/logs hab ich bisher nichts gefunden. und im webmail Verzeichnis ist kein log file.

im error_log vom apache kommt das hier bei der installation.

Code: Select all

[Tue Jun 25 10:50:13 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:50:13 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:50:13 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Tue Jun 25 10:50:13 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Jun 25 10:50:13 2013] [warn] module rewrite_module is already loaded, skipping
[Tue Jun 25 10:50:13 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:50:13 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:50:13 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
PHP Warning:  Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Tue Jun 25 10:50:13 2013] [notice] mod_python: Creating 8 session mutexes based on 10 max processes and 0 max threads.
[Tue Jun 25 10:50:13 2013] [notice] mod_python: using mutex_directory /tmp
[Tue Jun 25 10:50:13 2013] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 25 10:50:13 2013] [notice] Digest: done
[Tue Jun 25 10:50:13 2013] [notice] Apache/2.2.15 (Linux/SUSE) mod_ssl/2.2.15 OpenSSL/1.0.0 mod_fcgid/2.3.6 mod_python/3.3.1 Python/2.6.5 DAV/2 mod_perl/2.0.4 Perl/v5.12.1 configured -- resuming normal operations
[Tue Jun 25 10:51:06 2013] [notice] caught SIGTERM, shutting down
[Tue Jun 25 10:51:08 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:51:08 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:51:08 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Tue Jun 25 10:51:08 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Jun 25 10:51:08 2013] [warn] module rewrite_module is already loaded, skipping
[Tue Jun 25 10:51:08 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:51:08 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Tue Jun 25 10:51:08 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
PHP Warning:  Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Tue Jun 25 10:51:08 2013] [notice] mod_python: Creating 8 session mutexes based on 10 max processes and 0 max threads.
[Tue Jun 25 10:51:08 2013] [notice] mod_python: using mutex_directory /tmp
[Tue Jun 25 10:51:08 2013] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 25 10:51:08 2013] [notice] Digest: done
[Tue Jun 25 10:51:08 2013] [notice] Apache/2.2.15 (Linux/SUSE) mod_ssl/2.2.15 OpenSSL/1.0.0 mod_fcgid/2.3.6 mod_python/3.3.1 Python/2.6.5 DAV/2 mod_perl/2.0.4 Perl/v5.12.1 configured -- resuming normal
Last edited by Jaik on 2013-06-25 10:57, edited 3 times in total.
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Plesk + webmail = Error 500

Post by daemotron »

Die VHost-Konfiguration für Webmail sollte Dir Aufschluss darüber geben, wohin protokolliert wird.
“Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying 'End-of-the-World Switch. PLEASE DO NOT TOUCH', the paint wouldn't even have time to dry.” — Terry Pratchett, Thief of Time
Top

Jaik
Posts: 7
Joined: 2013-01-28 09:50

Re: Plesk + webmail = Error 500

Post by Jaik »

Ok, ich finde die Datei leider nicht, wo ist die denn? "/etc/apache2" <-- hier? oder ../www/vhosts?
Last edited by Jaik on 2013-06-25 14:01, edited 1 time in total.
Top

jan10001
Anbieter
Posts: 720
Joined: 2004-01-02 12:17

Re: Plesk + webmail = Error 500

Post by jan10001 »

Schau mal hier: /usr/local/psa/admin/conf
Top

Jaik
Posts: 7
Joined: 2013-01-28 09:50

Re: Plesk + webmail = Error 500

Post by Jaik »

Ok, hab die index.php mal in der Shell geöffnet( php index.php ). zuerst kam irgendetwas mit json_encode fehlt. nachdem ich es mit einer älteren(aber kompatiblen) php Version versucht hatte, kam eine andere Fehlermeldung, die ich nicht beheben kann, da es wohl am webmailer liegt.

Lösung: habe Squirrelmail installiert :) damit funktioniert alles.
Top