Mail Server hängt bei 100% Last bis reboot - täglich

mivogt
Posts: 64
Joined: 2003-01-22 09:58
Location: Ludwigshafen/Rh.

Mail Server hängt bei 100% Last bis reboot - täglich

Post by mivogt »

Hallo,

seit etwas über einer Woche habe ich massive Probleme mit meinem 1&1 Rootserver.
Meine Selbst(ver)suche bringen mich nicht weiter und ich gestehe, dass ich mit dem Problem überfordert bin. :-(

Konfiguration:

BS CentOS 5.9 (Final)
Panel-Version 11.0.9 Update #44, zuletzt aktualisiert am April 2, 2013 04:04 AM



Da ich mit (yum und Plesk) Updates und zaghaften Versuchen die Logfiles zu verstehen nicht selbst weiterkomme bitte ich daher hier um Hilfe oder zumindest einen Fingerzeig in die richtige Richtung.

System ist auf dem aktuellen Stand und die nervigste IP aus China die täglich massiv Loginfehlversuche erzeugt habe ich per Firewall ausgesperrt ...

Das Problem:
Der Server hängt inzwischen täglich . Web (also Apache) geht, aber der Mail Dienst will nicht mehr.
Es gehen keine Mails mehr rein oder raus.

Auffällig ist, dass der Mail-Server dann immer um die 95-100% CPU Last hat und sich davon auch nicht erholt bis ich den gesamten Server neu starte. Speicherauslastung hingegen ist immer sehr gering (selten über 100M, meist unter 40-50M)

Heute ist mir noch aufgefallen dass in Plesk in der Verwaltung der SMTP-Server (Postfix) nicht lief als die Last so hoch war – nach dem Serverneustart hingegen alles wieder in Butter.

Mein Anfangsverdacht war das Plesk-Backup da es einen ähnlichen Fall laut google schonmals vor Jahren gab.
Also habe ich dort mit dein Einstellungen gespielt – aber leider keine Änderung erreicht.

Meine Probleme treten sowohl nach dem Backup (da mit absoluter Zuverlässigkeit) auf (Backup ist gegen 0300 fertig und dann hängt der Mail-Dienst … aber auch tagsüber kam es schon zu identischen Problemen – weshalb ich das Backup nicht als Ursache sehe (oder nicht als alleinige Ursache)


Im Maillog habe ich ein paar sich wiederholende Einträge die ich nicht deuten kann aber mit dem Problem (Bauchgefühl) in Verbindung bringe:


Apr 3 04:16:57 sXXXXXXXXX postfix/smtpd[20762]: table hash:/var/spool/postfix/plesk/poplock(0,lock|fold_fix) has changed -- restarting
Apr 3 04:16:57 sXXXXXXXXX postfix/smtpd[20600]: table hash:/var/spool/postfix/plesk/poplock(0,lock|fold_fix) has changed -- restarting
Apr 3 04:16:57 sXXXXXXXXX postfix/smtpd[18313]: table hash:/var/spool/postfix/plesk/poplock(0,lock|fold_fix) has changed – restarting



Apr 3 04:17:36 sXXXXXXXX postfix/cleanup[12046]: warning: milter unix:/var/spool/postfix/ctmilter/ctmilter.sock: can't read SMFIC_OPTNEG reply packet header: Connection timed out
Apr 3 04:17:36 sXXXXXXXX postfix/cleanup[12046]: warning: milter unix:/var/spool/postfix/ctmilter/ctmilter.sock: read error in initial handshake
Apr 3 04:17:36 sXXXXXXXX postfix/cleanup[12046]: 660E1C0C5C2: milter-reject: CONNECT from localhost[127.0.0.1]: 4.7.1 Service unavailable - try again later; from=<apache@sXXXXXXXX.onlinehome-server.info>




Apr 3 04:20:29 sXXXXXXXXX postfix/smtpd[28797]: warning: milter unix:/var/spool/postfix/ctmilter/ctmilter.sock: can't read SMFIC_OPTNEG reply packet header: Connection timed out
Apr 3 04:20:29 sXXXXXXXXX postfix/smtpd[28797]: warning: milter unix:/var/spool/postfix/ctmilter/ctmilter.sock: read error in initial handshake



Apr 3 04:20:29 sXXXXXXXXX postfix/smtpd[28797]: NOQUEUE: milter-reject: CONNECT from hosting34.monitoring.1and1.com[195.20.253.7]: 451 4.7.1 Service unavailable - try again later; proto=SMTP
Apr 3 04:20:29 sXXXXXXXXX postfix/smtpd[28797]: lost connection after CONNECT from hosting34.monitoring.1and1.com[195.20.253.7]
Apr 3 04:20:29 sXXXXXXXXX postfix/smtpd[28797]: disconnect from hosting34.monitoring.1and1.com[195.20.253.7]




Wenn also jemand das Problem kennt und mit eine Lösung anbieten kann wäre das super denn mir gehen die Ideen aus und zumindest telefonisch hat mir auch die Hotline von 1&1 nicht helfen können ... und bei mir ist das Ende der Weisheit leider auch erreicht ...

So ich hoffe mal auf Feedback sowie Hilfe und danke schon vorab.

Grüße


Michael
Top

jan10001
Anbieter
Posts: 720
Joined: 2004-01-02 12:17

Re: Mail Server hängt bei 100% Last bis reboot - täglich

Post by jan10001 »

Soweit ich weiß, liegt das Problem bei ctmilter.sock und eine Lösung ist mir nicht bekannt. Was spricht dagegen auf Qmail um zu steigen?
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Mail Server hängt bei 100% Last bis reboot - täglich

Post by Joe User »

Die Plesk-Anti-Spam-Lösung scheint bei Dir nicht (richtig) zu laufen.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top