MySql startet nicht mehr

MySQL, PostgreSQL, SQLite
mildmr
Posts: 2
Joined: 2012-11-23 08:03

MySql startet nicht mehr

Post by mildmr » 2012-11-23 08:11

In der Nacht vom Mittwoch auf den Donnerstag scheint sich auf meinem vServer der Mysql Server verabschiedet zu haben. Wenn ich Ihn starten will kommt nur ....failed

Auf der Domain kommt:
SQL ERROR [ mysql4 ]

Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111) [2002]


Ich habe schon etliche Lösungsvorschläge ergoogelt, aber nix will helfen.

Ich komme nun auch nicht mehr bei phpmyadmin und in das Parallels Power Panel rein.

FTP und SSh Zugriff besteht noch. Ich sehe es es als einfachste Lösung den vServer wieder neu aufzusetzen, aber wie rette ich die Datenbanken? Der letzte Dump ist schon ne Weile her :oops:

Jedenfalls habe ich erstmal /var/lib/mysql/*.* gesichert.

Kann ich das dann so einfach, wenn ich einen User mit dem gleichen Namen und Passwort auf dem neu aufgesetzeten Server erstelle, übernehmen?

Betriebssystem ist Debian6 mit 5.1.63

Log Dateien sind 0 byte.
mysqld.sock ist 0 byte
und my.conf ist:

Code: Select all

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port      = 3306
socket      = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket      = /var/run/mysqld/mysqld.sock
nice      = 0

[mysqld]
#
# * Basic Settings
#
user      = mysql
pid-file   = /var/run/mysqld/mysqld.pid
socket      = /var/run/mysqld/mysqld.sock
port      = 3306
basedir      = /usr
datadir      = /var/lib/mysql
tmpdir      = /tmp
language   = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address      = 127.0.0.1
bind-address       = 88.84.146.203
bind-address      = 178.254.8.177
#
# * Fine Tuning
#
key_buffer      = 16M
max_allowed_packet   = 16M
thread_stack      = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit   = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#log_slow_queries   = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id      = 1
#log_bin         = /var/log/mysql/mysql-bin.log
expire_logs_days   = 10
max_binlog_size         = 100M
#binlog_do_db      = include_database_name
#binlog_ignore_db   = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet   = 16M

[mysql]
#no-auto-rehash   # faster start of mysql but no tab completition

[isamchk]
key_buffer      = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/


ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: MySql startet nicht mehr

Post by ddm3ve » 2012-11-23 10:35

Erstmal das System untersuchen,

1. ps -ef -> prüfen ob da nicht doch noch ein alter mysql Prozess herum hängt. Neustart des System soll da gelegentlich auch wunder voll bringen ;-)

2. Falls mysqld läuft mit netstat -tulpen prüfen ob er auch an dem gewünschten Interface horcht.

3. Prüfen was und ob sich zum problematischen start etwas in /var/log/messages oder syslog findet.

4. Prüfen ob die Verzeichnisse in der Konfig so auch existieren: z.B. /var/run/mysqld/ und beschreibbar sind die Eigentümerschaft stimmt.



Und das, kann so nicht !

bind-address = 127.0.0.1
bind-address = 88.84.146.203
bind-address = 178.254.8.177


einige Dich auf eine oder lass es weg.
Mysql kann sich nicht an "mehrere IPs" binden, konnte es noch nie und wird es wohl auch nie können.
Zumindest nicht so, wie Du es versuchst, das klappt ggf. mit lighttpd oder anderen Diensten. Hattest wohl nur einen reload versucht, da wird diese Konfig so einfach ignoriert Bzw. der letzte Wert genommen.

Du solltest es an, entweder localhost / 127.0.0.1 binden und per iptables von den erlaubten ips weiter leiten, oder an alle ips / interfaces binden (0.0.0.0) und den Zugriff über iptables einschränken.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

mildmr
Posts: 2
Joined: 2012-11-23 08:03

Re: MySql startet nicht mehr

Post by mildmr » 2012-11-25 10:42

Danke, es war ein hardware Fehler beim Provider. Und danke für den TIP mit den IP's. localhost reicht dort aus, oder?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11139
Joined: 2003-02-27 01:00
Location: Hamburg

Re: MySql startet nicht mehr

Post by Joe User » 2012-11-25 12:28

Nicht localhost, sondern 127.0.0.1 (das sind für MySQL zwei völlig verschiedene Dinge).
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: MySql startet nicht mehr

Post by ddm3ve » 2012-11-25 16:11

Naja, wenn "127.0.0.1" dann genügt i.d.R. und in den meisnten Fällen auch ein "localhost" oder gleich ein skip-networking.

Wobei ich grad nicht auswendig weiss, ob der mysqld localhost als bind parameter mag. Deiner obigen "Fehlermeldung" nach zu urteilen sollte ein skip-networking / localhost wohl genügen, wenn Du aber Remote darauf zugreifen musst, kommst Du ums binden an eine IP / Netzwerk nicht herum. Dann gilt es aus Sicherheitgründen gut ab zu klären, an welches Interface / ip und natürlich auch die Frage, wie man das absichert.

Es gab da lange bekannte Lücken um Remote auf die Datenbank zu kommen.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11139
Joined: 2003-02-27 01:00
Location: Hamburg

Re: MySql startet nicht mehr

Post by Joe User » 2012-11-25 17:42

localhost ist bei MySQL immer der UNIX-Socket und nie das Loopback-Interface, daher muss bind-address auf 127.0.0.1 gesetzt werden.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: MySql startet nicht mehr

Post by ddm3ve » 2012-11-25 18:00

Meine Frage war eher:

--bind-address=localhost -> Server verweigert den Dienst mit Fehlermeldung
oder --bind-address=localhost wird wie --skip-networking behandelt.

Da mich das aber gerade selber interessiert hat, eine bind-address=localhost wid wie 127.0.0.1 gewertet.

netstat -tulpen

Code: Select all

tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      60         1931614    27052/mysqld


my.cnf
bind-address = localhost


mysqld 5.5.25a-log

Bei der Namenskonventions und Umsetzung mancher Dingen war man sich nicht immer so einig.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.