Postfix, localdomains ignorieren

TecServer
Anbieter
Posts: 91
Joined: 2006-04-08 21:41

Postfix, localdomains ignorieren

Post by TecServer »

Hallo Jungs,

aktuell haben wir eine Situation die wir so noch nicht hatten. Kunden können selbst mit einem einfach Skript Postfächer etc anlegen, nur ist hier nicht sicher gestellt dass auch der MX Record auf den Server zeigt.
Idee von uns: den localdomains eintrag ignorieren und postfix zwingen immer einen MX Lookup durchzuführen und dann zu zustellen.

Beispiel: Kunde trägt gmail.com als Domain ein - hier würde ja Postfix direkt lokal dann zustellen. Wenn wir nun Postfix anweisen immer einen MX Lookup durchzuführen, dann würde er nicht lokal zustellen sondern zum echten Gmail.

Habt Ihr eine Idee bzgl. der Konfiguration bzw. kennt Ihr einen Parameter?
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Postfix, localdomains ignorieren

Post by Joe User »

Eigentlich müsste es genügen den local-Transport abzuschalten. Ein Beispiel dazu findest Du in http://www.postfix.org/STANDARD_CONFIGU ... l#firewall

Bin mir aber nicht ganz sicher, ob das bereits reicht.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

TecServer
Anbieter
Posts: 91
Joined: 2006-04-08 21:41

Re: Postfix, localdomains ignorieren

Post by TecServer »

Folgendes steht ja in deinem Link:

1 /etc/postfix/main.cf:
2 myorigin = example.com
3 mydestination =
4 local_recipient_maps =
5 local_transport = error:local mail delivery is disabled
6
7 /etc/postfix/master.cf:
8 Comment out the local delivery agent


Die Änderungen in der main.cf habe ich nicht vorgenommen, da weder mydestination, local_recipient_maps oder local_transport von mir konfiguriert wurde.

In der master.cf wurde sowohl "local" als auch "virtual" auskommentiert.
Ist postfix aber relativ egal, er versucht direkt lokal zuzustellen und das endet mit
NOQUEUE: reject: RCPT from unknown[xxx.xxx.xxx.xxx]: 550 5.1.1 <test@gmail.com>: Recipient address rejected: User unknown in virtual alias table; from=<office@tecserver.com> to=<test@gmail.com> proto=ESMTP helo=<Zeus>
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Postfix, localdomains ignorieren

Post by Joe User »

TecServer wrote:Die Änderungen in der main.cf habe ich nicht vorgenommen, da weder mydestination, local_recipient_maps oder local_transport von mir konfiguriert wurde.

Die Parameter sind aber mit Defaultwerten (postconf -d) belegt, daher müsstest Du sie schon Deiner main.cf hinzufügen.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

TecServer
Anbieter
Posts: 91
Joined: 2006-04-08 21:41

Re: Postfix, localdomains ignorieren

Post by TecServer »

Stupid me. Ich glaube ich ändere aber den Ansatz und füge in der postfix mysql einen parameter ein welcher die authentizität bestätigt. Dank views kann man ja sehr gut nicht authentifizierte domains dann verstecken.
Top