TLS Probleme mit Win8 / IE 10

Apache, Lighttpd, nginx, Cherokee
ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

TLS Probleme mit Win8 / IE 10

Post by ddm3ve » 2012-11-09 10:41

Hallo,

folgender Bug bereitet auch mir aktuell Probleme.
http://social.msdn.microsoft.com/Forums ... 9a1bf49333

Besteht eine realistische Chance z.B. über header gesteuert, dem IE bei zu bringen z.B. nur SSL3 anstelle von TLS zu nutzen?
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: TLS Probleme mit Win8 / IE 10

Post by ddm3ve » 2012-11-09 11:41

Ich denke ich haben einen Lösungsansatz gefunden.

BrowserMatch ".*MSIE [9-10]\..*" SSLProtocol +SSLv3 -TLSv1
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11139
Joined: 2003-02-27 01:00
Location: Hamburg

Re: TLS Probleme mit Win8 / IE 10

Post by Joe User » 2012-11-09 12:19

Ich würde es so ähnlich konfigurieren:

Code: Select all

        SSLEngine on
        SSLProtocol all -SSLv2
        SSLCipherSuite RSA:!EXP:!NULL:+HIGH:+MEDIUM:-LOW:-SSLv2
        SSLCertificateFile "/etc/ssl/cert.pem"
        SSLCertificateKeyFile "/etc/ssl/key.pem"
        BrowserMatch ".*MSIE [9-10]\..*" SSLProtocol all -SSLv2 -TLSv1
        BrowserMatch ".*MSIE.*" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

Allerdings kenne ich den Bug nicht, so dass diese Config auch falsch sein kann.
Gerade mit SSL sollte man vorsichtig sein.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

ddm3ve
Moderator
Moderator
Posts: 1187
Joined: 2011-07-04 10:56

Re: TLS Probleme mit Win8 / IE 10

Post by ddm3ve » 2012-11-09 13:11

Im prinzip bezeiht es sich nur auf TLS, der IE 10 hatte wohl in den jüngsten Versionen ein Problem damit. Updates sollen das Problem behoben haben. Ein manuelles Deaktivieren von TLS im Brwoser hätte wohl einen Fallback auf SSL3 verursacht und das Problem behoben.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.