First own VPS - VPN-Setup problems

Alles rund um Netzwerktechnik und Protokolle
chrischw
Posts: 3
Joined: 2012-06-10 21:11

First own VPS - VPN-Setup problems

Post by chrischw »

Hi Commmunity,

I just ordered my first VPS and want to set up a PPTP-server on it (Debian 6.0).

However, I am not totally new to the Linux world and managed the setup at home on a VM, but this VPS-thing appears to be a little bit different.

I have setup the pptpd and it's config files but as i try to connect from any client, I always get an error that the connection timed out.

For test purposes, I have removed all iptables rules and - what a wonder - I get a ping from the machine.

Does anyone have an idea why I do not even get a connection to that thing?

Thanks in advance,
Christian
User avatar
rudelgurke
Posts: 408
Joined: 2008-03-12 05:36

Re: First own VPS - VPN-Setup problems

Post by rudelgurke »

Hello :)

U may write german as well if u want - though back to topic - any specific reason for Iptables at this server ?
And if so, maybe enable logging that you can modify your rules matching your desired setup, based on the log output, so your pptp connection isn't blocked any longer.
chrischw
Posts: 3
Joined: 2012-06-10 21:11

Re: First own VPS - VPN-Setup problems

Post by chrischw »

Enabling logging had no effect in syslog... Are there any other firewalls that might be pre-installed on the system (used the hoster's standard debian appliance...)?
User avatar
rudelgurke
Posts: 408
Joined: 2008-03-12 05:36

Re: First own VPS - VPN-Setup problems

Post by rudelgurke »

Well - related to Iptables logging - something like - the final REJECT rule

Code: Select all

iptables -N LOGREJ
iptables -A LOGREJ -p tcp -j LOG --log-prefix "TCP Reject: "
iptables -A LOGREJ -p udp -j LOG --log-prefix "UDP Reject: "
iptables -A LOGREJ -j DROP
And the final Reject rules

Code: Select all

iptables -A INPUT -p tcp -i eth0 -j LOGREJ
iptables -A INPUT -p udp -i eth0 -j LOGREJ
Though note that pptp builds up another GRE based connection so just opening the port 1723 won't be enough when blocking the rest with a firewall.
chrischw
Posts: 3
Joined: 2012-06-10 21:11

Re: First own VPS - VPN-Setup problems

Post by chrischw »

Ok, so to make it short: I installed a clean, fresh Ubuntu Server and set the appropriate ports open in ufw.

So far, it now works from my iPhone when I am not on local WiFi so I think my router is doing some weird things, but that might be another topic...

Thanks anyway for your advices!