NAST meckert über Zonendatei

Bind, PowerDNS
mauronaut
Posts: 1
Joined: 2012-05-29 17:36

NAST meckert über Zonendatei

Post by mauronaut » 2012-05-29 18:03

Hallo Forum,

ich möchte gerne ein DDNS-Dienst auf meinem VServer haben, scheitere aber anscheinend bei der Config des Bind persé. Also DDNS erstmal hinten anstellen und BIND ans laufen bekommen...


Als Info vorab:

OS: Debian Squeeze mit bind 9.3.7 auf einem VServer mit eigener Domain.

Mein Hoster sollte den NS-Eintrag für meine Domain setzen (1. mein DNS, 2. Eintrag der Hoster) - Denic schmettert aber ab wegen der Fehler und meine Seite ist somit nicht mehr erreichbar.grrrr

Probiere hier mit NAST (Denic) rum, der meckert nun immer rum bei der Prüfung: ](*,)

Hier der Response vom NAST:
Error 116 SOA record response must be authoritative (resolver, answer)

[/10.121.46.5|/2001:608:6:7:3:0:0:11]=>srv001.dedi32.de/83.151.25.2:53 (UDP, PROTOCOL_EXPLICITLY_CHOSEN, Timeout: 3s, Retry: 1 x 0s, unsecure, ignoreTC)
[/10.121.46.5|/2001:608:6:7:3:0:0:11]=>srv001.dedi32.de/83.151.25.2:53 (UDP, PROTOCOL_EXPLICITLY_CHOSEN, Timeout: 3s, Retry: 1 x 0s, unsecure, ignoreTC): RA <No records>

Warning 120 Recursive queries should not be allowed (resolver)

[/10.121.46.5|/2001:608:6:7:3:0:0:11]=>meinserver.vxxx.de/83.151.22.xxx:53 (UDP, PROTOCOL_EXPLICITLY_CHOSEN, Timeout: 3s, Retry: 1 x 0s, unsecure, ignoreTC)

Warning 120 Recursive queries should not be allowed (resolver)

[/10.121.46.5|/2001:608:6:7:3:0:0:11]=>srv001.dedi32.de/83.151.25.2:53 (UDP, PROTOCOL_EXPLICITLY_CHOSEN, Timeout: 3s, Retry: 1 x 0s, unsecure, ignoreTC)


Hier meine Zonendatei (xxxx.de = meine domain):

Code: Select all

$TTL 86400
@       IN      SOA     ns.xxxx.de.      post.xxxx.de. (
                        2012052714       ; serial number YYMMDDNN
                        10000           ; Refresh
                        1800            ; Retry
                        604800          ; Expire
                        3600            ; Min TTL
         )

                IN        NS      ns.xxxx.de.
                IN        NS      nameserv2.meinisp.com.

                IN        MX      10 mail.xxxx.de.

                IN        A       83.151.22.xxx

$ORIGIN xxxx.de.
@                         A       83.151.22.xxx
test2           IN        A       83.151.22.xxx
ns              IN        A       83.151.22.xxx
mail            IN        A       83.151.22.xxx
www             IN        A       83.151.22.xxx



Meine Fragen sind nun:
1. Wie bekomme ich genau die Fehler vom NAST-Check weg.
2. Wie mache ich die ganze Sache möglichst sicher. Im Prinzip reicht es ja, wenn der Nameserver meines Hosters anfragen stellen darf und sonst keiner, oder?
3. Ist die Config so überhaupt richtig von meinem Bind?


Das ist mein erster DNS-Server mit Bind....also bitte verzeiht mir doofe Fragen - habe jetzt schon soviel gelesen/geändert aber komme einfach nicht weiter :(( - jetzt benötige ich Hilfe von Profis ^:)^


Vielen Dank schonmal vorab und hoffentlich kriegen wir das gemeinsam gelöst... :D

Gruß
Mauro