Apache 2 & Suphp will einfach nicht

Apache, Lighttpd, nginx, Cherokee
Krutok
Posts: 60
Joined: 2012-03-10 17:42

Apache 2 & Suphp will einfach nicht

Post by Krutok » 2012-03-22 19:14

Hi,

Lange ist es her als ich es das letzte mal verwendet habe, daher stelle ich gleich mal mein Problem vor.

Apache 2 & suphp alles per apt installiert und folgenden vhost eingerichtet:

Code: Select all

 <VirtualHost 192.168.178.20:80>
      DocumentRoot /home/micha/www
      ServerName micha.sytes.net
 <Directory /home/micha/www>
      suPHP_Engine on
      php_admin_value engine off
      AddHandler x-httpd-php   .php
      SuPHP_AddHandler x-httpd-php
      AllowOverride All
      Order allow,deny
      Allow from all
 </Directory>
</VirtualHost>


Nachdem ich "php_admin_value engine off" gesetzt habe in der vhost will er die Dateien immer nur runterladen. Entferne ich die zeile, dann wird die phpinfo datei normal ausgeführt.

Irgendwo ist noch der wurm drin und hab ein wenig gegoogelt, aber konnte mein Problem nicht lösen, daher frage ich hier jetzt mal wie man das Problem lösen kann.

hier noch die suphp.conf

Code: Select all

[global]
;Path to logfile
logfile=/var/log/suphp/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=www-data

;Path all scripts have to be in
;docroot=/var/www:${HOME}/public_html
docroot=/home

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0077

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100


[handlers]
;Handler for php-scripts
application/x-httpd-suphp="php:/usr/bin/php-cgi"

;Handler for CGI-scripts
x-suphp-cgi="execute:!self"


URL: http://micha.sytes.net/info.php

Krutok
Posts: 60
Joined: 2012-03-10 17:42

Re: Apache 2 & Suphp will einfach nicht

Post by Krutok » 2012-03-22 21:40

niemand eine idee?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache 2 & Suphp will einfach nicht

Post by Joe User » 2012-03-22 22:21

Liefert Debian keine Beispielkonfiguration mit?

suPHP wird nicht mehr häufig verwendet, heute kommt stattdessen meist mod_fcgid zum Einsatz, was aber zunehmend von PHP-FPM verdrängt wird.
Für neue Setups würde sich also PHP-FPM anbieten, da zukunftssicher.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Krutok
Posts: 60
Joined: 2012-03-10 17:42

Re: Apache 2 & Suphp will einfach nicht

Post by Krutok » 2012-03-23 06:05

Ne Debian bietet da keine Beispielkonfiguration an, aber hab ja gegoogelt und so die Tips und kniffe ausprobiert.

Damals hab ich es mit dem 1.4 Apache und php4 gemacht; nicht aber mit Apache2 und es ist halt schon paar jahre her :-D

Werde mir das mod_fcgid mal anschauen.
Dazu ist ja ein Home Linuxserver ganz praktisch, um wieder in die Materie reinzukommen :wink:
Last edited by Krutok on 2012-03-23 06:06, edited 1 time in total.