Konflikt zwischen php und php53

Alles was in keine andere Systemkategorie passt
splitti
Posts: 21
Joined: 2007-02-08 22:20

Konflikt zwischen php und php53

Post by splitti » 2012-03-10 13:39

Ich hab auf einem virtual Server mit CentOS5 unter anderem nagios installiert. Verwaltet wird der Server mit Plesk. Ich wollte jetzt in Plesk von PHP (5.1) auf PHP53 (5.3) umstellen. Allerdings hat nagios Abhängigkeiten zu php und deshalb kann ich nicht auf php53 umstellen.
Kann ich dem Nagios-Paket nachträglich irgendwie die Abhängigkeit ändern?

Ich hab jetzt erst mal nagios deinstalliert, weil mir php53 wichtiger ist.

Wenn ich jetzt nagios wieder installieren will, geht das eben nicht, wegen besagtem Konflikt:

Code: Select all

php53-common-5.3.3-5.el5.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common

jan10001
Anbieter
Posts: 727
Joined: 2004-01-02 12:17

Re: Konflikt zwischen php und php53

Post by jan10001 » 2012-03-11 15:02

Keine Ahnung wie du PHP umgestellt hast, aber es war kein sauberes Update und deswegen kommt diese Meldung.

splitti
Posts: 21
Joined: 2007-02-08 22:20

Re: Konflikt zwischen php und php53

Post by splitti » 2012-03-11 15:12

Doch, war ein sauberes Update. Aber das Problem hat sich erledigt. Der Virtual-Server ist schon wieder abbestellt und ein Root-Server bestellt. War doch zu klein dimensioniert.

jan10001
Anbieter
Posts: 727
Joined: 2004-01-02 12:17

Re: Konflikt zwischen php und php53

Post by jan10001 » 2012-03-11 15:44

Sry, die Medlung bezieht sich auf einen bekannten Bug.
http://bugs.centos.org/view.php?id=4852 ... 1#bugnotes