Reverse Proxy Apache2

Apache, Lighttpd, nginx, Cherokee
tsaenger
Posts: 414
Joined: 2003-08-13 01:14

Reverse Proxy Apache2

Post by tsaenger » 2012-03-05 12:02

Hallo zuammen,

ich habe mir gerade den Reverse Proxy im Apache2 eingerichtet:

Code: Select all

<VirtualHost *:80>
ServerName name.tld.de
        ProxyPass / http://10.17.0.6/
        ProxyPassReverse / http://10.17.0.6/

</VirtualHost>

Leider ist es aber scheinbar so, dass der Proxy dem Webserver eine falsche Adresse übermittelt, denn ich bekomme beim Anmelden am Webserver diese Meldung:

Code: Select all

TYPO3 Fatal Error: Error: This host address ("10.17.0.6") and the referer host ("name.tld.de") mismatches!

In Typo3 kann ich den Check zwar ausschalten, aber ich denke das beseitigt nur die Fehlermeldung aber nicht das tatsächliche problem.

Hat jemand eine Idee wie ich das korrigieren kann?

Vielen Dank.

Gruß

Tobias

ddm3ve
Moderator
Moderator
Posts: 1143
Joined: 2011-07-04 10:56

Re: Reverse Proxy Apache2

Post by ddm3ve » 2012-03-05 12:10

Das Geheimnis liegt unter anderem im Header X_FORWARDED_FOR.

Es gibt aber ggf. noch ein paar weitere Dinge zu beachten.
http://www.typo3.net/forum/beitraege/di ... gen/63235/

Bei mir funktionieren alle Typo3 Seiten ohne nennenswerte Problem hinter einen apache Proxy.

Wie sieht Deine Proxy Konfiguration aus?
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.

tsaenger
Posts: 414
Joined: 2003-08-13 01:14

Re: Reverse Proxy Apache2

Post by tsaenger » 2012-03-05 15:30

Hallo ddm3ve,

vielen Dank für deine Antwort.
Ich habe bis auf die oben stehende Einstellung sonst nichts am Proxy definiert.
Das es am Header liegen kann habe ich auch schon gelesen, aber wie kann ich diesen beeinflussen?
Dazu habe ich leider noch nichts gefunden.

ddm3ve
Moderator
Moderator
Posts: 1143
Joined: 2011-07-04 10:56

Re: Reverse Proxy Apache2

Post by ddm3ve » 2012-03-06 14:20

Es liegt wohl daran, dass die Header nicht bzw. flasch übertragen werden.

sind folgende Optionen gesetzt?
Die erste Option ist übrigens dafür Verantwortlich, dass der requestete Hostname an den Webserver im Backend durch den Proxy weiter gegeben wird.

In Deinem Fall Domain.tld statt der im Proxy eingegebenen ip.

ProxyPreserveHost On

ProxyRequests Off
ProxyVia Off
SetEnv force-proxy-request-1.0 1.0

Und BTW:

Ihr solltet folgende Hinweise in der apache doku ernst nehmen:

Warning

Do not enable proxying with ProxyRequests until you have secured your server. Open proxy servers are dangerous both to your network and to the Internet at large.

ich spreche da aus erfahrung durch eine unachtsamkeit habe ich leider einen Proxy für alle geöffnet und hatte schon ca. 20 Minuten später eine nicht unerhebliche netzwerklast dankbarer anonym Surfer.

Gott sei dank, die Ursache gleich bemerkt und sofort darauf reagiert.
So wie e bei dir aus sieht, besteht durchaus die chance, das Du ggf. auch einen öffentlich nutzbaren Proxy anbietest.
Last edited by ddm3ve on 2012-03-06 14:24, edited 1 time in total.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.