Eigenartiges Problem beim TS3 installieren

Serverdienste ohne eigene Kategorie
paykoman
Posts: 81
Joined: 2006-07-16 14:18

Eigenartiges Problem beim TS3 installieren

Post by paykoman »

Hallo Forum,

also ich habe einen Squeeze 6.0 Server hatte vorher immer Open suse und konnte dort die Userverwalung einfacher handhaben als hier und ich denke das dort auch das aktuelle Problem liegt...

Meine Schritte:
1) mkdir /home/teamspeak

2) adduser teamspeak

(Dann erfolgt Passworteingabe)

3) chown -R teamspeak /home/teamspeak/

4) Teamspeak geladen per wget

5) tar xfvz ts3xyz.tar.gz

6) Inhalt von /home/teamspeak/teamspeak3-server_linux-x86 nach /home/teamspeak verschoben

Code: Select all

teamspeak@web01: ./ts3server_startscript.sh start
Starting the TeamSpeak 3 server
TeamSpeak 3 server started, for details please view the log file
teamspeak@web01: ./ts3server_startscript.sh: 109: ./ts3server_linux_x86: not found
Seltsam ist das er anfängt den Server zu starten legt auch die .pid Datei an aber dann sagt er die ts3server_minimal_runscript.sh wäre nicht auf zu finden??? o.O
Leider blicke ich hier das Problem nicht ich bin in dem Ordner drin wo auch die Datei liegt (777) und rufe diese auf und er sagt es gibt sie nicht, bin ratlos =(

Hier noch paar infos:

Code: Select all

teamspeak@web01:~$ ls -la
insgesamt 11912
drwxr-xr-x 8 teamspeak root         4096 31. Jan 12:48 .
drwxr-xr-x 4 root      root         4096 31. Jan 12:05 ..
-rw------- 1 teamspeak teamspeak     137 31. Jan 12:40 .bash_history
-rw-r--r-- 1 teamspeak teamspeak   34858 17. Nov 08:36 CHANGELOG
drwxr-xr-x 2 teamspeak teamspeak    4096 17. Nov 08:36 doc
-rwxr-xr-x 1 teamspeak teamspeak  207779 17. Nov 08:36 libts3db_mysql.so
-rwxr-xr-x 1 teamspeak teamspeak  916223 17. Nov 08:36 libts3db_sqlite3.so
-rw-r--r-- 1 teamspeak teamspeak   24099 17. Nov 08:36 LICENSE
drwx------ 2 teamspeak teamspeak    4096 31. Jan 12:20 .mc
drwxr-xr-x 2 teamspeak teamspeak    4096 17. Nov 08:36 serverquerydocs
drwxr-xr-x 4 teamspeak teamspeak    4096 17. Nov 08:36 sql
drwxr-xr-x 2 teamspeak teamspeak    4096 31. Jan 12:50 teamspeak3-server_linux-x86
-rwxrwxrwx 1 teamspeak teamspeak 6696332 17. Nov 08:36 ts3server_linux_x86
-rwxrwxrwx 1 teamspeak teamspeak     432 17. Nov 08:36 ts3server_minimal_runscript.sh
-rwxrwxrwx 1 teamspeak teamspeak    2842 17. Nov 08:36 ts3server_startscript.sh
-rw-r--r-- 1 teamspeak teamspeak 4267130 17. Nov 08:41 ts3.tar.gz
drwxr-xr-x 2 teamspeak teamspeak    4096 17. Nov 08:36 tsdns
teamspeak@web01:~$ ls -la ts3server_startscript.sh
-rwxrwxrwx 1 teamspeak teamspeak 2842 17. Nov 08:36 ts3server_startscript.sh

Ich hoffe ihr könnt mir ein paar Tipps geben und mir ggf. weiter helfen..

MFG: Paykoman

jan10001
Anbieter
Posts: 726
Joined: 2004-01-02 12:17

Re: Eigenartiges Problem beim TS3 installieren

Post by jan10001 »

Du hast zwar einen User angelegt, allerdings hat dieser keine Rechte weil er in keiner Gruppe ist. Im Klartext er kann auf viele benötigten Dienste/Dateien usw. nicht zu greifen.

Bitte setzte auch die Dateirechte neu, 777 geht garnicht da kann man dir ja alles unterschieben und du führst es dann treu und brav aus.
Last edited by jan10001 on 2012-01-31 20:35, edited 2 times in total.

paykoman
Posts: 81
Joined: 2006-07-16 14:18

Re: Eigenartiges Problem beim TS3 installieren

Post by paykoman »

Hey, danke für diese Information, wie du weißt bin ich kein Profi und weiß nicht wie ich den user nun in eine Gruppe bekomme soweit ich gelesen habe sollte er eig. die Gruppe 10001 oder so haben (kam beim user erstellen).

Wäre toll wenn mir die Befehle nennen könntest (vllt auch noch den ein oder anderen nützlichen Befehl), hatte da heute schon gegoogelt bekam aber nix ausser adduser und deluser was nciht sehr hilfreich ist =(

MFG: Paykoman

jan10001
Anbieter
Posts: 726
Joined: 2004-01-02 12:17

Re: Eigenartiges Problem beim TS3 installieren

Post by jan10001 »

Google Suchworte: linux user gruppe zuweisen

Liefert mehr als genug gute Treffer.
Last edited by jan10001 on 2012-01-31 21:10, edited 1 time in total.