Server kam aus reboot nicht zurück (nach Plesk update)

Alles was in keine andere Systemkategorie passt
instinct-vfx
Posts: 4
Joined: 2011-06-27 21:53

Server kam aus reboot nicht zurück (nach Plesk update)

Post by instinct-vfx » 2011-06-27 22:08

Hallo zusammen,

ich war mir etwas unsicher wo genau das hingehört, daher habe ich mal unter "sonstige" geposted.

Das Problem beschreibt ja schon der Titel. Wobei ich nicht sicher bin ob das Plesk update (zunächst 9.5.3 pakete, dann auf 9.5.4) was damit zu tun hat.

Server Daten:

1und1 dedicated server L64
OpenSuse 10.2 64bit
Plesk 9.5.4

Der Server kam als wie erwähnt gar nicht erst aus dem reboot zurück, lies sich auch nicht pingen. Auch Verbindung mit der seriellen Konsole schlug fehl (blieb an Unterschiedlichen stellen hängen. Zuerst DIREKT beim Start:

Code: Select all

Trying 172.19.95.95...
Escape character is '^]'.
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 2.6.32.28 (root@buildd-amd64) (gcc version 4.3.2 (Debian 4.3.2-1.1) ) #1 SMP Mon Jan 17 10:22:53 CET 2011
[    0.000000] Comman


Dann habe ich festgestellt das scheinbar die Hauptpartition voll war und nach löschen lief er weiter, blieb aber dann später hängen. Beim letzten Versuch hat sich die Verbindung sofort beendet nachdem ich auf sercon.x die credentials eingegeben habe.

Einziger Zugang also via Recovery System. Was ich soweit gemacht habe:

Wie im Manual beschrieben Platten gecheckt, gemounted. Das ging soweit alles (hab bei der gelegenheit auch gleich noch ein volles Backup gezogen).

Memcheck (memecheck all steigt aus (liegt wohl am recovery system) mit niedrigeren Werten scheint es mal okay)

/var/log/boot.msg und boot.omsg scheinen bereits sehr alt zu sein und nicht mehr geschrieben zu werden (2008 (!?!)

messages letzter Eintrag (zeitlich mit dem reboot)

Code: Select all

Jun 27 11:10:22 s15287994 shutdown[7712]: shutting down for system reboot
Jun 27 11:10:22 s15287994 init: Switching to runlevel: 6
Jun 27 11:10:23 s15287994 qmail: 1309165823.159372 status: exiting
Jun 27 11:10:23 s15287994 sshd[3795]: Received signal 15; terminating.
Jun 27 11:10:23 s15287994 xinetd[2963]: Exiting...
Jun 27 11:10:24 s15287994 kernel: Kernel logging (proc) stopped.
Jun 27 11:10:24 s15287994 kernel: Kernel log daemon terminating.
Jun 27 11:10:25 s15287994 syslog-ng[14020]: syslog-ng version 1.6.11 going down


Daraus würde ich jetzt mal schliessen das bereits beim Reboot nichts mehr ging.

Irgendwelche Tips wie ich da weiter komme?

Schöne Grüße und Danke schonmal,
Thorsten

instinct-vfx
Posts: 4
Joined: 2011-06-27 21:53

Re: Server kam aus reboot nicht zurück (nach Plesk update)

Post by instinct-vfx » 2011-06-27 22:49

Kleines Update. Ich vermute (großes "vermute") Das Plesk versucht hat ein Kernel Update zu machen und es aufgrund von mangelndem Platz nicht zuende gebracht hat...dann reboot -> Tot.

Der Verdacht kam bei mir auf da auf der platte in boot/ die files in unterschiedlichen kernel-versionen vorliegen. Aber nicht alle auch in der neueren:

Code: Select all


-rw-r--r--  1 root root  953159 Nov 27  2006 System.map-2.6.18.2-34-default
-rw-r--r--  1 root root 1290771 Nov  8  2007 System.map-2.6.20.21-071108a
-rw-------  1 root root     512 Sep 19  2007 backup_mbr
lrwxrwxrwx  1 root root       1 Jan 26  2008 boot -> .
-rw-r--r--  1 root root     512 Jan 26  2008 boot.0800
-rw-r--r--  1 root root     512 Jan 26  2008 boot.0810
-rw-r--r--  1 root root   64105 Nov 27  2006 config-2.6.18.2-34-default
-rw-r--r--  1 root root   34910 Nov  8  2007 config-2.6.20.21-071108a
drwxr-xr-x  2 root root    4096 Jun 27 22:20 grub
-rw-r--r--  1 root root 3003978 Sep 18  2007 initrd-2.6.18.2-34-default
lrwxrwxrwx  1 root root      26 Jan 26  2008 initrd.old -> initrd-2.6.18.2-34-default
drwx------  2 root root   49152 Jan 26  2008 lost+found
-rw-------  1 root root   74240 Jun 27 22:22 map
-rw-------  1 root root  379904 Sep 19  2007 message
-rw-r--r--  1 root root   86365 Nov 27  2006 symsets-2.6.18.2-34-default.tar.gz
-rw-r--r--  1 root root  338728 Nov 27  2006 symtypes-2.6.18.2-34-default.gz
-rw-r--r--  1 root root   99344 Nov 27  2006 symvers-2.6.18.2-34-default.gz
-rwxr-xr-x  1 root root 2114468 Nov 27  2006 vmlinux-2.6.18.2-34-default.gz
lrwxrwxrwx  1 root root      27 Jan 26  2008 vmlinux.old -> vmlinuz-2.6.18.2-34-default
lrwxrwxrwx  1 root root      25 Jan 26  2008 vmlinuz -> vmlinuz-2.6.20.21-071108a
-rw-r--r--  1 root root 1619191 Nov 27  2006 vmlinuz-2.6.18.2-34-default
-rw-r--r--  1 root root 2875376 Nov  8  2007 vmlinuz-2.6.20.21-071108a


Wie zu sehen liegen system.map, config- und vmlinuz- in 2.6.20... vor während die anderen files nur als 2.6.18 vorliegen. In grub.lst ist 2.6.18 angegeben.

Ich würde dem Server ungern aus Mangel an Erfahrung den Rest geben und bin für jeden tip dankbar.

Thorsten

instinct-vfx
Posts: 4
Joined: 2011-06-27 21:53

Re: Server kam aus reboot nicht zurück (nach Plesk update)

Post by instinct-vfx » 2011-06-27 23:01

Wie das immer so ist wenn man den Grad an Verzweiflung erreicht hat um anderen damit auf die Nerven zu gehen löst das Posten die Gehirnwindungen.

Habe das "halbe" Kernelupdate "zurückgenommen" in dem ich den vmlinuz symbolic link auf die alte version gebogen habe.

Memo an mich selbst: Bei Plesk immer erst mal massiv Speicher bereitstellen, dann updaten.

Grüße,
Thorsten

User avatar
rudelgurke
Systemtester
Systemtester
Posts: 408
Joined: 2008-03-12 05:36

Re: Server kam aus reboot nicht zurück (nach Plesk update)

Post by rudelgurke » 2011-06-27 23:04

Ähm - naja - ich würde evtl. empfehlen die Kiste sauber neu aufzusetzen mit einem aktuellen SuSe - wenn man dabei bleiben will. Die 10.2 ist - naja - eher etwas für's Museum.
Dann auf einer neueren Version Plesk wieder aufspielen und die Backups von Plesk einpflegen - inkl. der Lizenzdatei.
Nur ein Vorschlag - ist vielleicht der einfachere Weg als die Kiste wieder online zu bringen und dann das benötigte Distro-Upgrade zu machen.

instinct-vfx
Posts: 4
Joined: 2011-06-27 21:53

Re: Server kam aus reboot nicht zurück (nach Plesk update)

Post by instinct-vfx » 2011-06-28 00:16

Hallo,

danke für das Feedback. Mein momentaner Plan war eigentlich den wackeligen Stand als zwischenlösung zu behalten, neue Kiste (bessere HW, wechsel zu Ubuntu LTS) bestellen, migrieren und dann die alte vom Netz nehmen.

Grüße,
Thorsten