Mails kommen trotz ausgeschaltetem postgreys nicht an

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
User avatar
lumio
Posts: 46
Joined: 2008-05-24 16:48

Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by lumio » 2011-03-21 23:12

Hi,

hab einen Kunden, bei dem die Mails mit ausgeschaltetem postgreys allerdings mit Maia nicht ankommen.

Habe in der Log folgende Zeilen gefunden:

Code: Select all

Mar 21 12:17:20 myhost postfix/policyd-weight[3447]: weighted check:  NOT_IN_SBL_XBL_SPAMHAUS=-1.5 NOT_IN_SPAMCOP=-1.5 NOT_IN_BL_NJABL=-1.5 CL_IP_NE_HELO=1.5 RESOLVED_IP_IS_NOT_HELO=1.5 (check from: .example. - helo: .smtp.example. - helo-domain: .example.)  MAIL_SEEMS_FORGED=2.5; <client=xx.xx.xx.xx> <helo=smtp.example.lan> <from=mail@example.org> <to=receiver@example.org>; rate: 1 
Mar 21 12:17:20 myhost postfix/policyd-weight[3447]: decided action=550 Mail appeared to be SPAM or forged. Ask your Mail/DNS-Administrator to correct HELO and DNS MX settings or to get removed from DNSBLs; MTA helo: smtp.example.lan, MTA hostname: netxx-xx-xx-xx.link.org[xx.xx.xx.xx] (helo/hostname mismatch); <client=xx.xx.xx.xx> <helo=smtp.example.lan> <from=mail@example.org> <to=receiver@example.org>; delay: 0s
Mar 21 12:17:20 myhost postfix/smtpd[3895]: NOQUEUE: reject: RCPT from netxx-xx-xx-xx.link.org[xx.xx.xx.xx]: 550 5.7.1 <receiver@example.org>: Recipient address rejected: Mail appeared to be SPAM or forged. Ask your Mail/DNS-Administrator to correct HELO and DNS MX settings or to get removed from DNSBLs; MTA helo: smtp.example.lan, MTA hostname: netxx-xx-xx-xx.link.org[xx.xx.xx.xx] (helo/hostname mismatch); from=<mail@example.org> to=<receiver@example.org> proto=ESMTP helo=<SMTP.EXAMPLE.LAN>


Ich hab grad in meinen konfigurationsdateien geschaut. Ich habe nichts mit der nummer 3447 definiert.
Danke schonmal :)

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by Roger Wilco » 2011-03-21 23:20

Wie kommst du auf postgrey oder Maia Mailguard? In deinen Logs steht doch eindeutig, dass policyd-weight die E-Mail ablehnt – übrigens mit schön detaillierter Begründung.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by Joe User » 2011-03-21 23:37

Der sendende Mailserver hat keinen zum Reverse-DNS passenden HELO geschickt, zudem scheint er auch noch hinter einer dynamischen IP zu stehen. Beides machen nur Spammer und lesefaule Hobbyadmins...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
lumio
Posts: 46
Joined: 2008-05-24 16:48

Re: Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by lumio » 2011-03-22 09:38

Mhm, sollte mir eigentlich auch besser auf einen managed server umsteigen.

Naja, kann ich für diese eine mail bzw für diese Domain eine whitelist machen?

Greets

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by Joe User » 2011-03-22 10:26

Da der andere Mailserver völlig falsch konfiguriert ist, solltest Du das nicht auch noch durch eine Whitelist unterstützen. Bitte den anderen Mailserveradmin darum die Fehler zu beseitigen, damit er Dir und allen anderen vernünftig konfigurierten Mailservern wieder Mails zustellen kann. Wenn er seine Konfiguration nicht anpassen will, dann muss er Dir die Mails eben per Snailmail (aka Post) zustellen.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
lumio
Posts: 46
Joined: 2008-05-24 16:48

Re: Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by lumio » 2011-03-25 10:23

Hi :)
Danke... jetzt noch die frage: wie finde ich die mail vom admin raus? einfach mal die mails webmaster/postmaster/...@xy.com probieren?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Mails kommen trotz ausgeschaltetem postgreys nicht an

Post by Joe User » 2011-03-25 11:29

Laut RFC ist für den Mailserver postmaster@ vorgesehen, also den zuerst, wenn das nicht reicht dann admin@ und zum Schluss webmaster@ und info@
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.