Entfernen von2 Paketen schlägt fehl | Debian Lenny

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
tsaenger
Posts: 414
Joined: 2003-08-13 01:14

Entfernen von2 Paketen schlägt fehl | Debian Lenny

Post by tsaenger » 2011-02-25 16:18

Hallo zusammen,

ich habe ein Problem.

Ich verwende ein Debian Lenny und kann keine Programme mehr installieren, da wohl 2 Pakete installiert sind die sich nicht entfernen lassen.

Meine Fehlermeldung lautet wie folgt:

Code: Select all

Error: /usr/sbin/remove-default-ispell not present or executable. Missing dependency on dictionaries-common?
dpkg: Fehler beim Bearbeiten von ingerman (--remove):
 Unterprozess post-removal script gab den Fehlerwert 1 zurück
Entferne wngerman ...
Error: /usr/sbin/remove-default-wordlist not present or executable. Missing dependency on dictionaries-common?
dpkg: Fehler beim Bearbeiten von wngerman (--remove):
 Unterprozess post-removal script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 ingerman
 wngerman


ich habe schon über apt-get remove --purge und aptitude versucht diese zu deinstallieren, leider ohne Erfolg.

Hat jemand von euch eine Idee wie ich den Konflikt beheben kann?

Unter usr/sbin kann ich tatsächlich die remove-scripte nicht finden.

Danke

Tobias

User avatar
rudelgurke
Posts: 405
Joined: 2008-03-12 05:36

Re: Entfernen von2 Paketen schlägt fehl | Debian Lenny

Post by rudelgurke » 2011-02-25 17:56

1. Alternative ist ein work-around und keine Lösung.

files="remove-default-ispell remove-default-wordlist"
for tempfile in $FILES; do
touch $tempfile
chmod +x $tempfile
done

Damit hat apt etwas zum ausführen. Die andere und wohl bessere Alternative wäre beide Pakete per apt-get nochmal zu laden, nicht zu installieren, und dann manuell zu entpacken und beide Binaries bzw. Scripte an Ort und Stelle zu kopieren.