SSL Zertifikat für einzelne Domain funktioniert nicht

Serverdienste ohne eigene Kategorie
mcfly
Posts: 92
Joined: 2005-09-20 17:10

SSL Zertifikat für einzelne Domain funktioniert nicht

Post by mcfly »

Hallo an alle

Ich sitze nun schon wieder vor einem Problem. Ich möchte für eine einzelne Domain ein separates SSL Zertifikat erstellen.

Im confixx Bereich habe ich dem Kunden (sind bei mir zwar keine aber steht ja so dort drinne) eine einzelne Domain gegeben. Danach auf denn SSL Punkt geklickt und der User mit der eigenen IP Adresse wird angezeigt ohne Zertifikat.

Nun habe ich von Confixx angeblich eins erstellen lassen aber sobald ich es im Browser aufrufe bekomme ich folgende Fehlermeldung:

(Fehlercode: ssl_error_rx_record_too_long)


Da ich nun schon seid gestern über dem Problem hänge habe ich natürlich mir schon etliche Dinge angesehen und bemerkt das unter /etc/apache2/ssl.crt und ssl.key sich nichts getan hat. Nun habe ich in der vhost von dem User nachgesehen und feststellen müssen das diese Domain über den Schlüssel in admin.key und admin.crt per https aufzurufen sei.

Diese Dateien sind auch vorhanden aber ich kriege im Firefox immer noch diesen Fehler.

Rufe ich alle anderen Domains mit dem Shared SSL auf, habe ich dabei keine Probleme. Probleme habe ich also nur mit der einen Domain mit eigener IP.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by Joe User »

Wie sehen die SSL-VHosts in der httpd.conf aus?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

mcfly
Posts: 92
Joined: 2005-09-20 17:10

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by mcfly »

Also in der httpd.conf stehen die vhosts ja nicht drinne sondern im Ordner confixx_vhosts

Für den User web1 mit seiner Domain steht einmal der entsprechende vhost Eintrag zu der IP so drinne:

NameVirtualHost 10.0.2.1:443

Mehr steht zu dieser IP und Port 443 nicht drinne.

Dazu gibt es die virtualhost Datei die für ander IP und Port 443
<VirtualHost 10.0.1.1:443>
ServerName web1.srv1.srv-test.de
DocumentRoot /srv/www/htdocs/web1/html
SuexecUserGroup web1 web1
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web1/html/:/srv/www/htdocs/web1/phptmp/:/srv/www/htdocs/web1/files/:/srv/www/htdocs/web1/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web1/phptmp/
<IfDefine SSL>
SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/srv/www/htdocs/web1/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>
</IfDefine>
</VirtualHost>
Bei Por 80 ist ein ähnliches Spiel nur das dort extra ein virtualhost für die IP 10.0.2.1 geschaffen wurde
<VirtualHost 10.0.2.1:80>
ServerName www.testdomain.de
ServerAlias testdomain.de
DocumentRoot /srv/www/htdocs/web1/html
SuexecUserGroup web1 web1
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web1/html/:/srv/www/htdocs/web1/phptmp/:/srv/www/htdocs/web1/files/:/srv/www/htdocs/web1/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web1/phptmp/
</VirtualHost>

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by Joe User »

OK, poste bitte mal alle Listen-Zeilen, NameVirtualHost-Zeilen und VirtualHost-Abschnitte in der exakten(!) Reihenfolge in der sie in der httpd.conf beziehungsweise den anderen Apache-Configs vorkommen. Zusätzlich bitte auch den <IfModule ssl_module>-Abschnitt.

PS: Bei "Include blubber/*.conf" geht Apache die Dateinamen alphabetisch durch.
Last edited by Joe User on 2010-12-28 12:51, edited 1 time in total.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

mcfly
Posts: 92
Joined: 2005-09-20 17:10

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by mcfly »

Also in der httpd.conf wird in dieser Reihenfolge geladen

listen.conf
#Listen 80
Listen 443

Listen 80


<IfDefine SSL>
<IfDefine !NOSSL>
<IfModule mod_ssl.c>

Listen 443

</IfModule>
</IfDefine>
</IfDefine>
Den Listeneintrag zwiete Zeile habe ich auskommentiert da vorher nichtmal das shared ssl zertifikat lief.

Dann kommen einige andere geladene Dateien unter anderem die ssl.conf und dann geht es mit diesem Eintrag weiter:
############### PARALLELS CONFIXX APACHE MAIN CONFIG FILE #################
# created at Mon Dec 27 23:54:24 2010
#
# !!! Do not make any changes in this file !!!
#
# 1. We cannot guarantee that the software will work properly, if
# the contents of this file are modified.
# 2. This file would be rewritten after each Parallels Confixx software update and
# in some other cases. Thus all your changes would be lost unless you made
# a backup of the file.
#
# If you need to modify this file, you can insert some custom "Include"
# directives. E.g.
# Include /path/to/your/file
# Includes inserted directly after <VirtualHost> tag would keep their
# location inchanged after the file is updated. Other includes would
# be moved to be inserted before the </VirtualHost> tag.
##########################################################################

php_admin_value open_basedir /srv/www/htdocs
php_admin_value include_path .

<Directory "/srv/www/htdocs/confixx/html">

AllowOverride all

<IfModule mod_access.c>
Allow from all
</IfModule>
<IfModule mod_authz_host.c>
Allow from all
</IfModule>

<IfModule mod_rewrite.c>

RewriteEngine On
Options +FollowSymlinks

RewriteRule ^reseller/res[0-9]+/(.*)$ reseller/$1 [L]

RewriteRule ^user/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+/(.*)$ user/$1 [L]

RewriteRule ^ftplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+/(.*)$ ftplogin/$1 [L]
RewriteRule ^ftplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+f[0-9]+/(.*)$ ftplogin/$1 [L]

RewriteRule ^poplogin/[a-zA-Z][-a-zA-Z0-9_]{0,4}[0-9]+p[0-9]+/(.*)$ poplogin/$1 [L]

</IfModule>

AddDefaultCharset off

php_admin_flag engine on

</Directory>


NameVirtualHost 10.0.1.1:80

<VirtualHost 10.0.1.1:80>

ServerName 10.0.1.1

DocumentRoot /srv/www/htdocs/confixx/html/gesperrt

Options FollowSymLinks
php_admin_flag safe_mode Off
php_admin_flag file_uploads On
php_admin_flag track_vars On
php_admin_flag magic_quotes_runtime Off
php_admin_flag magic_quotes_gpc Off
php_admin_flag allow_url_fopen Off

php_admin_value include_path ".:/srv/www/htdocs/confixx/html/include:/srv/www/htdocs/confixx/html:/srv/www/htdocs/confixx/html/PEAR"
php_admin_value default_charset none
php_admin_value open_basedir /srv/www/htdocs/confixx

<IfModule mod_dir.c>
DirectoryIndex index.php index.html index.htm index.shtml index.cgi
</IfModule>


</VirtualHost>

<VirtualHost 10.0.1.1:80>

ServerName srv1.srv-test.de

#User confixx
#Group confixx
DocumentRoot /srv/www/htdocs/confixx/html
Options FollowSymLinks


php_admin_flag safe_mode Off
php_admin_flag file_uploads On
php_admin_flag track_vars On
php_admin_flag magic_quotes_runtime Off
php_admin_flag magic_quotes_gpc Off
php_admin_value upload_tmp_dir /srv/www/htdocs/confixx/tmp
php_admin_value include_path ".:/srv/www/htdocs/confixx/html/include:/srv/www/htdocs/confixx/html:/srv/www/htdocs/confixx/html/PEAR"
php_admin_value default_charset none
php_admin_value open_basedir /srv/www/htdocs/confixx
php_admin_flag allow_url_fopen Off

php_admin_value session.cookie_path /
php_admin_value session.auto_start 0
php_admin_value session.gc_maxlifetime 1800
php_admin_value session.use_cookies 1
php_admin_value session.cookie_lifetime 0
php_admin_value session.cookie_secure Off
php_admin_value session.use_trans_sid 0

ScriptAlias /cgi-bin/ /srv/www/htdocs/confixx/html/cgi-bin/

<IfModule mod_dir.c>
DirectoryIndex index.html index.htm index.shtml index.cgi index.php
</IfModule>


CustomLog /var/log/apache2/server5-2.pcfuchs-server.de_access.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
ErrorLog /var/log/apache2/server5-2.pcfuchs-server.de_error.log


</VirtualHost>

NameVirtualHost 10.0.1.1:443

<VirtualHost 10.0.1.1:443>

ServerName 10.0.1.1

DocumentRoot /srv/www/htdocs/confixx/html/gesperrt

Options FollowSymLinks
php_admin_flag safe_mode Off
php_admin_flag file_uploads On
php_admin_flag track_vars On
php_admin_flag magic_quotes_runtime Off
php_admin_flag magic_quotes_gpc Off
php_admin_flag allow_url_fopen Off

php_admin_value include_path ".:/srv/www/htdocs/confixx/html/include:/srv/www/htdocs/confixx/html:/srv/www/htdocs/confixx/html/PEAR"
php_admin_value default_charset none
php_admin_value open_basedir /srv/www/htdocs/confixx

<IfModule mod_dir.c>
DirectoryIndex index.php index.html index.htm index.shtml index.cgi
</IfModule>


<IfModule mod_ssl.c>

SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt



SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>

<Directory "/srv/www/htdocs/confixx/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

</IfModule>


</VirtualHost>

<VirtualHost 10.0.1.1:443>

ServerName srv1.srv-test.de

#User confixx
#Group confixx
DocumentRoot /srv/www/htdocs/confixx/html
Options FollowSymLinks


php_admin_flag safe_mode Off
php_admin_flag file_uploads On
php_admin_flag track_vars On
php_admin_flag magic_quotes_runtime Off
php_admin_flag magic_quotes_gpc Off
php_admin_value upload_tmp_dir /srv/www/htdocs/confixx/tmp
php_admin_value include_path ".:/srv/www/htdocs/confixx/html/include:/srv/www/htdocs/confixx/html:/srv/www/htdocs/confixx/html/PEAR"
php_admin_value default_charset none
php_admin_value open_basedir /srv/www/htdocs/confixx
php_admin_flag allow_url_fopen Off

php_admin_value session.cookie_path /
php_admin_value session.auto_start 0
php_admin_value session.gc_maxlifetime 1800
php_admin_value session.use_cookies 1
php_admin_value session.cookie_lifetime 0
php_admin_value session.cookie_secure Off
php_admin_value session.use_trans_sid 0

ScriptAlias /cgi-bin/ /srv/www/htdocs/confixx/html/cgi-bin/

<IfModule mod_dir.c>
DirectoryIndex index.html index.htm index.shtml index.cgi index.php
</IfModule>


<IfModule mod_ssl.c>

SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt



SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>

<Directory "/srv/www/htdocs/confixx/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

</IfModule>


CustomLog /var/log/apache2/srv1.srv-test.de_access.ssl.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\""
ErrorLog /var/log/apache2/srv1.srv-test.de_error.ssl.log


</VirtualHost>

Include /etc/apache2/confixx_vhost.conf
# ^- Dieser Eintrag sollte unbedingt am Ende der Datei bleiben
## /PARALLELS CONFIXX
Hier habe ich nichts angefasst.

Jetzt wird ja die confixx_vhost.conf geladen
<Directory "/srv/www/htdocs">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options +FollowSymLinks +Includes
</Directory>

NameVirtualHost 85.214.88.64:80

<VirtualHost 85.214.88.64:80>

ServerName 85.214.88.64

DocumentRoot /srv/www/htdocs/confixx/html/gesperrt

Options +FollowSymLinks
php_admin_flag safe_mode Off
php_admin_flag file_uploads On
php_admin_flag track_vars On
php_admin_flag magic_quotes_runtime Off
php_admin_flag magic_quotes_gpc Off
php_admin_value include_path ".:/srv/www/htdocs/confixx/html/include:/srv/www/htdocs/confixx/html:/srv/www/htdocs/confixx/html/PEAR"
php_admin_value default_charset none
php_admin_value open_basedir /srv/www/htdocs/confixx
<IfModule mod_dir.c>
DirectoryIndex index.php index.html index.htm index.shtml index.cgi
</IfModule>

</VirtualHost>

NameVirtualHost 85.214.88.64:443
<VirtualHost 85.214.88.64:443>

ServerName 85.214.88.64

DocumentRoot /srv/www/htdocs/confixx/html/gesperrt

Options +FollowSymLinks
php_admin_flag safe_mode Off
php_admin_flag file_uploads On
php_admin_flag track_vars On
php_admin_flag magic_quotes_runtime Off
php_admin_flag magic_quotes_gpc Off
php_admin_value include_path ".:/srv/www/htdocs/confixx/html/include:/srv/www/htdocs/confixx/html:/srv/www/htdocs/confixx/html/PEAR"
php_admin_value default_charset none
php_admin_value open_basedir /srv/www/htdocs/confixx
<IfModule mod_dir.c>
DirectoryIndex index.php index.html index.htm index.shtml index.cgi
</IfModule>

<IfDefine SSL>
SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
</IfDefine>

</VirtualHost>


include /etc/apache2/confixx_vhosts/*.conf
Die IP (die zweite des Servers) die dort erscheint ist als Alias im Server unter der Netzwerkkarte eingetragen eine eigene Netzwerkkarte hat diese IP nicht.

Nun die vhost Dateien in dem Ordner confixx_vhosts
Ich denke das geht nach namen sortiert also erst die von web0 von confixx vermute ich mal
<Directory "/srv/www/htdocs/web0/html">
Options -FollowSymLinks -SymLinksIfOwnerMatch
<IfModule mod_access.c>
Allow from all
</IfModule>
<IfModule mod_authz_host.c>
Allow from all
</IfModule>
php_admin_flag engine on
</Directory>

<Directory "/srv/www/htdocs/web0/html/cgi-bin/">
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.cgihandler
</Files>
</IfModule>
</Directory>
<VirtualHost 10.0.1.1:443>
ServerName web0.server5-2.pcfuchs-server.de
DocumentRoot /srv/www/htdocs/web0/html
SuexecUserGroup web0 web0
ScriptAlias /cgi-bin/ /srv/www/htdocs/web0/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web0/html/:/srv/www/htdocs/web0/phptmp/:/srv/www/htdocs/web0/files/:/srv/www/htdocs/web0/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web0/phptmp/
<IfDefine SSL>
SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/srv/www/htdocs/web0/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>
</IfDefine>
</VirtualHost>

<VirtualHost 10.0.1.1:80>
ServerName web0.srv1.srv-test.de
DocumentRoot /srv/www/htdocs/web0/html
SuexecUserGroup web0 web0
ScriptAlias /cgi-bin/ /srv/www/htdocs/web0/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web0/html/:/srv/www/htdocs/web0/phptmp/:/srv/www/htdocs/web0/files/:/srv/www/htdocs/web0/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web0/phptmp/
</VirtualHost>
und danach die vom Web1. Dazu kurz noch gesagt ich habe den Hacken im Confixx bei SSL einmal entfernt und wieder gesetzt nach dem confixx seinen reload durchgeführt hatte. Jetzt steht in der web1.conf ein zusätzlicher vhost Eintrag auf die IP mit drinne. Leider behebt das nicht meine Fehlermeldung im Browser (Firefox Fehlermeldung, IE kann nicht anzeigen).
<Directory "/srv/www/htdocs/web1/html">
Options -FollowSymLinks -SymLinksIfOwnerMatch
<IfModule mod_access.c>
Allow from all
</IfModule>
<IfModule mod_authz_host.c>
Allow from all
</IfModule>
php_admin_flag engine on
</Directory>

<Directory "/srv/www/htdocs/web1/html/cgi-bin/">
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.cgihandler
</Files>
</IfModule>
</Directory>

NameVirtualHost 10.0.2.1:80

NameVirtualHost 10.0.2.1:443

<VirtualHost 10.0.2.1:443>
ServerName www.domain.com
ServerAlias domain.com
DocumentRoot /srv/www/htdocs/web1/html
SuexecUserGroup web1 web1
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web1/html/:/srv/www/htdocs/web1/phptmp/:/srv/www/htdocs/web1/files/:/srv/www/htdocs/web1/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web1/phptmp/
<IfDefine SSL>
SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/srv/www/htdocs/web1/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>
</IfDefine>
</VirtualHost>

<VirtualHost 10.0.2.1:80>
ServerName www.domain.com
ServerAlias domain.com
DocumentRoot /srv/www/htdocs/web1/html
SuexecUserGroup web1 web1
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web1/html/:/srv/www/htdocs/web1/phptmp/:/srv/www/htdocs/web1/files/:/srv/www/htdocs/web1/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web1/phptmp/
</VirtualHost>

<VirtualHost 10.0.1.1:443>
ServerName web1.srv1.srv-test.de
DocumentRoot /srv/www/htdocs/web1/html
SuexecUserGroup web1 web1
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web1/html/:/srv/www/htdocs/web1/phptmp/:/srv/www/htdocs/web1/files/:/srv/www/htdocs/web1/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web1/phptmp/
<IfDefine SSL>
SSLEngine on
SSLCertificateKeyFile /etc/apache2/ssl.key/admin.key
SSLCertificateFile /etc/apache2/ssl.crt/admin.crt
SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/srv/www/htdocs/web1/html/cgi-bin">
SSLOptions +StdEnvVars
</Directory>
</IfDefine>
</VirtualHost>

<VirtualHost 10.0.1.1:80>
ServerName web1.srv1.srv-test.de
DocumentRoot /srv/www/htdocs/web1/html
SuexecUserGroup web1 web1
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
<IfModule mod_python.c>
<Files ~ "\.py$">
AddHandler python-program .py
PythonHandler mod_python.publisher
</Files>
</IfModule>
php_admin_value open_basedir /srv/www/htdocs/web1/html/:/srv/www/htdocs/web1/phptmp/:/srv/www/htdocs/web1/files/:/srv/www/htdocs/web1/atd/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/htdocs/web1/phptmp/
</VirtualHost>

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by Joe User »

Auf 10.0.1.1 sind drei SSL-VHosts eingerichtet und das darf nicht sein. Pro IP-Adresse ist nur ein SSL-VHost erlaubt, Du musst Dir also mindestens zwei weitere IP-Adressen zulegen und die SSL-VHosts darauf aufsplitten.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

mcfly
Posts: 92
Joined: 2005-09-20 17:10

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by mcfly »

Die 10.0.1.1 funktioniert aber das ist die Adresse für die shared sll Domains. Könnte das der Grund für die drei vhosts sein?


Mein Problem ist ja die 10.0.2.1 welche den Fehler ausgibt.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by Joe User »

Ein weiteres Problem ist die Nutzung des Zertifikats (admin.*) für mehrere IPs und Domains. Normalerweise soll jeder SSL-VHost sein eigenes Zertifikat haben. Keine Ahnung was sich die Confixx-Entwickler dabei gedacht haben, aber so ganz richtig ist das meinem Verständnis der Apache-Doku nach nicht.

Ich kann Dir momentan nur raten, die von mir angeführten Probleme zu vermeiden und die Config dementsprechend zu überarbeiten. Eventuell kennt sich hier ja auch jemand mit den diesbezüglichen Confixx-Eigenheiten aus, für mich sieht es momentan nach Murks aka Bug aus...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

jan10001
Anbieter
Posts: 726
Joined: 2004-01-02 12:17

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by jan10001 »

Confixx ist eine grausame Sache, man war ich froh als Plesk kam. :-D
Die eigenwillige Apache Configuration verursacht wie man sieht massig Probleme.

Schau mal in die Apache Logfiles da dürften einige Fehlermeldungen drin stehen, die etwas mehr Licht an die Sache bringen.

mcfly
Posts: 92
Joined: 2005-09-20 17:10

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by mcfly »

So nachdem ich leider erstmal andere Sachen klären mußte sitze ich wieder einmal an diesem Problem.

Ich habe nun unter Confixx den Spass nochmals versucht und es wurde meiner Meinung nach nichtmal eine Key oder crt anglegt. Das durchsuchen der Log Dateien ist ebenfalls sehr aufschlussreich. über die zweite Domain und IP wurde nichts geloggt.

Nun habe ich mir weiterhin einen riesen kopf gemacht und mich weiter durch Foren gestöbert um dieses Problem nun endlich zu lösen. Was mir dabei aufgefallen ist das:

1. Confixx in der vhosts keinen Eintrag angelegt hat.

2. Ich die Domain unter www.domain.de:443 erreichen kann aber dort die Apache grundseite "It Works" erscheint.

3. Bei meinen selbst eingeschriebenen key und crt Dateien und einer Kopie von dem Shared SSL Vhosts und einer Änderung auf die Domain und key+crt Dateien der apache sich nicht mehr starten läßt da er die crt nicht lesen kann.

4. Wenn ich im Confixx ein Zertifikat einfügen will es eine Fehlermeldung gibt das "Schlüssel und Key nicht zusammen passen.


So langsam bin ich echt am verzweifeln was dieses Zertifikat angeht. Was kann ich denn vielleicht noch versuchen damit dieses blöde Ding endlich läuft?

jan10001
Anbieter
Posts: 726
Joined: 2004-01-02 12:17

Re: SSL Zertifikat für einzelne Domain funktioniert nicht

Post by jan10001 »