postfix + dovecot + imap = problem bei gesendeten opjekten

User avatar
coltseavers
Posts: 182
Joined: 2009-11-04 00:43
Location: NRW

postfix + dovecot + imap = problem bei gesendeten opjekten

Post by coltseavers »

hallo zusammen,

ich habe ein etwas spezielles problem: undzwar hab ich nen mail-server (lenny stable mit postfix und dovecot, login über STARTTLS) und nutze ihn mit thunderbird (aktuelle version) und imap.
im wesentlichen funktioniert alles, nur passiert es gelegentlich, dass beim senden einer mail eigentlich eine kopie der nachricht im jeweiligen postfach unter "gesendete objekte" gespeichert werden soll, und dies nicht funktioniert.
fehlermeldung sinngemäss "kann die nachricht nicht nach gesendete objekte kopieren".
die mail geht raus, aber wird nicht unter gesendete objekte gespeichert.
passiert wie gesagt nicht immer, aber gelegentlich.

fehlermeldungen in den logs konnte ich nicht finden.

hat jmd eine idee, woran das liegen könnte?
kann mir jmd vielleicht mal den kommunikationsverlauf zwischen thunderbird und dem server erklären (wie er sein sollte), wenn eine kopie einer gesendeten mail im ordner gesendete objekte abgelegt wird?
das würde mir bei der fehlersuche vielleicht schon sehr helfen!

vielen dank!

colt seavers
Top

User avatar
rudelgurke
Systemtester
Systemtester
Posts: 395
Joined: 2008-03-12 05:36

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by rudelgurke »

Schau mal bei Thunderbird in die Account Einstellungen rein und lege ein IMAP Verzeichnis fest wo gesendete Mails gespeichert werden sollen. Vorher das Verzeichnis entsprechend anlegen.
Wenn es nur bei einigen Mails passiert, Thunderbird speichert Mails die noch nicht gesendet wurden aber der "Compose" etwas länger dauert in "drafts" bis zum eigentlichen Versand und verschiebt die dann ins "Sent" Verzeichnis - soweit funktioniert es hier.

Hilft hoffentlich etwas :)
Top

User avatar
coltseavers
Posts: 182
Joined: 2009-11-04 00:43
Location: NRW

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by coltseavers »

servus,
vielen dank für die antwort!

also das problem tritt nur ab und zu auf.
meine vermutung ist, dass das verschieben in den "gesendete objekte"-ordner mit time-outs oder beschränkten server-ressourcen zu tun haben könnte.

ich habe z.b. einen kunden, der 3 imap-accounts von jeweils 3 PCs aus nutzt, teilweise auch gleichzeitig.

in den erweiterten server-einstellungen jedes einzelnen Thundebird-kontos kann man ja auch die maximale anzahl der "aufrecht erhaltenen Serververbindungen" einstellen. default ist 5.

bei 3x3 accounts komme ich allein für den einen kunden auf theoretisch 45 connections.

können diese/solche settings vllt mit dem problem zusammenhängen, oder bin ich da auf dem holzweg?

mir ist klar: ausprobieren wäre leicht.
aber ich arbeite generell eher ungern nach "try and error", sondern nach "fragen, informieren, lernen und wissen".

vllt weiss ja jmd was zu dieser thematik?

vielen dank vorab!
Top

pout
Posts: 4
Joined: 2011-09-02 23:43

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by pout »

Gabs dafür eine Lösung? Habe auf meinem vServer das selbe Problem.

LG pout
Top

User avatar
coltseavers
Posts: 182
Joined: 2009-11-04 00:43
Location: NRW

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by coltseavers »

Hallo,

die genaue Ursache konnte ich dafür leider nicht finden.

Ich habe bei Dovecot die folgenden Werte leicht angehoben:
login_processes_count = ...
Den Wert hab ich von 3 auf 6 angehoben. (Danach muss Dovecot natürlich einen Neustart bekommen.)

Ich habe das Problem seitdem nicht mehr - aber ob es jetzt wirklich daran lag, kann ich leider nicht mit Sicherheit sagen. Kannst es ja mal versuchen und Dein Ergebnis dann hier bekannt geben.

Gruß,
Colt Seavers
Last edited by coltseavers on 2011-09-03 02:30, edited 1 time in total.
Top

pout
Posts: 4
Joined: 2011-09-02 23:43

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by pout »

Danke für die schnelle Antwort. Hat bei mir nicht geholfen. Es scheint bei mir aber am postfix zu liegen, der ein timeout verursacht. Wenn man den Versand dann Abbricht schreibt Thunderbird eine Fehlermeldung, das ein smtp-Fehler vorliege, sendet die Nachricht aber, jedoch sortiert thunderbird dann die Nachricht dann nicht in gesendet. Interessanterweise nur mit thunderbird. Bei anderen Clients hab ich kein Problem (Android K9-Mail, Roundcube Webmail).
Muss weitersuchen.

LG pout
Top

User avatar
coltseavers
Posts: 182
Joined: 2009-11-04 00:43
Location: NRW

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by coltseavers »

An Postfix kann es glaub ich nicht liegen, denn Postfix hat mit den IMAP-Postfächern gar nichts zu tun. Das Problem liegt ja, wie Du schon sagtest, nicht etwa beim eigentlichen Versand der Mail (das geht natürlich über Postfix), sondern beim Einlagern der E-Mail in den entsprechenden IMAP-Ordner. Hier findet eine Kommunikation per IMAP-Protokoll zwischen Thunderbird und Dovecot statt. Deshalb kann es durchaus sein, dass es bei einem Mail-Client problemlos geht, bei nem anderen aber nicht.

Eine Stellschraube, die es bei Thunderbird wohl noch gibt ist unter "Extras" -> "Konteneinstellungen" -> "E-Mail-Konto XY" -> "Server-Einstellungen" -> "Erweitert" -> "Maximale Anzahl der aufrecht erhaltenen Serververbindungen".
Ich hab bei mir diese Einstellung pro Konto von 5 auf 3 reduziert - vielleicht lassen sich dadurch ja mögliche Timeouts von ungenutzten Verbindungen vermeiden. Kannst mit dieser Einstellung ja auch mal experimentieren. Solltest nach Veränderung des Wertes aber Thunderbird neu starten, damit er auch angewendet wird.

Solltest Du die endgültige Lösung finden, wärs klasse, wenn Du die Lösung hier posten würdest.
Top

pout
Posts: 4
Joined: 2011-09-02 23:43

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by pout »

Hallo,

bei mir scheint es gelöst zu sein. Der Versand von Nachrichten ohne ANhang hatte funktioniert. Daraufhin wurde ich mit Google fündig. Es ist der lokale Virenscanner. Auf einem Rechner läuft Avast. Da habe ich "Scannen ausgehender Mails" abgedreht. Am anderen bei Mircrosoft Essential bei "Ausgeschlossene Dateien und Speicherorte das Verzeichnis des Thunderbird-Profils angegeben.
Nun geht es von beiden Rechner aus. Ich hoffe es hilft auch dir.

LG pout
Top

pout
Posts: 4
Joined: 2011-09-02 23:43

Re: postfix + dovecot + imap = problem bei gesendeten opjekt

Post by pout »

Hallo,

leider zu früh gefreut. Nach wie vor timeouts.
Ich suche weiter.

LG pout
Top