Libvirt mit KVM - öfters read only filesystem?

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
monotek
Posts: 64
Joined: 2003-08-26 23:23
Location: Dresden

Libvirt mit KVM - öfters read only filesystem?

Post by monotek » 2010-10-21 13:03

Ich betreibe einen Ubuntu 10.04 Server, auf dem mittels Libvirt und KVM mehrere virtuelle Linux (wieder Ubuntu 10.04) und Windows Maschinen laufen.

Seit einiger Zeit habe ich nun das Problem, dass ab und zu bei 3 der virtuellen Linux Server die Festplatte (es ist eine richtige Festplatte kein Image) Read Only ist.

Ich muss die virtuellen Maschinen dann runter fahren und dann nen fsck auf den Platten machen, bei denen ich dann immer einige Fehler beheben muss.

Die Festplatten selbst zeigen aber komischer Weise keinerlei Smart Probleme an. Mich würde auch wundern, wenn es wirklich 3 Festplatten gleichzeitig erwischt und da ein Hardwaredefekt vorliegt. Die Platten werden nicht sonderlich beansprucht und sind durchgängig gut gekühlt.

Auch der Wechsel auf Virtio Zugriff auf die Platten brachte keine Besserung.

Meine Vermutung war nun, dass der RAM des KVM Host nen schaden hat, und dadurch falsch auf die Festplatten geschrieben wird. Ein Memtest86+ übers Wochenende konnte dies jedoch nicht bestätigen.

Bei den Windowssystemen sind derartige Fehler auch noch nicht aufgefallen.

Hat schon mal jemand ähnliche Erfahrungen gemacht oder hat ne Idee, wo ich hier noch nach dem Problem suchen kann?

Danke im Voraus :-)

monotek
Posts: 64
Joined: 2003-08-26 23:23
Location: Dresden

Re: Libvirt mit KVM - öfters read only filesystem?

Post by monotek » 2010-10-21 13:31

Es kommt inzwischen bei allen Platten EXT4 zum Einsatz. Vorher EXT3. Da gabs das gleiche Problem.

Es sind physische Festplatten. Die nun virtuellen Server liefen vorher auf eigener physicher Hardware. Habe die Festplatten also einfach aus den alten Servern ausgebaut und dann in den KVM Host gesteckt.

Ein Raid verwende ich bei den Platten derzeit nicht. Ist ein standard ACPI SATA Controller auf nem Core I7 Board. Ich werde mal schauen, ob ich testweise nen extra PCIe Controller verwenden kann.
Last edited by monotek on 2010-10-21 13:33, edited 2 times in total.

monotek
Posts: 64
Joined: 2003-08-26 23:23
Location: Dresden

Re: Libvirt mit KVM - öfters read only filesystem?

Post by monotek » 2010-11-05 16:23

Ein separater Controller hat das Problem nicht gelöst.

Ich schreib das OS jetzt in ein Image und schau was sich tut, wenn es über das Image in KVM geladen wird...

monotek
Posts: 64
Joined: 2003-08-26 23:23
Location: Dresden

Re: Libvirt mit KVM - öfters read only filesystem?

Post by monotek » 2010-11-24 16:58

Eventuell liegt das Problem an folgendem Bug:

https://bugs.launchpad.net/ubuntu/maver ... bug/574665

Ich werds mal mit den Backports von folgendem Link probieren:

https://launchpad.net/~nutznboltz/+arch ... ibvirt-lts