QMail Daemontools(?) Problem

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
docbru
Posts: 12
Joined: 2002-12-02 12:05

QMail Daemontools(?) Problem

Post by docbru » 2002-12-10 15:33

Hallo,

mein /var/log/messages wird zugespammt mit

Dec 10 15:17:58 p15110707 init: Id "SV" respawning too fast: disabled for 5 minutes

Ich habe bereits hier im Forum und bei google gesucht und es ist mir nun auch einigermassen klar was dieser Fehler bedeutet, vermutlich versucht deamontools irgendwas anzustarten die ganze Zeit.... Leider ist mir nicht ganz klar wo ich suchen kann was da schiefgeht

Im Verzeichnis /var/qmail/supervise/ liegen 3 Unterverzeichnisse qmail-pop3d, qmail-send und qmail-smtpd. In /etc/service gibt es Links auf diese.

Alle 3 Dienste laufen auch.

Jemand ne Idee?

Grüße
Bruno

scythe42
RSAC
Posts: 154
Joined: 2002-10-14 18:30
Location: Internet

Re: QMail Daemontools(?) Problem

Post by scythe42 » 2002-12-10 16:50

Der Eintrag mit SV in der /etc/inittab stimm nicht. Warscheinlich falsche Pfadangabe zu svscanboot.

Wie sieht denn der SV Eintrag in der /etc/inittab bei dir aus?
In welchem Verzeichnis leigt svscanboot bei dir?

ggf. anpassen und ein init -q machen.

docbru
Posts: 12
Joined: 2002-12-02 12:05

Re: QMail Daemontools(?) Problem

Post by docbru » 2002-12-10 18:47

thanx! da stand /service statt /etc/service

nun passts :)

alexn
Posts: 36
Joined: 2002-11-28 15:56

Re: QMail Daemontools(?) Problem

Post by alexn » 2003-03-15 22:36

Hi!

Entschuldigt, dass ich das Thema auch nochmal aufmache. Ich habe genau wie Olfi erwartet a) erst bei Google & Co. gesucht und dann hier im Forum - dies ist der einzige Thread, wo ich meine Frage passend anschließen könnte:

Ich habe die oberen Ratschläge befolgt und mein Verzeichnis ist /command/svscanboot . Dieses ist auch richtig in der Inittab eingetragen.

Hintergrund ist, dass wir den Server im Zuge eines Umzuges abklemmen mußten und beim Neustart startete weder svscanboot noch readproctitle. Derjenige, der damals QMail installiert hat, ist mittlerweile nicht mehr dabei und riet mir nur, das Ganze mal von Hand zu starten - leider seit 2 Wochen ohne Erfolg.

Wäre schön, wenn irgendjemand auch nur ein klitzekleines Indiz hätte, woran es liegt.

Danke, Alex

alexn
Posts: 36
Joined: 2002-11-28 15:56

Re: QMail Daemontools(?) Problem

Post by alexn » 2003-04-21 12:19

Hi,

Nachdem ich mir mit verschiedenen Admins schon den kopf über mein Problem zerbrochen habe, dachte ich mir, dass ich den Post nochmal nach oben schiebe. Vielleicht kann mir jemand mttlerweile helfen, da ich so einfache Fehler wie Rechte- und Pfadprobleme ausschliessen kann.

Danke, Alex

alexn
Posts: 36
Joined: 2002-11-28 15:56

Re: QMail Daemontools(?) Problem

Post by alexn » 2003-04-23 21:05

hat sich nun auch bei mir erledigt. /command existierte zwar, aber das /package war gelöscht und die Dateien konnten deshalb nicht in ihrem Kontext ausgeführt werden.
Aber super, dass ich in den letzten 2 Monaten feststellen mußte, dass die Meldung "Id "SV" respawning too fast: disabled for 5 minutes
" so ziemlich alles bedeuten kann. :x

wirsing
RSAC
Posts: 611
Joined: 2002-11-20 21:32
Location: Vaihingen und Karlsruhe

Re: QMail Daemontools(?) Problem

Post by wirsing » 2003-04-24 15:00

Zunächst heißt es nur, dass sich das Programm immer schnell wieder beendet, aber das kann eben verschiedene Ursachen haben.