Apache default Problem bei IP Eingabe

Apache, Lighttpd, nginx, Cherokee
lokitoki
Posts: 11
Joined: 2008-02-17 12:58

Apache default Problem bei IP Eingabe

Post by lokitoki » 2010-05-10 18:51

Hallo, ich hab ein paar Domains mit folgendem Format im Apache2 erstellt

<VirtualHost Server.IP.Adresse:80>
SuexecUserGroup "#1009" "#1004"
ServerName xyzdomain.de
etc.
</VirtualHost>

Diese sind jeweils als Dateien in sites-available/enabled abgelegt und funktionieren wie gewollt.

Wie kann ich trotzdem noch auf /var/www zugreifen. Wenn ich http://Server.IP.Adresse/ eingebe erscheint ein not found obwohl die standard "it works" index.html in var/www hinterlegt ist. Im default access log steht nichts.
Gäbe es außerdem eine Möglichkeit bei fehlendem VirtualHost Eintrag ebenfalls an die default zu verweisen?

meine default Konfiguration schaut folgendermaßen aus:

NameVirtualHost *
<VirtualHost *>
ServerName Server.IP.Adresse
DocumentRoot /var/www/

ErrorLog /var/log/apache2/error.log
LogLevel warn
CustomLog /var/log/apache2/access.log combined
ServerSignature On

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

</VirtualHost>

in meiner apache2.conf hab ich am Ende folgenden Eintrag
Include /etc/apache2/sites-enabled/
NameVirtualHost Server.IP.Adresse:80
NameVirtualHost Server.IP.Adresse:443
Alles andere ist default.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache default Problem bei IP Eingabe

Post by Joe User » 2010-05-10 18:58

lokitoki wrote:NameVirtualHost Server.IP.Adresse:80
NameVirtualHost Server.IP.Adresse:443

Die müssen raus und <VirtualHost IP:PORT> muss <VirtualHost *> sein, dann sollte es theoretisch wie gewünscht funktionieren.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

lokitoki
Posts: 11
Joined: 2008-02-17 12:58

Re: Apache default Problem bei IP Eingabe

Post by lokitoki » 2010-05-10 20:41

VirtualHost IP:PORT zu VirtualHost * müsst ich dann aber bei allen domains einstellen.

Ich frag mich warum der mir mein www-data nicht anzeigen will und warum da die logdateien keine Einträge haben.
bei einem anderen server hab ich in der default nur

NameVirtualHost 78.46.xxx.xx1:80
NameVirtualHost 78.46.xxx.xx2:80


<VirtualHost 78.46.xxx.xx1>
RedirectPermanent / "http://www.domainy.de/"
</VirtualHost>
<VirtualHost 78.46.xxx.xx2>
RedirectPermanent / "http://www.domainx.de/"
</VirtualHost>

das funktioniert auch wunderbar. Die virtuellen Domains hab ich da gleich konfiguriert wie oben.

lokitoki
Posts: 11
Joined: 2008-02-17 12:58

Re: Apache default Problem bei IP Eingabe

Post by lokitoki » 2010-05-10 20:49

Ich denke ich hab den Fehler. Eine Domain hatte ein 0 an erster Stelle des Dateinamens in sites-available. Diese wird dann wohl als erste angesprochen.