Postfix hinter NAT

tsaenger
Posts: 408
Joined: 2003-08-13 01:14

Postfix hinter NAT

Post by tsaenger »

Hallo,

ich versuche gerade meinen Mailserver der über NAT (Port Forwarding ) an meine öffentliche IP angebunden ist so zu konfigurieren, das er Mails annimmt und zustellt. Das Abrufen von Mail funktioniert ohne Probleme.

Folgende Situation:
Server auf dem NAT konfiguriert ist:
IP1: 111.111.111.111 sowie
IP2: 222.222.222.222

Server auf dem Postfix installiert is: 192.168.0.4
Nun habe ich mittels iptables eine Forwarding-regel erstellt, die alle Pakete die auf 222.222.222.222:25 , 110 53,587 und 80 ankommen auf die 192.168.0.4 geleiche Ports weiterleitet.

über

Code: Select all

 telnet 222.222.222.222 587
erhalte ich auch eine Rückmeldung vom Server. Sobald ich aber MAIL FROM: name@domain.de eingebe, bekomme ich die Meldung "Bad sender address syntax"
Hier meine komplette Kommunikation:

Code: Select all

220 domain.de ESMTP Postfix (Debian/GNU)
HELO domain.de
250 domain.de
MAIL FROM:name@domain.de
501 5.1.7 Bad sender address syntax


meine main.conf schaut so aus:

Code: Select all

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h
proxy_interfaces = 222.222.222.222
myhostname =tsaenger.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = domadin.de, localhost
relayhost =
mynetworks = 127.0.0.0/8,192.168.0.4
smtp_bind_address = 222.222.222.222
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
#smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_non_fqdn_hostname, reject_unknown_recipient_domain, reject_invalid_hostname, reject_unknown_hostname, reject_unknown_sender_domain, check_policy_service inet:127.0.0.1:60000, reject_unauth_destination
smtpd_helo_required = yes
disable_vrfy_command = yes
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_tls_clientcerts, permit_mynetworks,check_sender_mx_access hash:/etc/postfix/mx_access, reject_non_fqdn_sender, reject_unknown_client, reject_non_fqdn_recipient, reject_non_fqdn_hostname, reject_unknown_recipient_domain, reject_invalid_hostname,reject_unauth_pipelining, reject_non_fqdn_recipient, reject_unknown_recipient_domain, check_policy_service inet:127.0.0.1:60000, reject_unauth_destination, check_sender_access hash:/etc/postfix/sender_checks
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
virtual_mailbox_limit = 0
smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_pipelining
smtpd_sender_restrictions =
smtpd_client_restrictions =
smtpd_helo_required = yes
message_size_limit =0
strict_rfc821_envelopes = yes
disable_vrfy_command = yes
home_mailbox = Maildir/
minimal_backoff_time = 300queue_run_delay = 300
mailbox_command = /usr/bin/procmail -a "EXTENSION" DEFAULT=$HOME/Maildir/ MAILDIR=$HOME/Maildir
### CONFIXX POSTFIX ENTRY ###
virtual_maps = hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
### /CONFIXX POSTFIX ENTRY ###
inet_protocols = all


Hat jemand ne Idee wo da mein fehler liegt? Meine Recherchen ergaben, das ich doch eigentlich nur den Part: proxy_interfaces ergänzen muss oder?

Das Log zeigt mir nur eine Verbindung an, die aber noch ein bestimmten Zeit wieder geschlossen wird.

Gruß und Danke

Tobias
Top

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Postfix hinter NAT

Post by EdRoxter »

Probier mal EHLO statt HELO und

Code: Select all

MAIL FROM: <test@test.de>
.

Das sieht nicht nach einem NAT-, sondern eher nach einem Konfigurationsproblem aus. Was sagen obendrein die Logs?
Top

tsaenger
Posts: 408
Joined: 2003-08-13 01:14

Re: Postfix hinter NAT

Post by tsaenger »

Hi,

stimmt. Ich hatte einen Fehler im Postgrey.
Habe ihn behoben und siehe da es funktioniert.

Vielen Dank für deine Hilfe.

Tobias
Top