Virtual Host: Log wird falsch geschrieben

Apache, Lighttpd, nginx, Cherokee
amiga1200
Posts: 203
Joined: 2007-01-13 19:58

Virtual Host: Log wird falsch geschrieben

Post by amiga1200 » 2009-10-20 14:56

Ich habe auf meinen Server verschiedene Domains mit Virtual Host eingerichtet.
jede Domaine hat eine eigne error_log und access_log Datei.
Bei 5 funktioniert das alles, aber eine Domain hier als Test.de bezeichnet spinnt

Die logs landen nicht in
CustomLog /var/log/httpd/test/access_log combined
sondern in
/var/log/httpd/soso/access_log

Code: Select all

<VirtualHost *>
        ServerName test.de
        ServerAlias *.test1.de test2.de test3.de 
        ServerAdmin service@test.de
        DocumentRoot /webserver/httpd/firma/test

        ErrorLog /var/log/httpd/test/error_log
        CustomLog /var/log/httpd/test/access_log combined
        ScriptAlias /cgi-bin/ /webserver/httpd/test/cgi-bin/
        <Directory /webserver/httpd/test/cgi-bin>
                AllowOverride   none
                OPTIONS ExecCGI
                SetHandler cgi-script
        </Directory>
</VirtualHost>

Hat jemand eine Idee, woran es liegt?

/etc/init.d/apache restart habe ich gemacht.
entferne ich ServerName, wird die Domain nicht mehr gefunden,also wird die Datei bearbeitet,
aber warum wertet Apache CustomLog falsch aus?

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Virtual Host: Log wird falsch geschrieben

Post by EdRoxter » 2009-10-22 13:40

Was genau ist das "soso" in dem Pfad, in dem fälschlicherweise geschrieben wird?

amiga1200
Posts: 203
Joined: 2007-01-13 19:58

Re: Virtual Host: Log wird falsch geschrieben

Post by amiga1200 » 2009-10-22 15:08

EdRoxter wrote:Was genau ist das "soso" in dem Pfad, in dem fälschlicherweise geschrieben wird?


sos ist ein normaler Kunde

oder auch
var/log/httpd/kunde1/access_log
var/log/httpd/kunde2/access_log
var/log/httpd/kunde3/access_log
var/log/httpd/kunde4/access_log

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Virtual Host: Log wird falsch geschrieben

Post by EdRoxter » 2009-10-22 15:13

Existiert das Verzeichnis /var/log/httpd/test/ und ist für root einseh- und schreibbar (chmod 0770)?

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Virtual Host: Log wird falsch geschrieben

Post by daemotron » 2009-10-22 17:33

EdRoxter wrote:Existiert das Verzeichnis /var/log/httpd/test/ und ist für root einseh- und schreibbar (chmod 0770)?

Wenn es nicht exisitiert oder nicht schreibbar ist, verweigert Apache normalerweise den Start mit einem entsprechenden Hinweis im Error-Log.
“Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying 'End-of-the-World Switch. PLEASE DO NOT TOUCH', the paint wouldn't even have time to dry.” — Terry Pratchett, Thief of Time

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Virtual Host: Log wird falsch geschrieben

Post by EdRoxter » 2009-10-22 19:08

Nun ja, bezieht man die Mondphase und den Aszendenten des Orion mit ein, könnte es ja auch sein, dass er quasi als "Fallback" in das im letzten VHost definierte CustomLog schreibt. Oder es ist ein generischer CustomLog außerhalb der VHost-Konfiguration eingestellt..

Aber das sind nur Schüsse ins Blaue, warten wir mal die Antwort des Threaderstellers ab.

markuman
Posts: 38
Joined: 2008-01-23 13:27

Re: Virtual Host: Log wird falsch geschrieben

Post by markuman » 2009-10-22 20:33

oder die Vhost existiert in sites-enable und sites-available ...und im available stehts noch auf soso...oder oder oder :)

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: Virtual Host: Log wird falsch geschrieben

Post by EdRoxter » 2009-10-22 21:46

markuman wrote:oder die Vhost existiert in sites-enable und sites-available

..was bei einem gut konfigurierten Apache ja nicht der Fall sein sollte, weil in sites-enabled nur Symlinks auf die Konfigurationsdateien in sites-available vorhanden sein sollten. Und sites-available sollte gar nicht geparsed werden.