Rootserver Port Timeout IceCast/Shoutcast und Webinterface

Serverdienste ohne eigene Kategorie
Anonymous

Rootserver Port Timeout IceCast/Shoutcast und Webinterface

Post by Anonymous »

Hallo,

ich bin neu hier und möchte als erstes ein Lob aussprechen für das Klasse Forum hier. Ich hoffe hier bin ich richtig und ihr könnt evtl. auch mir weiterhelfen.

Mein Problem ist ein bisschen komplexer aber vielleicht auch doch einfacher als was ich denke. Versuche bestmöglichst mein Problem zu schildern. Wenn Informationen fehlen bitte ich drum zu fragen, da ich in Sachen RootServer nicht ganz das helle Köpfchen bin. Für normal wird mein Server von einem Kollegen gemanaged, nur ist dieser zunächst für einige Zeit leider nicht erreichbar, mein Problem muss aber gelöst werden.

Folgendes.
Auf meinem RootServer wird ein Webradio betrieben.
Dieses läuft über Shoutcast oder wahlweise Icecast, wie ihr wollt, denn das Problem besteht bei beidem.

Als Beispiel nehme ich nun mal den IceCast-Server.
Der IceCast-Server läuft auf Port 8000.
Eine reine Audioverbindung stellt kein Problem dar und läuft reibungslos. Mein Problem tritt auf sobald ich oder wer anderes mit Video streamt. Dieses wird gehändelt durch das NSV Format.
Jetzt kommts. Sobald ich, wer anderes, ein Hörer wie auch immer zu dem Videostream auf den Port 8000 connected, kommt er zwar drauf, hat auch keinerlei Probleme mit dem Empfang, aber der nächste dafür.
Bis ein weiterer Connect zum nächsten Hörer vollzogen werden kann, dauert es eine Weile, weil der Server / Port 8000 für einige Sekunden nicht erreichbar ist.
Auf http://ip:8000/ läuft ein Webinterface, dieses endet im Firefox mit der Meldung "Netzwerküberschreitung" bzw. "Timeout"
Dieses betrifft einen Shoutcastserver oder wahlweise Icecastserver, egal welcher Port. Daher schließe ich falsche Konfigurationen am Shout-/Icecastserver aus, zumal man dort wirklich nichts verkehrt machen kann. Mir scheint es fast, dass eine Anfrage nach der anderen abgearbeitet wird, erst wenn ein erfolgreicher Verbindungsversuch per Player auf den Stream erfolgt ist, dass dann der Port für weitere Anfragen zur verfügung steht. Ganz komisch halt und sicher nicht normal!
Hier noch einige Informationen:

Code: Select all

cat /proc/version
Linux version 2.6.28 (IP ENTFERNT) (gcc version 4.3.2 (Debian 4.3.2-1) ) #3 SMP Sat Jan 17 15:13:22 CET 2009
Hosting: webtropia (fastIT)
sysCP

Naja, für mehr Informationen bin ich wohl leider noch nicht in der Lage, da mein Wissen erst jetzt wirklich auf die Probe gestellt wird.
ich hoffe ihr könnt damit was anfangen und mir bitte bitte weiterhelfen.
Wenn mehr Informationen benötigt werden, bitte ich Euch, mir diese zu stellen evtl. mit Weg, wie genau ich diese erfahre.

Ps. In den Logfiles habe ich nichts ersichtliches zu diesem Problem finden können.
Pps. Die Homepage die auf dem gleichen Server läuft, wird nicht beeinflusst von diesem Problem und ist immer erreichbar. Es betrifft lediglich nur den Port, egal welcher genutzt wird, für den Streamingserver.

Mfg. ParaDox